Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 33
  1. jrjr488's Avatar
    Member

    Posts
    40 Posts
       #1  
    My 920 form the MS developer conference went into a reset and is now stuck at the Nokia screen. I've tried a number of things without success. I can get to the lightening bolt/cog screen by soft resetting and then holding volume up but it's frozen there as well. Anyone have any suggestion for me? Thanks for any help in advance.
  2. hfcas's Avatar
    Member

    Posts
    56 Posts
    #2  
    Same thing happened to me. I flashed it with the latest firmware for att since there is no where I can find the exact firmware for dev version 920,which is rm-820-nam-Canada -246. By the way, I tried Rogers firmware first but failed. Nokia care suite says it's incompatible with the device.
  3. jrjr488's Avatar
    Member

    Posts
    40 Posts
       #3  
    Quote Originally Posted by hfcas View Post
    Same thing happened to me. I flashed it with the latest firmware for att since there is no where I can find the exact firmware for dev version 920,which is rm-820-nam-Canada -246. By the way, I tried Rogers firmware first but failed. Nokia care suite says it's incompatible with the device.
    The problem is I'm with t mobile and I'll lose data if I flash the ATT software. I tried to flash the Rogers firmware and it failed. Any other ideas? Thanks for your help.
  4. andraeseus's Avatar
    Member

    Posts
    93 Posts
    #4  
    WOW. first let me start by saying sorry. I can only imagine the fustration. 2. I can not help. I am totally clueless on options for this device. Three if you get it fixed please let us know in case one day I find myself in the same position. I am on TMO also and I hope I don't run in to this problem. So far the volume rocker and lock button pressed for about 10 seconds has worked every time the phone froze or got stuck. I would go ape kaka if that didn't work one day because i paid so much for this thing. Maybe nokia can help with getting a copy of the firmware. Good luck. Oh yeah, can you tell me what you were doing when it happened so I know NOT to do that:
  5. hfcas's Avatar
    Member

    Posts
    56 Posts
    #5  
    Just be careful about resetting. It could brick your phone.
  6. Dave Blake's Avatar
    Mod and Ambassador Team Emeritus

    Posts
    5,662 Posts
    Global Posts
    7,164 Global Posts
    #6  
    Try power down, then on power up hold Volume down/power and camera at the same time.
  7. jrjr488's Avatar
    Member

    Posts
    40 Posts
       #7  
    Quote Originally Posted by Dave Blake View Post
    Try power down, then on power up hold Volume down/power and camera at the same time.
    Thanks but it won't turn off. The 3 finger reset simply brings me back to the Nokia screen. The battery died in the night I'm going to recharge and start allover.
  8. hfcas's Avatar
    Member

    Posts
    56 Posts
    #8  
    Dude,obviously it's bricked. You need to flash it.
    Quote Originally Posted by jrjr488 View Post
    Thanks but it won't turn off. The 3 finger reset simply brings me back to the Nokia screen. The battery died in the night I'm going to recharge and start allover.
  9. pankaj981's Avatar
    Member

    Posts
    2,326 Posts
    #9  
    Quote Originally Posted by hfcas View Post
    Dude,obviously it's bricked. You need to flash it.
    Agreed, its bricked, do a dead flash using navifirm and it should work
  10. jrjr488's Avatar
    Member

    Posts
    40 Posts
       #10  
    Quote Originally Posted by hfcas View Post
    Dude,obviously it's bricked. You need to flash it.
    Sure but flash it with what firmware? if I flash ATT its locked and I won't have data. I'm a t mobile customer.
  11. pankaj981's Avatar
    Member

    Posts
    2,326 Posts
    #11  
    Quote Originally Posted by jrjr488 View Post
    Sure but flash it with what firmware? if I flash ATT its locked and I won't have data. I'm a t mobile customer.
    Can u explain what are you losing here apart from the phone contents? Also does the device say ATT on it anywhere? If not can you tell what Model is it? RM-XXX?
  12. jrjr488's Avatar
    Member

    Posts
    40 Posts
       #12  
    Quote Originally Posted by pankaj981 View Post
    Can u explain what are you losing here apart from the phone contents? Also does the device say ATT on it anywhere? If not can you tell what Model is it? RM-XXX?
    RM-820. It's not a ATT model. I could flash ATT but I am on t mobile
  13. pankaj981's Avatar
    Member

    Posts
    2,326 Posts
    #13  
    Quote Originally Posted by jrjr488 View Post
    RM-820. It's not a ATT model. I could flash ATT but I am on t mobile
    Flashing a wrong firmware will brick your phone, not sim lock it as you are thinking. ATT firmware is junk, try flashing the unbranded firmware from Navifirm
  14. jrjr488's Avatar
    Member

    Posts
    40 Posts
       #14  
    Quote Originally Posted by pankaj981 View Post
    Flashing a wrong firmware will brick your phone, not sim lock it as you are thinking. ATT firmware is junk, try flashing the unbranded firmware from Navifirm
    Thanks, do you know which firmware is the unbranded one for an rm-820?
  15. hfcas's Avatar
    Member

    Posts
    56 Posts
    #15  
    Quote Originally Posted by jrjr488 View Post
    Thanks, do you know which firmware is the unbranded one for an rm-820?
    Just got a reply from Stephen Elop. He said he'll ask his team to assist. Hopefully we can get a copy of the firmware of dev version. will keep you updated.
  16. hfcas's Avatar
    Member

    Posts
    56 Posts
    #16  
    Quote Originally Posted by pankaj981 View Post
    Flashing a wrong firmware will brick your phone, not sim lock it as you are thinking. ATT firmware is junk, try flashing the unbranded firmware from Navifirm
    As I can tell, currently there's no unbranded firmware for RM-820. I guess we can't flash it with RM-821 firmware, right?
  17. jrjr488's Avatar
    Member

    Posts
    40 Posts
       #17  
    Quote Originally Posted by hfcas View Post
    Just got a reply from Stephen Elop. He said he'll ask his team to assist. Hopefully we can get a copy of the firmware of dev version. will keep you updated.
    Thanks, I'm in contact with nokia care by email and waiting a response
  18. pankaj981's Avatar
    Member

    Posts
    2,326 Posts
    #18  
    Quote Originally Posted by hfcas View Post
    As I can tell, currently there's no unbranded firmware for RM-820. I guess we can't flash it with RM-821 firmware, right?
    You can try the Rogers firmware which I am currently looking at on Navifirm, those are usually unbranded.
  19. jrjr488's Avatar
    Member

    Posts
    40 Posts
       #19  
    Quote Originally Posted by pankaj981 View Post
    You can try the Rogers firmware which I am currently looking at on Navifirm, those are usually unbranded.
    Thanks. I tried that earlier and it didn't work. I appreciate you trying to help.
  20. #20  
    Quote Originally Posted by jrjr488 View Post
    Thanks. I tried that earlier and it didn't work. I appreciate you trying to help.
    Any solutions to this?
  21. jrjr488's Avatar
    Member

    Posts
    40 Posts
       #21  
    Quote Originally Posted by DyeLongJustice View Post
    Any solutions to this?
    None that i found. I'm waiting for a new phone from nokia
  22. power5's Avatar
    Member

    Posts
    1,208 Posts
    Global Posts
    1,448 Global Posts
    #22  
    Quote Originally Posted by pankaj981 View Post
    Can u explain what are you losing here apart from the phone contents? Also does the device say ATT on it anywhere? If not can you tell what Model is it? RM-XXX?
    Data Service runs on a different frequency than the cell. If he flashes to ATT firmware he will not have the frequency needed for data connections. So, for internet he would need to be in wifi area.
  23. #23  
    Quote Originally Posted by jrjr488 View Post
    None that i found. I'm waiting for a new phone from nokia
    Wow, that sucks. I have a Dev Lumia 920 as well, and so far nothing has happened with it. Of course, I've barely been using it, bc I'm afraid it will brick and I'll be out of a phone. I can't believe they won't release the Dev firmware (unless it unlocks an ATT phone or something). Super annoying!
  24. yukit's Avatar
    Member

    Posts
    15 Posts
    #24  
    Did anyone with the Build version of the phone ever get the original firmware?

    My Build phone has been flaky for the last few weeks, I bricked my phone by a hard reset (against better judgement)

    I managed to get my phone working with the AT&T firmware despite I am using a T-mobile SIM.

    All of restore of Nokia apps from SkyDrive is failing. I don't think I can get the AT&T apps to work either since I am not a member.

    Let me know if someone managed to get the original firmware (or dev firmware with the working reset function)

    TIA
  25. yukit's Avatar
    Member

    Posts
    15 Posts
    #25  
    For the last couple of weeks I have been messing around with my phone; flashing with different versions of firmware, resetting from software & hardware.

    Here is my findings:
    • it is pretty easy to brick pre-Portico version of this phone. Since Portico does not seem to be available for the BUILD phone, you are likely to get stuck with "reset your phone" option in the About Settings.
    • just because the phone is stuck in the spinning gear screen for a long time (more than an hour) does not mean the phone is completely bricked. I have seen posts where removing the SIM card or hard reset through button combo fixed the phone. In retrospect, I should have read through the posts to try this before I slammed the ATT firmware on the phone.
    • The original BUILD firmware is nowhere to be found. Some people have managed to get a replacement BUILD phone, but it took like 2 months to get a new phone back. Emailing the Nokia CEO may help.
    • There are tools like NaviFarm & NCS to flash firmware back on the phone to unbrick it. Thanks to itxjobe & XDA-dev.

    I have tried both AT&T & Rogers firmware. I even tried RM-821 dev firmware. I eventually settled on the Rogers Portico version. The version I have is indeed branded with Rogers, but I figured it is the closest version to the BUILD version (canada_200 vs canada_246) I am hoping I would get GDR2 update with this firmware, if not I can look for another version.

    Please correct any mis-info.
    TIA
Page 1 of 2 12 LastLast

Similar Threads

  1. Developer device
    By 3DPiper in forum Windows Phone 7
    Replies: 4
    Last Post: 07-26-2011, 03:16 PM

Posting Permissions