Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. JordanDelapp's Avatar
    Member

    Posts
    2 Posts
       #1  
    I got my white Nokia lumia 920 Sunday and have had no problems out of it......until yesterday. There was an update available yesterday so I tried to update the phone. It had over 50% battery life left and I even placed the Phone on the charger tO update. When I checked on my phone it was completely dead after 10 minutes. I tried charging it but it would not come on after 3 hours of charging. I tried a hard reset and when I did the cog wheels showed up, they would spin for a minute then a frowning emoticon would pop up on my screen and nothing else would happen. What went wrong? I liked the phone alot and I am having it replaced. I would like to know what happened so I can keep it from happening again
  2. Beltelmel's Avatar
    Member

    Posts
    87 Posts
    Global Posts
    186 Global Posts
    #2  
    Can't tell you what happened but can tell you that on a couple of occasions when my phone battery died, it took a long time (as long as 3 hours) before it would come back to life. You would think that they would make it so that the phone could be used in a few minutes after being plugged in as long as it remained plugged in....pray we never have to make an emergency call during that time.
  3. rdubmu's Avatar
    Member

    Posts
    2,879 Posts
    Global Posts
    3,164 Global Posts
    #3  
    Plug it in and press the power button and volume down at the same time for 5-10 seconds
    Sent from my RM-820_nam_att_100 using Board Express
  4. JordanDelapp's Avatar
    Member

    Posts
    2 Posts
       #4  
    Quote Originally Posted by rdubmu View Post
    Plug it in and press the power button and volume down at the same time for 5-10 seconds
    Sent from my RM-820_nam_att_100 using Board Express
    I tried that and it just went back the frown emoticon in the middle of the screen

Similar Threads

  1. What happened to the Podcast?
    By mobilejk in forum WindowsCentral.com - Site News, Feedback, Help
    Replies: 3
    Last Post: 01-24-2011, 08:53 AM

Posting Permissions