1. Darren Smith's Avatar
    I have Monster Purity Headphones wh-930
    Does anyone know if these are the right headphones for the 920 I hooked it to the phone and media controls dont work neither does the in-line mic and when i go to accessories the headphones dont show up it plays music fine just would like to get everything else working on it called nokia and they told me just to send it back where i got them from of course this was a gift for christmas and i dont have a proof of purchase.

    FYI...I called monster and all they did was direct me to nokia
    david90531 likes this.
    12-26-2012 10:36 AM
  2. jmerrey's Avatar
    Are you using the controller that came with the headset, or a different one? If you are using the one that came with the headset and it's not working, I would exchange the headset, as it sounds like you have a defective one.

    I'm not sure what the accessories area is in the settings of the phone. When connect my purity headphones, they don't show up there.
    12-26-2012 11:01 AM
  3. Darren Smith's Avatar
    in the settings if you scroll down on the 920 right above Nokia account there is a setting that say acessories....all that came with the heaphones were 2 tangle free cables and the headphones themselves 153752994.jpg
    12-26-2012 11:11 AM
  4. david90531's Avatar
    I have Monster Purity Headphones wh-930
    Does anyone know if these are the right headphones for the 920 I hooked it to the phone and media controls dont work neither does the in-line mic and when i go to accessories the headphones dont show up it plays music fine just would like to get everything else working on it called nokia and they told me just to send it back where i got them from of course this was a gift for christmas and i dont have a proof of purchase.

    FYI...I called monster and all they did was direct me to nokia
    It should work if the one you got was the On-Ear one, because I just got one two days ago and the controls work perfectly, which is the only reason I got these headphones over other cheaper but better options (sound-wise), because it is fully compatible with WP.
    So yeah if the controls don't work get a replacement for sure. Where did you get it from?
    12-26-2012 11:13 AM
  5. david90531's Avatar
    in the settings if you scroll down on the 920 right above Nokia account there is a setting that say acessories....all that came with the heaphones were 2 tangle free cables and the headphones themselves Click image for larger version. 

Name:	153752994.jpg 
Views:	132 
Size:	17.7 KB 
ID:	25564
    ok so yeah that's exactly the same one. you shouldn't have to do any set ups even, it worked as soon as I plugged it in.
    12-26-2012 11:14 AM
  6. Darren Smith's Avatar
    yeah i got them for christmas i think my brother got them from amazon
    is there a retail store that sells these that i dont have to order them online i checked best buy and they didnt sell them
    12-26-2012 11:20 AM
  7. david90531's Avatar
    yeah i got them for christmas i think my brother got them from amazon
    is there a retail store that sells these that i dont have to order them online i checked best buy and they didnt sell them
    I bought them from MS Store. I don't know where you're at so I'm not sure..
    12-26-2012 11:27 AM
  8. Darren Smith's Avatar
    bout 2 hrs from here :(
    12-26-2012 01:32 PM
  9. MSkulker's Avatar
    AT&T stores carry them.
    12-26-2012 01:54 PM
  10. Darren Smith's Avatar
    i will check thanks
    david90531 likes this.
    12-26-2012 08:39 PM
  11. loukkis's Avatar
    i will check thanks
    If you have not yet tried, reboot your phone.
    12-26-2012 11:35 PM
  12. david90531's Avatar
    I have a question about these actually, for ppl that own them

    The headphones include two cables; the one with controltalk works perfectly, but the other one (without control buttons but with mic) when I plug it into the headphones the sound is distorted and not very clear at all, kind of like when radio station is getting interference. Is there a specific function for these cables and they're not meant to be connected to the headphones, or is this just a defect??
    12-27-2012 11:42 PM
  13. david90531's Avatar
    I have a question about these actually, for ppl that own them

    The headphones include two cables; the one with controltalk works perfectly, but the other one (without control buttons but with mic) when I plug it into the headphones the sound is distorted and not very clear at all, kind of like when radio station is getting interference. Is there a specific function for these cables and they're not meant to be connected to the headphones, or is this just a defect??
    Anyone that can help me with this??
    12-28-2012 03:05 PM
  14. Jason Villeda's Avatar
    Hey,

    My cable stopped working today. I would also like to know more about where to find a replacement cable.. I know i can buy the monster inspiration cable, but I need volume control to work and I don't know if those will.
    10-24-2013 10:34 PM
  15. Bull1shbuy3r's Avatar
    I use the ones without controls whenever I'm using the headphones and they wotk perfectly with my ipad/macbook/L920 they DO NOT work with my 520 tho, whenever I plug them in the mobile goes mad, it will display volume 0/30 and won't play anything until I reboot...
    10-25-2013 12:36 PM
  16. fiveaces01's Avatar
    these are similar to some of the issues I experienced with my yurbuds earbuds that had an in line mic and the same button also had the pause music function. After using them for a while they began to act weird when I would connect them. The volume on the phone would go form 30 all the way down to 0 upon connection. The only way I could get this to stop was to use the earbuds on my pc for a few minutes and then re-connect to phone. However, if I used the pause or mic function the same problem came back. I eventually got another set of earbuds and try to use the button for pause or mic as little as possible...so far so good.
    10-26-2013 01:18 PM

Similar Threads

  1. Anyone else having issues with the Me tile?
    By Chowdah72 in forum Windows Phone 7
    Replies: 125
    Last Post: 08-30-2012, 09:01 PM
  2. Issues with the white 900
    By vishrb in forum Nokia Lumia 900
    Replies: 10
    Last Post: 05-01-2012, 11:23 PM
  3. Anyone having issues with the ARRIVE?
    By jasqid in forum HTC Arrive / 7 Pro
    Replies: 15
    Last Post: 03-14-2012, 08:55 AM
  4. issue with the zune player...
    By Luisraul924 in forum Windows Phone 7
    Replies: 0
    Last Post: 01-02-2012, 03:14 AM
  5. Replies: 5
    Last Post: 12-17-2011, 07:18 PM
LINK TO POST COPIED TO CLIPBOARD