Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. kamajikaciya's Avatar
    Member

    Posts
    2 Posts
       #1  
    Hi;

    I got an USB 3.0 Hub (Vantec 4 Port) connected to USB 3.0 controller via PCI Express.

    When I connect my Lumia to USB Hub, it starts Windows Phone App. normally, I can open the folders with Windows but in photos some folders (especially saved pictures) cannot open. After double click I can insert the folder but after 1-2 seconds windows bar starts loading. Then I cannot reach my Lumia unless I disconnect it. Windows Phone App. and My Computer freezes too.

    On USB 2.0 there's no such a problem but I don't have an USB 2.0 Hub now and it's to hard to reach to USB 2.0.

    USB 3.0 works well on other devices. Also on device manager my Lumia 920 shows up unidentified.

    If you'll able to help me I'll be happy. I'm using Windows 7 64 bit version.
  2. nikholaspappas's Avatar
    Member

    Posts
    47 Posts
    Global Posts
    77 Global Posts
    #2  
    I have USB 3.0 ports on my laptop and have no such issue. Sorry

Similar Threads

  1. Does Nokia lumia 920 support usb mass storage?
    By Vitogalaxy in forum Windows Phone 8
    Replies: 4
    Last Post: 06-07-2013, 09:12 AM
  2. Replies: 0
    Last Post: 11-17-2012, 05:08 AM
  3. Replies: 7
    Last Post: 11-08-2012, 09:07 AM
  4. Testing Lumia 920 with forks and gloves
    By LEC 360 in forum Windows Phone 8
    Replies: 6
    Last Post: 10-11-2012, 03:11 PM
  5. Replies: 18
    Last Post: 10-04-2012, 04:31 AM

Posting Permissions