Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 39
Like Tree1Likes
  1. generalsu's Avatar
    Member

    Posts
    119 Posts
       #1  
    No one's talked about this. I am surprised.

    I had an Android phone and it sets the date and time automatically based on location. WP8 has the same functionality, but the date and time does not automatically adjust to my location / timezone. Is this happening to everyone?

    I hate having to set the date and time manually every time I soft reset the phone.
  2. wjlim3's Avatar
    Member

    Posts
    99 Posts
    #2  
    I agree...doesn't work for me
  3. glimited's Avatar
    Member

    Posts
    82 Posts
    #3  
    I had a problem with my phone being off a few hours the first week I had the phone. After using manual for a while I switched it back to automatic and now it seems to work fine. I was messing with a lot of settings in the beginning though so I don't know if something I did fixed it.
  4. Tiago Lopes's Avatar
    Member

    Posts
    24 Posts
    #4  
    What network are you on?
    Im EE UK and here it doesn't work at all. However when i pop into Europe, any country, it automatically changes. Great. It doesn't when i get back though. Annoying as ****
  5. Arsenic17's Avatar
    Member

    Posts
    178 Posts
    #5  
    That functionality doesnt actually come from within the phone or by the phone finding your location. The clock is set based on the time signals from the cell towers of your carrier. If you are having issue with the time not updating, it is likely because

    1) you either do not have cell service.
    2) the carrier you have is bad and doesnt have the time signal set up right from the towers to your phone.
  6. jeremyshaw's Avatar
    Member

    Posts
    602 Posts
    Global Posts
    603 Global Posts
    #6  
    For me it is:

    3) Just my Lumia 920 is screwing up. Focus is working fine with carrier time, iPhone 4S is working fine, and Motorola atrix is working fine. All on at&t. IPad with cellular is working fine with Verizon.

    Only my Lumia 920 doesn't seem to know what the time is, to be exact, it is one time zone off.
  7. welsbloke's Avatar
    Member

    Posts
    238 Posts
    #7  
    This is subject to your operator as others have mentioned for example T-Mobile UK do not provide the time service so you need to do it manually. It does however work as I use it when travelling and works fine just not with EE in the UK.
  8. duncan0622's Avatar
    Member

    Posts
    137 Posts
    #8  
    Mine too. After I soft reset, the time seems to be the factory time. When I switch to auto, It doesn't work. But one day I surprisingly got the time auto back.
    But I soft reset afterwards again later, It disappeared again. Now I just simply set time manually, switch to auto and wish one day the Auto function will come back again.
  9. nag3's Avatar
    Member

    Posts
    4 Posts
    Global Posts
    89 Global Posts
    #9  
    it doesn't work for me too ... and i realize that when u switch the time from 24 h to 12 h .. u dont see the AM and PM next to the time !!!!
  10. deuxani's Avatar
    Member

    Posts
    106 Posts
    Global Posts
    110 Global Posts
    #10  
    I don't even have the auto button :) I bought mine in Germany, but it's weird that that matters. With iPhone or Android your time is always synced with any operator in the world, so I don't understand why Windows Phone shows such strange behaviour.
  11. generalsu's Avatar
    Member

    Posts
    119 Posts
       #11  
    This does not make sense. I was using an Android phone with the same telco and the date and time sync just fine. Does not work anymore when I switched to a NL920.
  12. generalsu's Avatar
    Member

    Posts
    119 Posts
       #12  
    I don't think this has anything to do with the carriers, but more to do with WP8 lacking in some real basic functionality.

    As I said before, I was with the same carrier for many years and using Android phone, and it worked perfectly.
  13. ClixT's Avatar
    Member

    Posts
    114 Posts
    #13  
    Quote Originally Posted by generalsu View Post
    I don't think this has anything to do with the carriers, but more to do with WP8 lacking in some real basic functionality.

    As I said before, I was with the same carrier for many years and using Android phone, and it worked perfectly.
    I agree. Most devices (heck even my cable box and S40 Nokia 6500c) connects to the internet to adjust the time automatically.. Maybe the L920 uses the carrier's time service, maybe not. Like you said, WP8 lacks the basic functionality. Nokia most likely knows how much WP8 lacks so much functionality compared to Symbian...
  14. phirefly's Avatar
    Member

    Posts
    346 Posts
    Global Posts
    350 Global Posts
    #14  
    I'm on AT&T and have no issues. My time updates fine, I have never set it.
  15. MF73's Avatar
    Member

    Posts
    104 Posts
    #15  
    I'm on EE in the UK, auto time and date does not work, actually pretty much everything EE offer does not work with the lumia 920. Crap network rushed out for 4g, which also only covers a few percent of the country if that.
    Andrew Milne likes this.
  16. jin8k's Avatar
    Member

    Posts
    13 Posts
    Global Posts
    15 Global Posts
    #16  
    it doesnt work on mine too. i had to soft reset the phone couple of times, and it doesnt work... i gave the phone about 2 hours of time, but still no auto setting. so i updated manually. anyway, someone says it's the operator problem, but i am using the sim from my old iphone 4s, which used to auto set the time...
  17. generalsu's Avatar
    Member

    Posts
    119 Posts
       #17  
    I think this is a problem with WP8 OS, not so with the operator.
  18. namdanog's Avatar
    Member

    Posts
    1 Posts
    #18  
    I have this issue. When Date+Time is set to automatic it doesn't update at all here in Singapore (Starhub) even though all my other phones work with the same provider (Nokia N9 amongst them). Both the NL920 and NL620 exhibit this behaviour. When I go to Indonesia it does update automatically with INDOSAT, which is good. But then coming back to Singapore it's wrong again so I have to do it manually.

    Very strange that this would not "just work".
  19. andrewkeith5's Avatar
    Member

    Posts
    280 Posts
    #19  
    I'm on Vodafone UK, and Automatic time updates worked perfectly right up until I first had to soft reset the Lumia 920 (i.e. pressing and holding the Volume Down + Power buttons).

    Doing that reset the clock to some time before the phone was even announced, even though automatic was set to on. Even after leaving it for an hour or two, nothing.

    I just turned it off and set the time/date manually, then turn automatic back on. Not a clue if it actually works anymore, it definitely doesn't work if you reset the device. It's like the act of resetting switches off automatic time sync or deletes the code or something...
  20. ChazTyldsley's Avatar
    Member

    Posts
    81 Posts
    Global Posts
    113 Global Posts
    #20  
    Quote Originally Posted by andrewkeith5 View Post
    I'm on Vodafone UK, and Automatic time updates worked perfectly right up until I first had to soft reset the Lumia 920 (i.e. pressing and holding the Volume Down + Power buttons).

    Doing that reset the clock to some time before the phone was even announced, even though automatic was set to on. Even after leaving it for an hour or two, nothing.

    I just turned it off and set the time/date manually, then turn automatic back on. Not a clue if it actually works anymore, it definitely doesn't work if you reset the device. It's like the act of resetting switches off automatic time sync or deletes the code or something...
    This is the issue I have also. T-Mobile UK (EE) here. It's never seemed to work...
  21. Jealy666's Avatar
    Member

    Posts
    196 Posts
    Global Posts
    197 Global Posts
    #21  
    Mine also never works (4GEE) - I always thought they would just pull the date/time from the internet.
  22. yaashul's Avatar
    Member

    Posts
    12 Posts
    #22  
    I have the very same issue as well.
  23. #23  
    My Problem here is (T-Mobile Germany). That my LG Optimus Speed (Android 4.1.2) can set Time Perfectly and my Lumia 800 and Lumia 920 can't... They always are some time off from what it real is... Not a good thing for WP in General...
  24. Bspain's Avatar
    Member

    Posts
    18 Posts
    #24  
    Same problem here, LG Quantum (WP7) is fine, Lumia 820 just does not update time from the carrier.
  25. cyleng's Avatar
    Member

    Posts
    2 Posts
    #25  
    My Lumia 920 also not working for auto mode, I leave it there for few days with wrong time / date, it just do nothing there.
    I am 100% confirmed not an issue from my Telco, as I tried the same SIM card on Android phone & other classic phone, all working fine except this flagship Windows Phone 8 device.
Page 1 of 2 12 LastLast

Similar Threads

  1. 5 phones per live id -- how does it work?
    By petersun21 in forum Windows Phone Apps
    Replies: 3
    Last Post: 04-30-2012, 04:29 PM
  2. How does it work?
    By diapers in forum Developers Beta Testing
    Replies: 2
    Last Post: 04-17-2012, 01:10 PM
  3. Google Apps - Own domain - does it work on Mango
    By holzlondon in forum Windows Phone 7
    Replies: 3
    Last Post: 03-01-2012, 02:51 AM
  4. Who are they, and how does it work? Please enlighten me...
    By SEKKDS in forum Windows Phone Apps
    Replies: 4
    Last Post: 10-21-2011, 03:02 PM
  5. Windows Phone Update: How Does It Work
    By MobileSugar in forum Windows Phone 7
    Replies: 1
    Last Post: 09-12-2011, 07:00 PM

Posting Permissions