1. lander06's Avatar
    I've noticed periodically over the past 2 weeks that I've been getting delayed text messages. They come in all at once and oddly enough, the timestamps of each text is correct. It appears that when I reply to the person (not knowing they already sent me a text), it triggers the backlog of text that were not delivered.
    01-03-2013 04:19 PM
  2. slick5150's Avatar
    Sounds like a network issue rather than a device issue.
    01-03-2013 04:25 PM
  3. richie20's Avatar
    Did you ever get this fixed? My wife and I have 920s and are experiencing the same issue.
    01-23-2013 09:22 AM
  4. lhuddles's Avatar
    I'm having the same issue. Delayed text messages as well as delayed voicemail notifications. It can't be a network issue because other members of my family (we're all on the same network, they have an iPhone and a Galaxy SIII) aren't having any problems at all.
    01-26-2013 08:51 PM
  5. sanders2232's Avatar
    Rebooting your phone is the best way to fix.
    01-27-2013 12:16 AM
  6. lhuddles's Avatar
    Done that. Several times. Unfortunately, it doesn't solve the issue.
    01-27-2013 01:21 AM
  7. MaxPower203's Avatar
    I'm not saying it's not your phone but I had the same problem with my iPhone and my HTC before that.
    01-27-2013 01:28 AM
  8. smileyh's Avatar
    I had this, and I talked with att, they fixed it, haven't had the problem in 5 days now
    01-27-2013 01:31 AM
  9. sanders2232's Avatar
    Does is it happen randomly or certain area each time? Mine will happen when I go to to a roaming area then back out it's like I have to reboot the phone.
    01-27-2013 10:05 AM
  10. jbwpcentral's Avatar
    I have the same problem, it only happens randomly, but when it does it lasts the entire day.
    01-27-2013 10:10 AM
  11. lhuddles's Avatar
    I called AT&T, the rep did "something" on her end, and said if I continue to have issues, I should call back and they will send me a new SIM card. So far, everything is ok. *fingers crossed*
    01-27-2013 03:30 PM
  12. lander06's Avatar
    Ok..ATT just sent me another phone over the weekend. New SIM did not work. Looked at my coverage and I literally in the middle of 3 cells. I was hoping that it was my radio, but guess what, the new phone just did the same think.

    The wife sent a msg 40 mins ago and they just came in. I DO NOT have cell data enabled because I have wifi converge everywhere. Could this be the cause??
    01-28-2013 04:36 PM
  13. lander06's Avatar
    More info..this happens often at the house (great coverage). The wife has an Iphone, but she is NOT send group mms. I had issues with her iphone, and my son's nokia and android.
    01-28-2013 04:38 PM
  14. sanders2232's Avatar
    Ok..ATT just sent me another phone over the weekend. New SIM did not work. Looked at my coverage and I literally in the middle of 3 cells. I was hoping that it was my radio, but guess what, the new phone just did the same think.

    The wife sent a msg 40 mins ago and they just came in. I DO NOT have cell data enabled because I have wifi converge everywhere. Could this be the cause??
    possible yes.
    01-29-2013 12:42 AM
LINK TO POST COPIED TO CLIPBOARD