Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 10 of 10
  1. A54D's Avatar
    Member

    Posts
    34 Posts
       #1  
    I recently purchased a Lumia 920 and had problems with it. I gave it to Nokia for repair and they have now sent a new one. Everything looked fine up until I tried making a call. The call went through but I can't hear anything at all. Not even the dialler! When I put the phone on speaker then I can hear everything but from the handset nothing! Has anybody else had this problem? Anyone know how to fix it? Don't want to send the phone back in after just receiving it. I need it for my work :/
  2. alphonsohall's Avatar
    Member

    Posts
    135 Posts
    #2  
    Sounds like its behaving as if the headset is plugged in, try inserting and removing the headset jack plug a few times, it might be the contacts inside the phone headset socket stuck open and not making contact......nothing to lose by trying this.
  3. TenTwelve's Avatar
    Member

    Posts
    514 Posts
    Global Posts
    522 Global Posts
    #3  
    Try a hard reset.
  4. A54D's Avatar
    Member

    Posts
    34 Posts
       #4  
    Thanks for the suggestion, tried it but unfortunately it didn't work. The sound started coming from the headset as expected but when removed, nothing. The phones brand new, just come today! Any other suggestions or fixes I could try?
  5. A54D's Avatar
    Member

    Posts
    34 Posts
       #5  
    Done a hard reset too. Hasn't helped.
  6. jtm9009's Avatar
    Member

    Posts
    1 Posts
    #6  
    If you use AT&T try going up there and getting a new sim card... weird but it fixes some problems
  7. #7  
    I already have a second 920 and my brand new head set doesn't work. I will sell my today and will go back to Iphone ;/
  8. George Ponder's Avatar
    Editor

    Posts
    472 Posts
    Global Posts
    473 Global Posts
    #8  
    Call Nokia... they may send you a replacement while you're shipping the one with the speaker problem back.
    Or better yet, send you a replacement with a return label for the other.
    Almost sounds as if the earpiece got disconnected. Why did you send it to Nokia to begin with? Maybe a tech goofed when re-assembling the phone?
    George Ponder
    Reviews Editor - Windows Phone Central
    Email: george.ponder@wpcentral.com
    Twitter: @coppertop004

  9. winkid's Avatar
    Member

    Posts
    1 Posts
    #9  
    i am having somtehing similar. on my 920 if i listen to music through the headsets and i recieve a call the phone rings but when i pick no sound comes out or turns on the speaker option. then when i attempt to return the call i cant hear the dialer or anything else for that matter. i always have to restart my phone.

    anyone else!
  10. A54D's Avatar
    Member

    Posts
    34 Posts
       #10  
    Quote Originally Posted by George Ponder View Post
    Call Nokia... they may send you a replacement while you're shipping the one with the speaker problem back.
    Or better yet, send you a replacement with a return label for the other.
    Almost sounds as if the earpiece got disconnected. Why did you send it to Nokia to begin with? Maybe a tech goofed when re-assembling the phone?
    The first Lumia 920 I sent off was regarding extensive overheating. I mean not the standard warm, it actually burn my nephew and started to smell until turned off and left to cool, also with that the battery life would drain. After sending it off I received an email saying it was beyond repair and got sent a brand new (faulty) phone, wrapped and everything. Looks like I'll be sending this one off too. Guess I just had some bad luck lol.

Similar Threads

  1. Replies: 15
    Last Post: 11-20-2012, 05:31 PM
  2. Anybody think this would make a perfect apollo device?
    By freestaterocker in forum Upcoming & Rumored Devices
    Replies: 8
    Last Post: 06-28-2012, 12:59 AM
  3. Anybody try this? Get Edge, 3g, 4g toggle on WP7
    By dkp23 in forum Windows Phone 7
    Replies: 17
    Last Post: 05-14-2012, 04:42 PM
  4. Anybody here this rumor
    By ericreinhardt in forum Windows Phone 7
    Replies: 17
    Last Post: 12-11-2011, 01:18 AM
  5. Have you had this problem?
    By JackB03 in forum Windows Phone 7
    Replies: 8
    Last Post: 10-13-2011, 10:42 AM

Posting Permissions