4K all the way

You probably don't NEED a 4K webcam, but we love Logitech's BRIO 4K anyway

Long live Windows phone

Contrary to popular belief, Windows phone won't die anytime soon

XP-YESSSSSSS

Dell's already awesome XPS 15 gets even better in 2017

Surface Pwn 5

Surface Pro 5, Project NEON details leaked on LinkedIn?

Redefining the PC

Why Microsoft's Surface phone could be MUCH more than a mere 'phone'

Surface table meets Windows 10

Yes, we did put Windows 10 on the original Surface table ... and it rocks

Cream o' the crop

Before buying a Microsoft laptop, check out our pick for the absolute best

Simple and secure, just the way I like it

We think Windows 10 Cloud is a great idea, here's why

uber micro

Halo Wars 2 has something for everyone. Here's our full review.

Oldie but goldie

We reviewed Microsoft's decade-old Surface table

Creators Update comin' at ya

These are the coolest new features in the next big Xbox One update (video)

Buyer's guide

The Razer Blade 14 is the best laptop Razer has to offer

Windows 10 app gems

10 terrific Windows 10 apps you should be using

Tower of power

Here's what we think of Dell's XPS Tower Special Edition

Quite a deal

Grab the complete C# coding bootcamp for $41!

Your go-to laptop guide

Introducing our ultimate laptop buyer's guide

Listen here

Attn Android and iPhone users: What you need to know about Windows phone

Old is new?

The original Surface Pro still holds its own in the 2-in-1 world

Xbox Greenlight?

No, internet, Microsoft isn't opening Xbox to all UWP games

Falling in love

HP Envy 34 review: An ultrawide curved all-in-one after my heart

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. bitstreamz's Avatar
    Member

    Posts
    4 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #1  
    Hi

    I recently acquired a black L920 a few days ago. However since my sim was activated yesterday I have had the most frustrating experience where my phone shows that its lost all reception and it stays like that until I reboot the phone and its fine maybe for a few hours until the next time where it stops and then I have to reboot the phone. I am in a very good coverage both at work and home and once its rebooted it shows full reception. I haven't tried any other service providers or sim but I cant see that being the issue, has anyone else had a similar experience and if so what did you do to resolve the problem
  2. tissotti's Avatar
    Member

    Posts
    1,105 Posts
    Global Posts
    1,107 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #2  
    Quote Originally Posted by bitstreamz View Post
    Hi

    I recently acquired a black L920 a few days ago. However since my sim was activated yesterday I have had the most frustrating experience where my phone shows that its lost all reception and it stays like that until I reboot the phone and its fine maybe for a few hours until the next time where it stops and then I have to reboot the phone. I am in a very good coverage both at work and home and once its rebooted it shows full reception. I haven't tried any other service providers or sim but I cant see that being the issue, has anyone else had a similar experience and if so what did you do to resolve the problem
    Have you checked that everything seems to be fine on the SIM tray? Do you have old SIM or do you take the SIM off and on often so the connectors on the SIM would be worn?

    Have you tried hard reset?
  3. bitstreamz's Avatar
    Member

    Posts
    4 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #3  
    Hi
    Thank you for the response

    I have only really reseated the sim tray once which is when I inserted the sim. The sim is brand new but what doesn't make sense to me is that it starts working perfectly fine when its powered down and then powered back up. I have tried when it happens to disable the GSM by enabling flight mode and then re enabling to see if that makes a difference but nothing.

    When you say hard reset would you mean physically powering down the device?
  4. bitstreamz's Avatar
    Member

    Posts
    4 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #4  
    Hi

    someone else I know had the same issue and they resolved it by dropping the minmum speed to 3G. Surely this is a bug how whats the best way of logging this with nokia/microsoft
  5. e4et's Avatar
    Member

    Posts
    138 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #5  
    Mine does the same every now and then. Only fix for me is also to shut down and restart the phone.
    Very anoying.
    I also replaced my sim, thinking the old one (which was cut to to the micro size) was faulty.. guess not

Posting Permissions

";