Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 14 of 14
  1. smileyh's Avatar
    Member

    Posts
    55 Posts
       #1  
    So I am just browsing through wpcentral on board express, and I check the app battery sense. It says I'm discharging at 15% an hour!! I am on a replacement phone, and the previous phone had better battery life, will it fix itself like others say you think? Or do I need a new phone:(
    Sent from my RM-820_nam_att_100 using Board Express
  2. smileyh's Avatar
    Member

    Posts
    55 Posts
       #2  
    And after a few more minutes it is up to 29% an hour, and it seems to be true, checked %ant 11:59 and it was at 33% then at 12, it was at 29%...4% a minute!!! Freaking ridiculous!
    Sent from my RM-820_nam_att_100 using Board Express
  3. NokFromApp's Avatar
    Member

    Posts
    73 Posts
    #3  
    Try a soft refresh. That has worked for me in the past.
  4. conanheath's Avatar
    Member

    Posts
    450 Posts
    Global Posts
    589 Global Posts
    #4  
    If the phone is new, battery will require "breakin" period. If that's what it is. That's about where I started with mine, got down to about 7-9% pre-portico and now I have about 3%/hr on Att Lte. I regretted buying phone due to the abysmal battery life at first, but now its better than my BB 9810. So I can't complain.

    I actually did a factory reset on a full charge after about a week on Portico and whether coincidence or not, I went from 7-9% to 3-4% overnight and I have been able to turn on all of my email accounts, notifications and background services since reset and keep 3%. Try soft reset every morning and see if it gets any better. If not might give hard reset a try but beware, there were issues with hard reset earlier. Nokia may have resolved them with portico. Search forums for info. Seemed to have the most impact on mine.

    I would give it a couple of weeks unless you are in 14day window with carrier. I returned first 920 on 14th day due to battery concerns. #2 wasn't any better than first so I stuck with it and now I have great battery life for LTE.
  5. smileyh's Avatar
    Member

    Posts
    55 Posts
       #5  
    thank you, I tried a soft reset this morning, didn't work, maybe I will give it a while.. I have had the phone for a couple months, but also on 4th replacement

    will try your suggestions though, thank you
  6. stoneysilence's Avatar
    Member

    Posts
    116 Posts
    Global Posts
    148 Global Posts
    #6  
    My phone is new and running any app will drain the battery at 30% an hour. But just by itself it runs at about 1% an hour which was better than my previous phone which lost 4-7% an hour in standby. Today is day 3.

    Sent from my Nexus 7 using Tapatalk HD
  7. NokFromApp's Avatar
    Member

    Posts
    73 Posts
    #7  
    Try chatting with a Nokia support person. I searched for nokia support, then went to contact us and then clicked on online chat. It was for a different problem, but they were quite responsive.
  8. CaptDjob's Avatar
    Member

    Posts
    162 Posts
    #8  
    I have the same, around 1% /h if phone is screen off.
  9. ttsoldier's Avatar
    Member

    Posts
    2,239 Posts
    Global Posts
    2,912 Global Posts
    #9  
    How is this NOT the same as everyone else? lol..
  10. realwarder's Avatar
    Member

    Posts
    1,320 Posts
    #10  
    Quote Originally Posted by ttsoldier View Post
    How is this NOT the same as everyone else? lol..
    Sounds the same Random usage. Yesterday my phone had a bad day. Was using 30% an hour at one point after playing a game. Today, it's currently using 2.7% an hour. Go figure.

    Yes, I back out of apps to "close" them all. (Although this doesn't apparently stop IE running in the background, so I suspect it makes no difference to other apps too!)

    Patiently waiting for the next firmware update...
  11. gbbg's Avatar
    Member

    Posts
    172 Posts
    #11  
    Soft reset works some times when a rogue app is responsible or when the battery stats is guilty of miscalculation. I had Battery Sense but the damn tile wouldn't update at all unless I opened it manually. The drop showed by the app on the other hand was staggering. My discharge rate varied from -22 to -3.
  12. MS_SURVEYOR's Avatar
    Member

    Posts
    113 Posts
    #12  
    Quote Originally Posted by gbbg View Post
    Soft reset works some times when a rogue app is responsible or when the battery stats is guilty of miscalculation. I had Battery Sense but the damn tile wouldn't update at all unless I opened it manually. The drop showed by the app on the other hand was staggering. My discharge rate varied from -22 to -3.
    Once I unloaded Battery Sense my random drains are a issue of the past. I rely on the settings battery app. Mostly because I don't have to keep looking for a battery drain. But that's only my experience. Carry on.
  13. gbbg's Avatar
    Member

    Posts
    172 Posts
    #13  
    Quote Originally Posted by MS_SURVEYOR View Post
    Once I unloaded Battery Sense my random drains are a issue of the past. I rely on the settings battery app. Mostly because I don't have to keep looking for a battery drain. But that's only my experience. Carry on.
    I had to install BS (lol) because my phone battery wasn't lasting enough as my original 920. I wanted to see what the charge/discharge cycles looked like. Now am back to WP battery status but, I need to solve this issue of battery drain.
  14. CaptDjob's Avatar
    Member

    Posts
    162 Posts
    #14  
    Install "Battery level for wp8". That works but hopefully the developer fixes the abysmal time -axis on chart.

Similar Threads

  1. Replies: 59
    Last Post: 11-21-2012, 04:59 AM
  2. Text Sound Crackles (Not a speaker issue, it seems)
    By ilifecomputer in forum Windows Phone 8
    Replies: 0
    Last Post: 11-19-2012, 11:31 PM
  3. Why are ROM sizes not listed as part of mobile specs??
    By kenzibit in forum Windows Phone 7
    Replies: 17
    Last Post: 03-08-2012, 06:02 PM
  4. How to text numbers not saved as mobile
    By enahs555 in forum Windows Phone 7
    Replies: 5
    Last Post: 12-23-2011, 04:39 PM
  5. Zune player not working as expected
    By Spyral in forum Zune
    Replies: 6
    Last Post: 12-27-2010, 09:01 PM

Posting Permissions