1. bartekxyz's Avatar
    Hi, I'm on my second l920, everything was great but few days ago I noticed that sometimes display of my phone turns off itself for half a second or show something that look like noise from empty tv channel(when I touch the screen, noise disappears). It happens randomly. For me It looks like software related defect but I'm not sure. Has anyone encountered the same issue? What can I do with it?

    1.jpg
    2.jpg
    Last edited by bartekxyz; 01-28-2013 at 11:52 AM.
    01-28-2013 05:17 AM
  2. autumnride's Avatar
    Nerver heard of that issue before...

    First you can try fixing it with a soft-reset (middle and volume down button for at least 10 sec)
    Second you can try the hard-reset (settings->about->reset)

    If still having the problem afterwards it must be a hardware issue. -> go get replacement or reparation for the device.
    01-28-2013 06:47 AM
  3. bartekxyz's Avatar
    I tried soft-resetting it, will see how it goes.
    01-28-2013 11:24 AM
  4. bartekxyz's Avatar
    Damn, it happened again...
    01-28-2013 11:50 AM
  5. HIllste1's Avatar
    I've had a similar problem, but only on my lock screeen, but the date and time stamps still show.
    01-28-2013 12:40 PM
  6. rbxtreme's Avatar
    Very strange... But as autumnride suggested give the hard reset a try.. If that too does no help.. Rush for a replacement...
    01-28-2013 12:44 PM
  7. scubus's Avatar
    I had the same thing happen. A hard reset will clear it, but even so the AT&T store exchanged it without question or comment and my new one has not had any issues since. Mine did it while talking on the phone. Call went fine but I couldn't hang-up or end the call nor did it clear itself and I couldn't even do a simple power-down.

    I wonder if it happens often based on the fact they didn't even try and diagnose the problem.
    01-28-2013 12:51 PM
  8. bartekxyz's Avatar
    Hard reset? Damn... Maybe I will wait for portico update, I can't lose my progress in "Where is my water" :|
    01-29-2013 04:17 AM
  9. Madeye234's Avatar
    I am having a slightly different situation. My screen seems to know randomly start to "speckle" it starts to look like a star field on a black background, the UI movement is choppy, and there is a strip at the very top (like a TV channel that is scrambled) If it prgresses it changes the color resolution of the screen completely. The only thing i can do it turn off the screen and the screen reverts to normal. This started yesterday and I only had the phone for a week. Starting to be concerned. Anyone else seeing this??
    02-08-2013 05:00 PM
  10. Thomas Jaycox's Avatar
    We had this same issue as well as lockup issues. We have the phone replaced with a brand new one from the MS Store. No change... We uninstalled several apps.... No Change, We restored to factory default.... No Change. Also each time we had to use the reboot to unlock it. The last option we tried worked! That was to get a new SIM card from Verizon. They wanted to charge us for a new card, but we insisted for a new one for free. They conceded. The phone is completely restored back to the way is was when it was locking up... all apps included.. with the new SIM card, we have had zero lockups, slow downs, or any issues.

    Good luck with your phone.
    RezZed likes this.
    07-20-2014 04:04 PM
  11. deniozer's Avatar
    Hi everyone my lovely lumia 920 today giving this screen issue . I am on twitter and someone call me screen turn to black and not opened my screen and than my unlock button not worked. I try soft reset and my screen turn to old tv screen. I try Hard reset But not changed anythin. ı make last update 2 days ago. How to fix it this. Please help me.


    20140831_134838.jpg
    08-31-2014 11:03 AM
  12. denzilla's Avatar
    Happened once to me while watching a video from metrotube. Whole phone locked down. Had to force a shutdown to get the phone back up. I figured it was a bug with the DP and not having the latest firmware.
    09-01-2014 09:36 AM
  13. cynetinc's Avatar
    Hi everyone my lovely lumia 920 today giving this screen issue . I am on twitter and someone call me screen turn to black and not opened my screen and than my unlock button not worked. I try soft reset and my screen turn to old tv screen. I try Hard reset But not changed anythin. ı make last update 2 days ago. How to fix it this. Please help me.

    Click image for larger version. 

Name:	20140831_134838.jpg 
Views:	11 
Size:	616.2 KB 
ID:	79267
    I had the same problem. It's the display IC, had to swap phones, your screen is fine. Your phone, unfortunately is not. Buy a cracked screen one and replace it with your screen. You will be happy.
    Last edited by cynetinc; 09-02-2014 at 03:46 AM.
    09-02-2014 03:20 AM
  14. QuangAnhDang's Avatar
    I have completely the same issue but with my Lumia 1520. Have you found any solutions and highly appreciated if you could share. Thank you.
    09-27-2014 10:46 PM
  15. rotkod's Avatar
    Main problem on IE is this http://s25.postimg.org/e0kdzmc8r/no_signal.jpg after playing video on youtube, IE sometimes bloks complete device. This hapaned on my L920, 1020, 925 cyan, and ativ s PFD 8.1, never on 8!

    Solution volume down+power soft restart lumias, on ativ s remove the battery :(

    no_signal.jpg
    09-28-2014 04:35 AM
  16. El Kaminant Sin Kamino's Avatar
    HOLA yo tengo el mismo problema con un 920 muestra la pantalla tipo tv .y el display anda de 10 ya que lo e probado con otra placa ,sera problema de el flex ??
    03-11-2015 02:41 PM
  17. Atharv Sankholkar's Avatar
    Did manage to solve it. Got this 8 mins ago. I was so scared. But after a bit, I realised that everything was working fine. I had incoming notifications and since I know where all the buttons are on the screen, I was able to slide up and enter my code to unlock my phone. So the problem was the screen. So I held the Power Button, which would bring a popup to slide down if I want to switch off. So I slid my finger across the area of the screen where the popup would usually be. My phone then turned off. And everything was back to normal when I started it. :)
    10-02-2015 04:14 PM
  18. gordonfink's Avatar
    You can also do a soft reset if it happens - power and volume down at the same time. Basically just reboots your phone.
    10-02-2015 05:44 PM
  19. nikyns's Avatar
    I had the exact problem when my daughter was watching youtube in IE. Volume down + power button for 12 seconds rebooted and came back fine. Thanks for your solution.
    06-26-2016 09:10 AM
  20. Braden T's Avatar
    DO NOT RESET YOUR PHONE!!!!!! The digitizer (touch screen) still works, so hold the power button and swipe down to shut the phone down.
    Also, I always get this while using YouTube, is it my phone or the operating system? Nokia Lumia 925
    09-10-2016 01:05 PM
  21. Jennifer Saks's Avatar
    I just had this happen the other day for the fist time. I was letting my granddaughter watch a cartoon on youtube in the car...the phone got really hot and then the screen turned to snow. I tried to turn the phone off...tried all sorts of things. Finally I just threw it in my purse and looked at it about an hour later and it was back to normal. I hope it doesn't happen again.

    A secondary issue is the heating up. Is that normal, or is there something wrong?
    Jennifer
    09-16-2016 03:26 PM
  22. gordonfink's Avatar
    soft reset fixes that issue. Vol down and power, and it reboots, and you're ok. my 920 used to do that on occasion.

    what does "heating up" mean? how hot? where?
    Laura Knotek likes this.
    10-27-2016 07:09 PM

Similar Threads

  1. Lumia 920 Display Bug
    By chatafrata in forum Nokia Lumia 920
    Replies: 4
    Last Post: 02-13-2013, 06:44 AM
  2. Nokia lumia 920 Calendar bug
    By rsweis62 in forum Nokia Lumia 920
    Replies: 3
    Last Post: 01-07-2013, 06:29 AM
  3. Lumia 920 display LCD 1 column just shows green
    By ccube1 in forum Nokia Lumia 920
    Replies: 7
    Last Post: 01-06-2013, 12:50 AM
  4. Redirected from Nokia Lumia 920 forum--bug
    By Keith Wallace in forum Site Feedback & Help
    Replies: 6
    Last Post: 12-02-2012, 04:28 PM
  5. Replies: 25
    Last Post: 09-27-2012, 08:47 AM
LINK TO POST COPIED TO CLIPBOARD