Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 15 of 15
  1. bartekxyz's Avatar
    Member

    Posts
    39 Posts
       #1  
    Hi, I'm on my second l920, everything was great but few days ago I noticed that sometimes display of my phone turns off itself for half a second or show something that look like noise from empty tv channel(when I touch the screen, noise disappears). It happens randomly. For me It looks like software related defect but I'm not sure. Has anyone encountered the same issue? What can I do with it?

    1.jpg
    2.jpg
    Last edited by bartekxyz; 01-28-2013 at 12:52 PM.
  2. autumnride's Avatar
    Member

    Posts
    81 Posts
    Global Posts
    86 Global Posts
    #2  
    Nerver heard of that issue before...

    First you can try fixing it with a soft-reset (middle and volume down button for at least 10 sec)
    Second you can try the hard-reset (settings->about->reset)

    If still having the problem afterwards it must be a hardware issue. -> go get replacement or reparation for the device.
  3. bartekxyz's Avatar
    Member

    Posts
    39 Posts
       #3  
    I tried soft-resetting it, will see how it goes.
  4. bartekxyz's Avatar
    Member

    Posts
    39 Posts
       #4  
    Damn, it happened again...
  5. HIllste1's Avatar
    Member

    Posts
    24 Posts
    #5  
    I've had a similar problem, but only on my lock screeen, but the date and time stamps still show.
  6. rbxtreme's Avatar
    Member

    Posts
    112 Posts
    #6  
    Very strange... But as autumnride suggested give the hard reset a try.. If that too does no help.. Rush for a replacement...
  7. scubus's Avatar
    Member

    Posts
    54 Posts
    Global Posts
    55 Global Posts
    #7  
    I had the same thing happen. A hard reset will clear it, but even so the AT&T store exchanged it without question or comment and my new one has not had any issues since. Mine did it while talking on the phone. Call went fine but I couldn't hang-up or end the call nor did it clear itself and I couldn't even do a simple power-down.

    I wonder if it happens often based on the fact they didn't even try and diagnose the problem.
  8. bartekxyz's Avatar
    Member

    Posts
    39 Posts
       #8  
    Hard reset? Damn... Maybe I will wait for portico update, I can't lose my progress in "Where is my water" :|
  9. Madeye234's Avatar
    Member

    Posts
    107 Posts
    Global Posts
    111 Global Posts
    #9  
    I am having a slightly different situation. My screen seems to know randomly start to "speckle" it starts to look like a star field on a black background, the UI movement is choppy, and there is a strip at the very top (like a TV channel that is scrambled) If it prgresses it changes the color resolution of the screen completely. The only thing i can do it turn off the screen and the screen reverts to normal. This started yesterday and I only had the phone for a week. Starting to be concerned. Anyone else seeing this??
  10. Thomas Jaycox's Avatar
    Member

    Posts
    1 Posts
    #10  
    We had this same issue as well as lockup issues. We have the phone replaced with a brand new one from the MS Store. No change... We uninstalled several apps.... No Change, We restored to factory default.... No Change. Also each time we had to use the reboot to unlock it. The last option we tried worked! That was to get a new SIM card from Verizon. They wanted to charge us for a new card, but we insisted for a new one for free. They conceded. The phone is completely restored back to the way is was when it was locking up... all apps included.. with the new SIM card, we have had zero lockups, slow downs, or any issues.

    Good luck with your phone.
    Thanked by:
    RezZed 
  11. deniozer's Avatar
    Member

    Posts
    2 Posts
    #11  
    Hi everyone my lovely lumia 920 today giving this screen issue . I am on twitter and someone call me screen turn to black and not opened my screen and than my unlock button not worked. I try soft reset and my screen turn to old tv screen. I try Hard reset But not changed anythin. ı make last update 2 days ago. How to fix it this. Please help me.


    20140831_134838.jpg
  12. denzilla's Avatar
    Member

    Posts
    177 Posts
    #12  
    Happened once to me while watching a video from metrotube. Whole phone locked down. Had to force a shutdown to get the phone back up. I figured it was a bug with the DP and not having the latest firmware.
  13. cynetinc's Avatar
    Member

    Posts
    6 Posts
    #13  
    Quote Originally Posted by deniozer View Post
    Hi everyone my lovely lumia 920 today giving this screen issue . I am on twitter and someone call me screen turn to black and not opened my screen and than my unlock button not worked. I try soft reset and my screen turn to old tv screen. I try Hard reset But not changed anythin. ı make last update 2 days ago. How to fix it this. Please help me.

    Click image for larger version. 

Name:	20140831_134838.jpg 
Views:	5 
Size:	616.2 KB 
ID:	79267
    I had the same problem. It's the display IC, had to swap phones, your screen is fine. Your phone, unfortunately is not. Buy a cracked screen one and replace it with your screen. You will be happy.
    Last edited by cynetinc; 09-02-2014 at 04:46 AM.
  14. QuangAnhDang's Avatar
    Member

    Posts
    1 Posts
    #14  
    I have completely the same issue but with my Lumia 1520. Have you found any solutions and highly appreciated if you could share. Thank you.
  15. rotkod's Avatar
    Member

    Posts
    84 Posts
    #15  
    Main problem on IE is this http://s25.postimg.org/e0kdzmc8r/no_signal.jpg after playing video on youtube, IE sometimes bloks complete device. This hapaned on my L920, 1020, 925 cyan, and ativ s PFD 8.1, never on 8!

    Solution volume down+power soft restart lumias, on ativ s remove the battery :(

    no_signal.jpg

Similar Threads

  1. Lumia 920 Display Bug
    By chatafrata in forum Nokia Lumia 920
    Replies: 4
    Last Post: 02-13-2013, 07:44 AM
  2. Nokia lumia 920 Calendar bug
    By rsweis62 in forum Nokia Lumia 920
    Replies: 3
    Last Post: 01-07-2013, 07:29 AM
  3. Lumia 920 display LCD 1 column just shows green
    By ccube1 in forum Nokia Lumia 920
    Replies: 7
    Last Post: 01-06-2013, 01:50 AM
  4. Redirected from Nokia Lumia 920 forum--bug
    By Keith Wallace in forum WindowsCentral.com - Site News, Feedback, Help
    Replies: 6
    Last Post: 12-02-2012, 05:28 PM
  5. Replies: 25
    Last Post: 09-27-2012, 09:47 AM

Posting Permissions