Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. dreamfly's Avatar
    Member

    Posts
    35 Posts
    Global Posts
    40 Global Posts
       #1  
    So I ordered my Cyan 920 on Nov 19 and finally got it a few days ago. It's got the Portico update already. But I am frustrated now that it refused to connect to my work network. My old trusty HTC HD7 which is sitting next to the Lumia now is happily connected to the network using the same user ID. Note I was able to connect to my home secured network as well as a non-secured enterprise network.

    My company's network is using WPA2-Enterprise protocol. Naturally all the Androids and Iphones are problem free. I am sure the enterprise-minded blackberries will be problem free as well.

    So is it Nokia's fault or Microsoft's? From the spec sheet, the Lumia 920 supports "WPA2 (AES/TKIP)" and from the searching net, WPA2 has Personal and Enterprise. So is the Enterprise missing from the OS or Nokia never tested it?

    Has anyone able to connect to their enterprise network using WPA2-Enterprise? You can verify what protocol used from a connected wireless laptop.

    So much for Windows Phone 8 beating the blackberry.
  2. pewpewbangbang's Avatar
    Member

    Posts
    28 Posts
    Global Posts
    38 Global Posts
    #2  
    My school network is similar to yours if not the same and it's connected perfectly, whereas my iPhone 5 has had problems on and off with it.
  3. NokFromApp's Avatar
    Member

    Posts
    73 Posts
    #3  
    Not sure if it will work, but try a soft refresh (Volume down + Power till the phone restarts) and check if it works. If it still does not work, then I would suggest try with some other network (maybe set up your home network with the same security settings) and check if that works.
    Also, as I noted in another thread I started yesterday, do not forget to do a normal reboot after the soft refresh. If you dont do that, then your live tiles will not work.
  4. dreamfly's Avatar
    Member

    Posts
    35 Posts
    Global Posts
    40 Global Posts
       #4  
    Had been on Nokia tech support and refreshed my phone and lost all my settings. But it's still the same. There were other threads on wpcentral with people having similar problems.

    http://forums.wpcentral.com/windows-...-problems.html

    http://forums.wpcentral.com/nokia-lu...rise-wifi.html

    Looks like it's a Windows Phone 8 OS issue.

    It's hard to replicate WPA2-Enterprise at home as it requires a separate server.
  5. lionel007's Avatar
    Member

    Posts
    3 Posts
    #5  
    I also had problems connecting to WPA2 enterprise networks, untill a few days ago. I received a few updates for Nokia apps including Network+ After installing these updates I am now able to connect to WPA2 Enterprise networks.
  6. adimax24's Avatar
    Member

    Posts
    2 Posts
    #6  
    @lionel007, whats the firmware version on your phone - is it 5962?

Similar Threads

  1. Finally got my Lumia 920, have few queries
    By maverick786us in forum Nokia Lumia 920
    Replies: 12
    Last Post: 01-12-2013, 11:37 PM
  2. Finally got my 920. Quick question?
    By wayneholbrook in forum Nokia Lumia 920
    Replies: 13
    Last Post: 12-30-2012, 02:58 AM
  3. Can't connect to HSDPA network
    By ma_c in forum Nokia Lumia 920
    Replies: 0
    Last Post: 12-19-2012, 05:19 PM
  4. I got my Lumia 920 Cyan for free!
    By BrownxGoblin in forum Nokia Lumia 920
    Replies: 1
    Last Post: 11-14-2012, 08:01 PM
  5. Just got my Cyan 920 and...
    By WIndowsReborn in forum Nokia Lumia 920
    Replies: 12
    Last Post: 11-12-2012, 02:28 PM

Posting Permissions