Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 20 of 20
  1. xalasten's Avatar
    Member

    Posts
    43 Posts
    Global Posts
    82 Global Posts
       #1  
    Hi Everyone, sorry if this has been asked but is there no way to get lte to work on Bell? I have it unlocked and mms,internet sharing etc work but I can only get 4G to show. In tests I am getting hspa+ speeds. Any help would be great!
  2. Noob1ee's Avatar
    Member

    Posts
    93 Posts
    Global Posts
    94 Global Posts
    #2  
    I have LTE with Virgin which uses Bell's network. Have you tried installing the access point app and selecting Bell?
  3. WavingReds's Avatar
    Member

    Posts
    746 Posts
    Global Posts
    747 Global Posts
    #3  
    yep not on bell, Roger uses the 700 band, Bell and Telus signed and agreement to use the 850 band so...yeah D=
  4. xalasten's Avatar
    Member

    Posts
    43 Posts
    Global Posts
    82 Global Posts
       #4  
    I do have access point installed and the Lumia 920 is supposed to be pentaband so should support all the frequencies I thought?
  5. lipper2000's Avatar
    Member

    Posts
    185 Posts
    Global Posts
    273 Global Posts
    #5  
    I never realized 4G was not LTE lol...ive not seen LTE symbol either...getting pretty quick speeds on Bell though with my unlocked Rogers 920
  6. lipper2000's Avatar
    Member

    Posts
    185 Posts
    Global Posts
    273 Global Posts
    #6  
    I read the Canadian manual and it only talks about 4g
  7. WavingReds's Avatar
    Member

    Posts
    746 Posts
    Global Posts
    747 Global Posts
    #7  
    oh sorry my mistake, bell does use the 700 band as well.

    the pentaband phone was only for I believe the 3G network and it was the first batch that came out.

    Do you have an LTE sim card?
  8. xalasten's Avatar
    Member

    Posts
    43 Posts
    Global Posts
    82 Global Posts
       #8  
    Yep using lte sim from my HTC 8x
  9. WavingReds's Avatar
    Member

    Posts
    746 Posts
    Global Posts
    747 Global Posts
    #9  
    Then sorry I don't know how to help you, I've seen the LTE symble...actually I've seen all the symbols like a car shifting into higher gears
    O > E > 3G > 4G > LTE
    Thanked by:
  10. lipper2000's Avatar
    Member

    Posts
    185 Posts
    Global Posts
    273 Global Posts
    #10  
    Quote Originally Posted by WavingReds View Post
    Then sorry I don't know how to help you, I've seen the LTE symble...actually I've seen all the symbols like a car shifting into higher gears
    O > E > 3G > 4G > LTE
    ive probably got a 3G sim....how can i tell the version of phone if some are not LTE?

    if i get a 4G SIM...will it work with 3G devices...didnt know there was a difference
  11. VegaNovus's Avatar
    Member

    Posts
    214 Posts
    #11  
    4The box should say 4G/LTE ready if it's 4G/LTE capable.

    4G sim cards work fine in 3G devices :)
  12. slashd0t's Avatar
    Member

    Posts
    170 Posts
    Global Posts
    259 Global Posts
    #12  
    I'm on Bell and LTE works for me..
    Thanked by:
  13. xalasten's Avatar
    Member

    Posts
    43 Posts
    Global Posts
    82 Global Posts
       #13  
    I seem to be getting an LTE signal now from time to time, I am not sure why but it seems to work somewhat. The speed difference is not really noticeable except when downloading something so I guess I will just deal with it. Thanks for all the tips everyone.
  14. WavingReds's Avatar
    Member

    Posts
    746 Posts
    Global Posts
    747 Global Posts
    #14  
    make sure it actually says LTE and not 4G. I work in a cell phone shop and we sell sims from bell that says 4G and LTE
  15. lipper2000's Avatar
    Member

    Posts
    185 Posts
    Global Posts
    273 Global Posts
    #15  
    so do I need to have a different SIM for LTE? I just took the SIM out of my old phone (3G), cut it down and it worked fine but I never see the LTE...just 4G..
    I'm getting close to 30mbps with speedtest
  16. lipper2000's Avatar
    Member

    Posts
    185 Posts
    Global Posts
    273 Global Posts
    #16  
    BTW- box says :
    WCDMA 850/900/1900/2100/1700_2100 : LTE 700/850/1900/1700_2100 GSMQUAD
  17. Noob1ee's Avatar
    Member

    Posts
    93 Posts
    Global Posts
    94 Global Posts
    #17  
    Quote Originally Posted by lipper2000 View Post
    so do I need to have a different SIM for LTE? I just took the SIM out of my old phone (3G), cut it down and it worked fine but I never see the LTE...just 4G..
    I'm getting close to 30mbps with speedtest
    You will need an LTE sim, usually LTE sims will say LTE on the sim itself.
    Thanked by:
  18. lipper2000's Avatar
    Member

    Posts
    185 Posts
    Global Posts
    273 Global Posts
    #18  
    Quote Originally Posted by slashd0t View Post
    I'm on Bell and LTE works for me..
    Did you have to get a new LTE sim? When I look on the bell site the small sim's say they are for iphone5 only?!
    Perhaps I'm misunderstanding it...I thought the iphone4 and 5 had the same micro sim card...

    I cut down my regular sim to size and it works fine but would like LTE which I am seemingly not getting as it never states LTE

    Thanks.
  19. slashd0t's Avatar
    Member

    Posts
    170 Posts
    Global Posts
    259 Global Posts
    #19  
    Quote Originally Posted by lipper2000 View Post
    Did you have to get a new LTE sim? When I look on the bell site the small sim's say they are for iphone5 only?!
    Perhaps I'm misunderstanding it...I thought the iphone4 and 5 had the same micro sim card...

    I cut down my regular sim to size and it works fine but would like LTE which I am seemingly not getting as it never states LTE

    Thanks.
    I do have an LTE sim yes.

    Sent from my Nexus 7 using Tapatalk HD
  20. WavingReds's Avatar
    Member

    Posts
    746 Posts
    Global Posts
    747 Global Posts
    #20  
    yes, you will need a micro bell sim that says LTE on it, not 3G, not 4G.

    the LTE sim has access to the LTE network and lower.

    the iPhone 5 will only take a nano sim, those only comes in LTE.

    To be honest, you're not missing much with LTE at all. the only thing you'll notice is a huge battery drain from LTE and 3G

Similar Threads

  1. Replies: 14
    Last Post: 08-24-2014, 04:18 AM
  2. I just saw a yellow Lumia 920 - no LTE?
    By snaqvi91 in forum Nokia Lumia 920
    Replies: 7
    Last Post: 04-09-2013, 12:18 PM
  3. Replies: 6
    Last Post: 02-19-2013, 06:48 PM
  4. Rogers Lumia 920 on Bell no LTE?
    By xalasten in forum Nokia Lumia 920
    Replies: 0
    Last Post: 02-03-2013, 08:32 PM
  5. Rogers Lumia 920 price is $711 on the box?
    By garconcn in forum Nokia Lumia 920
    Replies: 5
    Last Post: 12-04-2012, 07:23 PM

Posting Permissions