Get ready for beta!

Prepare for Halo Wars 2 Blitz Mode beta: Everything you need to know!

One Windows

Microsoft is building a new Windows 10 Shell for PC, Mobile and Xbox

On the Inside

Everything you need to know about the Xbox Insider Program

Beautiful compromises

Surface Studio review: you'll want one, even if you don't need one

3-in-1

Is this the Surface Phone? Microsoft awarded patents for foldable devices

Windows Central Offers

MCSE Certification bundle is just $39

Even more improvements

All the changes found in Windows 10 build 15007!

Games as a Service

What does the cancellation of Scalebound mean for future Xbox exclusives?

Windows Central Offers

Save $90 on these FRESHeBUDS Pro Magnetic Bluetooth Earbuds

Returning for 2017

We're back with an new episode of #AskDanWindows

Lifetime Subscription

VPNSecure is currently 91% off

Our favorite things

The Best of CES 2017 Awards

Infinity Edge in your hand

The XPS 13 2-in-1 is the Dell convertible we've always wanted

Project Valerie

Razer just made a laptop with three — THREE! — 17-inch 4K displays. 😱

Great design from Palo Alto

HP's CES 2017 releases are truly gorgeous PCs

Intel and Google's big day

CES 2017 Day Two: New laptops, new phones, and old ideas made new

Take five is better than ever

The updated Lenovo ThinkPad X1 packs Kaby Lake chips and zero bloatware

Everything we know about the next Xbox: Project Scorpio

UWPowered

'Game Mode' for Windows 10 will power Xbox One and Scorpio games too

Buyer's guide

Best accessories for Microsoft Surface Book

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
Like Tree1Likes
  • 1 Post By slashd0t
  1. Achilles Heal's Avatar
    Member

    Posts
    20 Posts
       #1  
    I have an AT&T branded Lumia 920. I put a Telus SIM into the phone, and it seems to be working - it sends/receives texts and calls fine, and displays the signal info with a 4G label. However the internet connection isn't working. Can someone explain why?

    The model is RM-820_nam_att_100.

    The frequencies I've been told that it supports are:

    • GSM/GPRS/EDGE: Supporting 3GPP Bands 2 (1900), 3 (1800), 5 (850) and 8 (900)
    • HSPA+/WCDMA: Supporting 3GPP Bands 1 (2100), 2 (1900), 5 (850) and 8 (900)
    • LTE: Supporting 3GPP Bands 2 (1900), 4 (1700/2100), 5 (850) and 17 (700)


    Thanks!
  2. slashd0t's Avatar
    Member

    Posts
    170 Posts
    Global Posts
    259 Global Posts
    #2  
    You need the APN setup .. Best thing to do is install the Access Point app, it will find the Telus APN and set it up for you:

    access point | Windows Phone Apps+Games Store (United States)
    Laura Knotek likes this.
  3. Achilles Heal's Avatar
    Member

    Posts
    20 Posts
       #3  
    Fixed, thanks!

Similar Threads

  1. Lumia 920 Bricked - not responding at all.
    By jwinch2 in forum Nokia Lumia 920
    Replies: 27
    Last Post: 12-31-2012, 12:29 PM
  2. LG WCP-700 does not work with the Lumia 920
    By ramrandhawa in forum Nokia Lumia 920
    Replies: 2
    Last Post: 12-11-2012, 12:29 AM
  3. AT&T Preorder Lumia 920 - Not On Time
    By garak0410 in forum Windows Phone 8
    Replies: 11
    Last Post: 11-10-2012, 06:24 PM
  4. AT&T Preorder Lumia 920 - Not On Time
    By garak0410 in forum Windows Phone 8
    Replies: 10
    Last Post: 11-09-2012, 02:12 PM
  5. Replies: 8
    Last Post: 09-15-2012, 10:17 PM

Posting Permissions