One Windows

Microsoft is building a new Windows 10 Shell for PC, Mobile and Xbox

On the Inside

Everything you need to know about the Xbox Insider Program

Beautiful compromises

Surface Studio review: you'll want one, even if you don't need one

3-in-1

Is this the Surface Phone? Microsoft awarded patents for foldable devices

Windows Central Offers

MCSE Certification bundle is just $39

Even more improvements

All the changes found in Windows 10 build 15007!

Games as a Service

What does the cancellation of Scalebound mean for future Xbox exclusives?

Windows Central Offers

Save $90 on these FRESHeBUDS Pro Magnetic Bluetooth Earbuds

Returning for 2017

We're back with an new episode of #AskDanWindows

Lifetime Subscription

VPNSecure is currently 91% off

Our favorite things

The Best of CES 2017 Awards

Infinity Edge in your hand

The XPS 13 2-in-1 is the Dell convertible we've always wanted

Project Valerie

Razer just made a laptop with three — THREE! — 17-inch 4K displays. 😱

Great design from Palo Alto

HP's CES 2017 releases are truly gorgeous PCs

Intel and Google's big day

CES 2017 Day Two: New laptops, new phones, and old ideas made new

Take five is better than ever

The updated Lenovo ThinkPad X1 packs Kaby Lake chips and zero bloatware

Everything we know about the next Xbox: Project Scorpio

UWPowered

'Game Mode' for Windows 10 will power Xbox One and Scorpio games too

Buyer's guide

Best accessories for Microsoft Surface Book

Oh, what a year!

Windows Central Best of 2016 Awards

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 7 of 7
  1. JJ Win's Avatar
    Member

    Posts
    4 Posts
       #1  
    My Nokia Lumia 920 is not charging for some odd reason. I was using the lumia awhile ago and was letting it charge. When I plugged it back in to charge again it wasn't connecting, it hasn't popped up the sound or icon that it is charging. I have tried connecting it to the PC and in wall charger and I also have tried plugging a different charger cord into it and nothing has worked. Any ideas?
  2. JJ Win's Avatar
    Member

    Posts
    4 Posts
       #2  
    Bump?
  3. jfa1's Avatar
    Member

    Posts
    2,564 Posts
    Global Posts
    2,647 Global Posts
    #3  
    have you tried a soft reset
  4. denzilla's Avatar
    Member

    Posts
    227 Posts
    Global Posts
    354 Global Posts
    #4  
    I have this issue from time to time. Sometimes there is also a long delay from the time you plug it in till it actually indicates its charging. Figured the USB port in mine was crap.
  5. JJ Win's Avatar
    Member

    Posts
    4 Posts
       #5  
    Yes, I've tried a soft reset and a hard reset.
  6. JJ Win's Avatar
    Member

    Posts
    4 Posts
       #6  
    I figured out it wasn't working when it was at like 79% and i tried unplugging it for a few minutes and plugging it back in, still no results. I have also tried 3 different chargers without any result either.
  7. Daniel Ratcliffe's Avatar
    Retired Moderator

    Posts
    3,046 Posts
    Global Posts
    4,703 Global Posts
    #7  
    Sounds to me as though the port in the phone that receives the charge is borked. Take it to a Nokia Care Store.

Posting Permissions