Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 39
Like Tree8Likes
  1. Kevin Russell's Avatar
    Member

    Posts
    10 Posts
       #1  
    So, I purchased the 920 yesterday to replace a lost iPhone 5 and I now can't receive iMessages from iPhone users. I can send to them but can't receive back. No issue with non-iPhone users. AT&T support has informed me that this is an iMessage issue and just sends me to the Apple support folks.

    Is there anyway to resolve this?
  2. ExcaliburII's Avatar
    Member

    Posts
    115 Posts
    Global Posts
    122 Global Posts
    #2  
    get them to turn off imessage on their iPhones.
  3. sstockss's Avatar
    Member

    Posts
    3 Posts
    #3  
    have them delete your contact in their phone and re-add you. happened to every single one of my iphone friends when i switched.
    Thanked by:
  4. Curtieson's Avatar
    Member

    Posts
    1,321 Posts
    Global Posts
    1,330 Global Posts
    #4  
    How the what? You can send iMessages from a Windows Phone?

    What's next...we can send Black Berry Messages?
    nbktonic likes this.
  5. ttsoldier's Avatar
    Member

    Posts
    2,239 Posts
    Global Posts
    2,912 Global Posts
    #5  
    Quote Originally Posted by Curtieson View Post
    How the what? You can send iMessages from a Windows Phone?

    What's next...we can send Black Berry Messages?
    Well this is what I am wondering...
    nbktonic likes this.
  6. Kevin Russell's Avatar
    Member

    Posts
    10 Posts
       #6  
    No, I'm just sending a text to contacts (assume it's regular SMS) but when they reply they are replying with an iMessage and my number is still linked to iMessage. Working on testing sstocks solution...
    Thanked by:
    Jastow 
  7. Kevin Russell's Avatar
    Member

    Posts
    10 Posts
       #7  
    As in it is still linked to iMessage on their end with my contact information they have for me.
  8. brianlg's Avatar
    Member

    Posts
    55 Posts
    #8  
    Quote Originally Posted by sstockss View Post
    have them delete your contact in their phone and re-add you. happened to every single one of my iphone friends when i switched.
    Yep. This is what you have to do. Its silly, but it fixes it
  9. JMBasquiat's Avatar
    Member

    Posts
    191 Posts
    #9  
    Quote Originally Posted by Kevin Russell View Post
    No, I'm just sending a text to contacts (assume it's regular SMS) but when they reply they are replying with an iMessage and my number is still linked to iMessage. Working on testing sstocks solution...
    That's a bug with iMessage. You can't send/receive iMessages unless you have an iPhone or iPod. Apple doesn't allow it. You want to send them SMSs, and you want them to do the same (wait until the text field turns green for SMS, iMessage is blue).

    This is an iMessage bug, not a WP thing.

    The Apple Bug That Let Us Spy on a Total Stranger's iPhone
  10. Curtieson's Avatar
    Member

    Posts
    1,321 Posts
    Global Posts
    1,330 Global Posts
    #10  
    It isn't a bug really...it is just in their contacts.

    IIRC....I thought on iOS you had to mark wither each contact owned an iPhone or not, and if they had an iPhone it unlocked iMessage and FaceTime. They just need to remove the marker that says what type of iPhone you have and it should fix it. The suggestion of completely removing the contact does that same thing, just a more difficult process.
  11. Kevin Russell's Avatar
    Member

    Posts
    10 Posts
       #11  
    Ok, this is maddening now. My brother deleted my contact on his iPhone and re-added me but I still can't receive a text from him. however, his wife just bought the new HTC Windows phone and is able to receive imessages. Would it have anything to do with the fact that online when logged into my AT&T account it still shows me as owning the iPhone. Customer Support said it take 24-48 hrs before that switches over. Not sure why that would have any impact though.
  12. alpinestars1z's Avatar
    Member

    Posts
    1,457 Posts
    Global Posts
    2,094 Global Posts
    #12  
    This happens because iMessage is still activated for your number so when other iPhones text you it sends iMessages rather than text messages. Borrow someone's iPhone, stick your SIM in, then turn off iMessage.
    Phone History (hopefully in order): Samsung SGH-D407 > AT&T (HTC) Tilt > Sony Ericsson W580 > Blackberry Curve 8900 > Sony Ericsson C901 > HTC Touch Pro 2 > Blackberry 9700 > iPhone 3GS > Motorola Defy > Blackberry 9650 > iPhone 4 > Nokia E71 > Dell Venue Pro > HTC Titan > HTC Titan II > Lumia 900 + Samsung Galaxy Exhibit > Nokia Lumia 920 + Nokia Lumia 521 + Motorola RAZR V3xx
    Last updated: 05/13/2013
  13. Kevin Russell's Avatar
    Member

    Posts
    10 Posts
       #13  
    Curtieson,
    I see no such marker in Contacts on my iPad.
  14. Kevin Russell's Avatar
    Member

    Posts
    10 Posts
       #14  
    Quote Originally Posted by alpinestars1z View Post
    This happens because iMessage is still activated for your number so when other iPhones text you it sends iMessages rather than text messages. Borrow someone's iPhone, stick your SIM in, then turn off iMessage.
    That is a pain in the ***. I guess I can do that with my wife's iPhone but it's going to scare the crap out of her for me to do that. May have to go to AT&T store and let them do it so I don't get blamed if everything crashes.
  15. Kevin Russell's Avatar
    Member

    Posts
    10 Posts
       #15  
    Wait...this is a brand new SIM card since my old SIM card is obviously still with my lost iPhone. Why would my new SIM card have me linked with iMessage?
  16. alpinestars1z's Avatar
    Member

    Posts
    1,457 Posts
    Global Posts
    2,094 Global Posts
    #16  
    Quote Originally Posted by Kevin Russell View Post
    Wait...this is a brand new SIM card since my old SIM card is obviously still with my lost iPhone. Why would my new SIM card have me linked with iMessage?
    Well you still have the same number right? I think that's how it works, by number. The old SIM card should be inactive now if they gave you a new one.
    Phone History (hopefully in order): Samsung SGH-D407 > AT&T (HTC) Tilt > Sony Ericsson W580 > Blackberry Curve 8900 > Sony Ericsson C901 > HTC Touch Pro 2 > Blackberry 9700 > iPhone 3GS > Motorola Defy > Blackberry 9650 > iPhone 4 > Nokia E71 > Dell Venue Pro > HTC Titan > HTC Titan II > Lumia 900 + Samsung Galaxy Exhibit > Nokia Lumia 920 + Nokia Lumia 521 + Motorola RAZR V3xx
    Last updated: 05/13/2013
  17. HeyCori's Avatar
    Mod Emeritus

    Posts
    5,275 Posts
    Global Posts
    5,300 Global Posts
    #17  
    Everyone's missing out on the easiest solution... replace all your friend's iPhones with Lumia 920s.
  18. Kevin Russell's Avatar
    Member

    Posts
    10 Posts
       #18  
    Yes, same number. Guess I'll run by AT&T store and see if they can do this for me.
  19. uswebworx's Avatar
    Member

    Posts
    34 Posts
    #19  
    Its an Apple thing, I went through it to until i deactivated the phone through itunes and asked AT&T to delete that phone
  20. ftap's Avatar
    Member

    Posts
    89 Posts
    Global Posts
    91 Global Posts
    #20  
    The problem is you "lost" you iphone 5. Unfortunately you needed to sign off imessage first with the iphone. I know it's not practical (since you lost the iphone). But it's common knowledge this is a severe problem with imessage.

    I figured this out the hard way when I constantly was switching from iPhone to Galaxy S3 and Lumia 900 last year.

    Like the other posters say. It will take some time. You can request all other users sign off imessage first and you send them a text and have them reply. But it's a pain in the ****.

    Do you have an iPad? You will notice on iPad that their reply messages are being received by imessage servers. But you won't see them unless you sign in with another idevice.
    Thanked by:
  21. EauRouge's Avatar
    Member

    Posts
    67 Posts
    Global Posts
    1,681 Global Posts
    #21  
    As people have hinted towards, its an Apple issue. Your friends iphone is still trying to send an imessage, since thats what it thinks you have. Deleting and readding won't always work, it takes some time for Apple's servers to sort everything out (I believe its 2 weeks). Till then, just hate on Apple for causing you such inconvenience and send emails
  22. Sinabu's Avatar
    Member

    Posts
    226 Posts
    Global Posts
    267 Global Posts
    #22  
    Go to apples support site log into your Apple ID go to account and Devices and Then remove the old iphone from your number.
    Red Lumia 920
  23. realwarder's Avatar
    Member

    Posts
    1,268 Posts
    #23  
    This is the answer:

    Annoyed the heck out of my wife...

    When you leave an Apple iPhone you must turn off iMessaging on your phone in the settings before you change to any other type of phone.

    If you do not, then your phone number is registered in the Apple servers as being tied to iMessage and you will have trouble.

    Typically one on one, you will still get messages, but they will be delayed because phones try to iMessage first. But for group messages, you will never get the message.

    If you no longer have your phone you will have to use someone else's phone and put your SIM in the phone, start it, and turn iMessaging off. If you are on a different carrier, it won't matter if the phone is on Wifi.

    After you have turned that off, your friends will still need to power down and restart their phones before everything works.

    Welcome to the world of Apple lock down... you are not permitted to leave Apple. How dare you even think about it!
  24. realwarder's Avatar
    Member

    Posts
    1,268 Posts
    #24  
    Quote Originally Posted by Sinabu View Post
    Go to apples support site log into your Apple ID go to account and Devices and Then remove the old iphone from your number.
    I can confirm that this does not work... been there, tried it.
  25. Derrick4Real's Avatar
    Member

    Posts
    4 Posts
    Global Posts
    156 Global Posts
    #25  
    could you go to an apple store. insert your sim in one of their phones, log into imessage with your apple id, then disable it, then log off. and remove your sim.
    Thanked by:
    rdubmu 
Page 1 of 2 12 LastLast

Similar Threads

  1. Can't Receive Text Messages
    By mrozanski in forum Nokia Lumia 900
    Replies: 7
    Last Post: 05-10-2014, 01:40 PM
  2. I can't received PIN on GroupMe.
    By Gavin Ding in forum Windows Phone Apps
    Replies: 0
    Last Post: 12-26-2012, 10:43 AM
  3. Can send email but can't receive
    By jcar302 in forum Nokia Lumia 900
    Replies: 5
    Last Post: 12-14-2012, 07:03 AM
  4. Can't receive updates?
    By emptyy in forum Nokia Lumia 920
    Replies: 1
    Last Post: 11-30-2012, 12:26 AM
  5. Can't Receive Tango video calls on my Lumia 900
    By apRPhle in forum Nokia Lumia 900
    Replies: 6
    Last Post: 05-19-2012, 11:18 PM

Posting Permissions