Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 24 of 24
Like Tree5Likes
  • 1 Post By Shakeel88
  • 1 Post By barareklam
  • 1 Post By wjlim3
  • 1 Post By Dinkumschnauger
  • 1 Post By Shakeel88
  1. Shakeel88's Avatar
    Member

    Posts
    15 Posts
       #1  
    Hello all.

    I find my lumia 920 takes sometimes upto 30 seconds to lock and i noticed this after the here update. When it works its fantastic however sometimes i have also noticed that it will not update my location as im driving.

    Any body got any tips on how too fix this

    Kind regards
    Thanked by:
    abel920 likes this.
  2. realwarder's Avatar
    Member

    Posts
    1,258 Posts
    #2  
    Try running a different program when it doesn't appear to lock.

    E.g. I was out in the car the other day. Ran HERE maps and it was lost showing home. Switched to Nokia Drive and it instantly found me.

    Looks like another bug to me...
  3. barareklam's Avatar
    Member

    Posts
    202 Posts
    Global Posts
    203 Global Posts
    #3  
    I am having similar problems. GPS usually locks in a few seconds, then as I moves, GPS shows I am still in one place? I open then maps or "sports tracker app" just to refresh GPS, sometimes it refresh, sometimes not. Restarted my L920 several times.
    So sometimes it works perfectly.
    And then again sometimes just cant Lock GPS.
    Tried offline. Downloaded map first.
    Tried flight mode.
    Tried Soft reset.
    And I just can not trust it will work when I need it :(
    Thanked by:
    abel920 likes this.
  4. wjlim3's Avatar
    Member

    Posts
    99 Posts
    #4  
    Same problem as me....I am trying to troubleshoot it. The only solution nokia support offered me was to hard reset it, which I haven't tried.

    Can you help me test it out by confirming that you have turned off wifi when this issue occurs? I am testing out the theory that with wifi on, this problem tends to occur whereas with wifi off, the problem doesn't occur.

    I have tried both with data on and off and it still recurs. Just wondering whether wifi could be the culprit instead.
    Thanked by:
    abel920 likes this.
  5. Shakeel88's Avatar
    Member

    Posts
    15 Posts
       #5  
    Hi i don't think that is the issue with me. I first thought it was the case but its not that either. Before i got the here update is was working a lot better
    Thanked by:
  6. Shakeel88's Avatar
    Member

    Posts
    15 Posts
       #6  
    Hello again. It has nothing to do with a case. It seems now it is very hit and miss wont guide me anywhere
    Last edited by Shakeel88; 03-09-2013 at 08:56 AM.
  7. johninsj's Avatar
    Member

    Posts
    373 Posts
    #7  
    Quote Originally Posted by Shakeel88 View Post
    Hello again. It has nothing to do with a case. It seems now it is very hit and miss wont guide me anywhere
    That would be a hardware problem with your GPS then.
  8. Shakeel88's Avatar
    Member

    Posts
    15 Posts
       #8  
    It was fine before the here update
  9. Shakeel88's Avatar
    Member

    Posts
    15 Posts
       #9  
    Just downloaded gmaps and same issue
  10. joshuaj11's Avatar
    Member

    Posts
    6 Posts
    #10  
    I'm having the same issue after the HERE maps update ... Before that my navigation was working with no problems ... Now it loses track of my location ..
  11. arshan9o's Avatar
    Member

    Posts
    1 Posts
    #11  
    Same here. None of the HERE maps work using GPS alone. WinGPS info app on the other hand gives accurate GPS info quickly.
  12. Shakeel88's Avatar
    Member

    Posts
    15 Posts
       #12  
    Tried wingps but that also give wrong location. Its out by about 600m. Is there anyway to calibrate the gps
  13. Shakeel88's Avatar
    Member

    Posts
    15 Posts
       #13  
    Quote Originally Posted by wjlim3 View Post
    Can you help me test it out by confirming that you have turned off wifi when this issue occurs? I am testing out the theory that with wifi on, this problem tends to occur whereas with wifi off, the problem doesn't occur.

    I have tried both with data on and off and it still recurs. Just wondering whether wifi could be the culprit instead.
    Ok i just got home and when i turned on the wifi it picked up the correct location. The wifi help triangulate the location. However with the wifi of it doesnt work
  14. #14  
    Not that this is particularly helpful but...I have the same issue. GPS is real slow to locate me. Also, I'm not sure how to activate the compass, could someone help? Thx
    Thanked by:
    abel920 likes this.
  15. Shakeel88's Avatar
    Member

    Posts
    15 Posts
       #15  
    Really didn't expect this from Nokia I though the nav was a main feature
    Thanked by:
    abel920 likes this.
  16. abel920's Avatar
    Member

    Posts
    498 Posts
    Global Posts
    502 Global Posts
    #16  
    Same issue! We almost got lost, and almost crashed in the middle of the intersection because GPS didn't update!
  17. Shakeel88's Avatar
    Member

    Posts
    15 Posts
       #17  
    I think I may have found a fix. I opened the app and let it sit for a while around a minute it then found my location accurately. I tried this with the maps and drive and also yell.com app. Try this
  18. barareklam's Avatar
    Member

    Posts
    202 Posts
    Global Posts
    203 Global Posts
    #18  
    I think I have tried everything. Wi-Fi off too....
    I can only say, sometimes it works perfectly... sometimes nothing helps, not even restart of phone... it just can't lock GPS. Once I waited for 10 minutes hoping "now" but nothing...... can't really stay parked on a road for a 10 minutes and wait and hope...... :(
  19. ammarmalik2011's Avatar
    Banned

    Posts
    712 Posts
    Global Posts
    727 Global Posts
    #19  
    Quote Originally Posted by abel920 View Post
    Same issue! We almost got lost, and almost crashed in the middle of the intersection because GPS didn't update!
    Yeah you can't blame GPS for almost crashing in the middle of an intersection. That's like saying I blame the cook book for this cut on my finger from a knife.
  20. barareklam's Avatar
    Member

    Posts
    202 Posts
    Global Posts
    203 Global Posts
    #20  
    I can confirm that today I started Here drive, app locked GPS in few sec with precision of 50 meter, then not moving. Turned off Wi-fi and magic happens, Here drive work like a charm.
    Anyone else who can confirm that turn off Wi-Fi helps?
  21. wjlim3's Avatar
    Member

    Posts
    99 Posts
    #21  
    i can sort of confirm that for mine, (fingers crossed), so far since I made the conscious effort of turning off wifi each time, it works well....soooo far :P
  22. EliteMikes's Avatar
    Member

    Posts
    104 Posts
    #22  
    My first 920 locked really fast. The 2nd one can take up to 10 seconds.
  23. Nakazul's Avatar
    Member

    Posts
    287 Posts
    #23  
    600 meters wrong: CHECK
    Slow to get good readings: CHECK
    Problem before "Here": CHECK
    More/less prob. since WP7: CHECK
  24. barareklam's Avatar
    Member

    Posts
    202 Posts
    Global Posts
    203 Global Posts
    #24  
    I can confirm that today HERE had issues to lock, even with Wi-Fi off..... worked good yesterday.....

Similar Threads

  1. GPS takes forever to lock in
    By Teamteal in forum Nokia Lumia 900
    Replies: 6
    Last Post: 12-03-2013, 09:39 AM
  2. Taking a long time to charge.....goodness!
    By vingengo in forum Nokia Lumia 920
    Replies: 6
    Last Post: 11-28-2012, 10:55 AM
  3. Time to take a stand!!(Netflix)
    By schweetzeke in forum Windows Phone Apps
    Replies: 15
    Last Post: 01-27-2012, 10:04 AM
  4. Focus Takes Long Time to Charge
    By baseballbert in forum Samsung Focus
    Replies: 15
    Last Post: 09-23-2011, 11:49 PM
  5. Replies: 12
    Last Post: 04-17-2011, 07:35 PM

Posting Permissions