1. Shakeel88's Avatar
    Hello all.

    I find my lumia 920 takes sometimes upto 30 seconds to lock and i noticed this after the here update. When it works its fantastic however sometimes i have also noticed that it will not update my location as im driving.

    Any body got any tips on how too fix this

    Kind regards
    03-08-2013 10:17 PM
  2. realwarder's Avatar
    Try running a different program when it doesn't appear to lock.

    E.g. I was out in the car the other day. Ran HERE maps and it was lost showing home. Switched to Nokia Drive and it instantly found me.

    Looks like another bug to me...
    03-08-2013 10:31 PM
  3. barareklam's Avatar
    I am having similar problems. GPS usually locks in a few seconds, then as I moves, GPS shows I am still in one place? I open then maps or "sports tracker app" just to refresh GPS, sometimes it refresh, sometimes not. Restarted my L920 several times.
    So sometimes it works perfectly.
    And then again sometimes just cant Lock GPS.
    Tried offline. Downloaded map first.
    Tried flight mode.
    Tried Soft reset.
    And I just can not trust it will work when I need it :(
    03-09-2013 01:23 AM
  4. wjlim3's Avatar
    Same problem as me....I am trying to troubleshoot it. The only solution nokia support offered me was to hard reset it, which I haven't tried.

    Can you help me test it out by confirming that you have turned off wifi when this issue occurs? I am testing out the theory that with wifi on, this problem tends to occur whereas with wifi off, the problem doesn't occur.

    I have tried both with data on and off and it still recurs. Just wondering whether wifi could be the culprit instead.
    03-09-2013 01:59 AM
  5. Shakeel88's Avatar
    Hi i don't think that is the issue with me. I first thought it was the case but its not that either. Before i got the here update is was working a lot better
    03-09-2013 06:42 AM
  6. Shakeel88's Avatar
    Hello again. It has nothing to do with a case. It seems now it is very hit and miss wont guide me anywhere
    Last edited by Shakeel88; 03-09-2013 at 07:56 AM.
    03-09-2013 07:35 AM
  7. johninsj's Avatar
    Hello again. It has nothing to do with a case. It seems now it is very hit and miss wont guide me anywhere
    That would be a hardware problem with your GPS then.
    03-09-2013 08:48 AM
  8. Shakeel88's Avatar
    It was fine before the here update
    03-09-2013 08:50 AM
  9. Shakeel88's Avatar
    Just downloaded gmaps and same issue
    03-09-2013 09:02 AM
  10. joshuaj11's Avatar
    I'm having the same issue after the HERE maps update ... Before that my navigation was working with no problems ... Now it loses track of my location ..
    03-09-2013 09:18 PM
  11. arshan9o's Avatar
    Same here. None of the HERE maps work using GPS alone. WinGPS info app on the other hand gives accurate GPS info quickly.
    03-09-2013 09:55 PM
  12. Shakeel88's Avatar
    Tried wingps but that also give wrong location. Its out by about 600m. Is there anyway to calibrate the gps
    03-10-2013 01:19 AM
  13. Shakeel88's Avatar
    Can you help me test it out by confirming that you have turned off wifi when this issue occurs? I am testing out the theory that with wifi on, this problem tends to occur whereas with wifi off, the problem doesn't occur.

    I have tried both with data on and off and it still recurs. Just wondering whether wifi could be the culprit instead.
    Ok i just got home and when i turned on the wifi it picked up the correct location. The wifi help triangulate the location. However with the wifi of it doesnt work
    03-10-2013 04:34 PM
  14. Dinkumschnauger's Avatar
    Not that this is particularly helpful but...I have the same issue. GPS is real slow to locate me. Also, I'm not sure how to activate the compass, could someone help? Thx
    03-10-2013 04:46 PM
  15. Shakeel88's Avatar
    Really didn't expect this from Nokia I though the nav was a main feature
    03-10-2013 05:20 PM
  16. abel920's Avatar
    Same issue! We almost got lost, and almost crashed in the middle of the intersection because GPS didn't update!
    03-10-2013 05:22 PM
  17. Shakeel88's Avatar
    I think I may have found a fix. I opened the app and let it sit for a while around a minute it then found my location accurately. I tried this with the maps and drive and also yell.com app. Try this
    03-10-2013 06:11 PM
  18. barareklam's Avatar
    I think I have tried everything. Wi-Fi off too....
    I can only say, sometimes it works perfectly... sometimes nothing helps, not even restart of phone... it just can't lock GPS. Once I waited for 10 minutes hoping "now" but nothing...... can't really stay parked on a road for a 10 minutes and wait and hope...... :(
    03-11-2013 03:14 AM
  19. ammarmalik2011's Avatar
    Same issue! We almost got lost, and almost crashed in the middle of the intersection because GPS didn't update!
    Yeah you can't blame GPS for almost crashing in the middle of an intersection. That's like saying I blame the cook book for this cut on my finger from a knife.
    03-11-2013 03:47 AM
  20. barareklam's Avatar
    I can confirm that today I started Here drive, app locked GPS in few sec with precision of 50 meter, then not moving. Turned off Wi-fi and magic happens, Here drive work like a charm.
    Anyone else who can confirm that turn off Wi-Fi helps?
    03-11-2013 12:21 PM
  21. wjlim3's Avatar
    i can sort of confirm that for mine, (fingers crossed), so far since I made the conscious effort of turning off wifi each time, it works well....soooo far :P
    03-12-2013 06:16 AM
  22. EliteMikes's Avatar
    My first 920 locked really fast. The 2nd one can take up to 10 seconds.
    03-12-2013 06:42 AM
  23. Nakazul's Avatar
    600 meters wrong: CHECK
    Slow to get good readings: CHECK
    Problem before "Here": CHECK
    More/less prob. since WP7: CHECK
    03-12-2013 07:04 AM
  24. barareklam's Avatar
    I can confirm that today HERE had issues to lock, even with Wi-Fi off..... worked good yesterday.....
    03-12-2013 08:19 AM

Similar Threads

  1. GPS takes forever to lock in
    By Teamteal in forum Nokia Lumia 900
    Replies: 6
    Last Post: 12-03-2013, 08:39 AM
  2. Taking a long time to charge.....goodness!
    By vingengo in forum Nokia Lumia 920
    Replies: 6
    Last Post: 11-28-2012, 09:55 AM
  3. Time to take a stand!!(Netflix)
    By schweetzeke in forum Windows Phone Apps
    Replies: 15
    Last Post: 01-27-2012, 09:04 AM
  4. Focus Takes Long Time to Charge
    By baseballbert in forum Samsung Focus
    Replies: 15
    Last Post: 09-23-2011, 10:49 PM
  5. Replies: 12
    Last Post: 04-17-2011, 06:35 PM
LINK TO POST COPIED TO CLIPBOARD
";