Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. ismeyall's Avatar
    Member

    Posts
    8 Posts
       #1  
    I bought an unlocked 920 from a guy from craigslist's. At 1st I thought it was a scam, because of the many people who can't get their phones unlocked.. But surprisingly this phone works. The problem is getting the my internet to work is spotty with my T-Mobile network. I live in Houston, where I'm suppose to have LTE. When the phone gets the LTE signal, I can not get my internet to work, but when my signal drops to 4g my internet works. I called T-Mobile and they told me their engineers would look into and try to fix in the 72 hour time frame(Wed 4-10-13)... My question is this a network problem or is it because my phone isn't meant to be used on the T-Mobile network?

    Thanks
    Last edited by ismeyall; 04-09-2013 at 08:55 AM.
  2. youssefelra's Avatar
    Member

    Posts
    11 Posts
    #2  
    If your phone is the 1308 update its from that. Nokia will be releasing another update to fix that problem very soon, so dont worry your phone is okay just the update was buggy.
    Thanked by:
  3. ismeyall's Avatar
    Member

    Posts
    8 Posts
       #3  
    Thank-you!!
  4. ceraf's Avatar
    Member

    Posts
    77 Posts
    Global Posts
    80 Global Posts
    #4  
    Also, if you're using the Access Point settings app, try switching to another APN and then back to the one you use.
  5. jmajid's Avatar
    Member

    Posts
    308 Posts
    Global Posts
    318 Global Posts
    #5  
    also from houston - i would be interested to hear about your progress with this as I am thinking of moving from ATT to TMo, but just not sure of the coverage here...

    I have asked this is plenty of times - is there any way i can see what cell ID i am actually using and the signal strength? That way i can maybe use antennaweb to check the info...
    I know in the SW (towards Hwyt 59/Beltway8) i have intermittent good data with ATT
  6. peacefulberry's Avatar
    Member

    Posts
    695 Posts
    Global Posts
    941 Global Posts
    #6  
    Quote Originally Posted by jmajid View Post
    also from houston - i would be interested to hear about your progress with this as I am thinking of moving from ATT to TMo, but just not sure of the coverage here...

    I have asked this is plenty of times - is there any way i can see what cell ID i am actually using and the signal strength? That way i can maybe use antennaweb to check the info...
    I know in the SW (towards Hwyt 59/Beltway8) i have intermittent good data with ATT
    just visit T-Mobile.com and check your coverage. You can put in your street address or general zip codes for home, work, and frequently visited locations.

Similar Threads

  1. At work No Signal inside then no LTE sig outside until reboot!
    By CoZmicShReddeR in forum Nokia Lumia 920
    Replies: 12
    Last Post: 02-18-2013, 11:10 AM
  2. Change from 3G to 2G (or whatever) causes no signal
    By lfjj in forum Windows Phone 8
    Replies: 0
    Last Post: 01-02-2013, 12:43 AM
  3. No signal, but...signal?
    By shinygerbil in forum HTC 8X
    Replies: 3
    Last Post: 11-21-2012, 06:28 AM
  4. No Data Connection After Low Signal/No Signal
    By Fuzzy John in forum Windows Phone 7
    Replies: 1
    Last Post: 02-24-2012, 01:16 PM
  5. No signal, means no data connection?
    By jeff4L in forum HTC HD 7 / 7s
    Replies: 6
    Last Post: 04-20-2011, 01:58 AM

Posting Permissions