Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 17 of 17
Like Tree1Likes
  • 1 Post By yeungl
  1.    #1  
    I have a Red NOKIA LUMIA 920, and AT&T provided me with the unlock code. But the phone will not bring up the unlock screen when a "foreign" SIM is inserted.

    I have unlocked a different (Black) Nokia Lumia 920 before this, and that time I had no problem seeing the unlock screen immediately with a T-Mobile SIM. So this does seem strange. I've seen other report this problem, but no solutions posted.

    Here is what I have tried, and what I know is definitely not the problem to save some time on responses:

    I tried putting in many different T-Mobile SIM cards, some active on my T-Mobile corporate, multi-line account, and some that are new but not active T-Mobile SIMs. The phone simply won't ask me for the unlock code. The phone boots up with a T-Mobile SIM and shows, for a moment, the Airplane Mode icon, then up comes an icon of a SIM card with a Circle with Diagonal Bar symbol over it. After that, the message in the tile is No Service

    I know that the problem is not a bad unlock code -- Yes, I do have the unlock code -- AT&T supplied it to me. But there is no way to enter it. (unless somebody out there knows a keypad entry which will force the unlock screen to appear. And those instructions only appear on the net for earlier Lumias, not for the 920.

    Nope, I don't have the original ATT SIM card to insert (I bought this phone on Craigslist), but the Lumia 920 seems to resist taking the ##782# command anyway, saying that command is not in its library.

    Yes, I have factory-reset the phone, and the first time I did that, it locked up in the famous gear-lock position. I was able to rescue from that, and re-factory-reset (twice since), each time to completion. All shows as OK in Settings>About. And, no, the reset is not the problem here, because the problem existed before and after.

    Yes, the phone does recognize the T-Mobile SIM and in Settings>About it shows the SIM number and the T-Mobile phone number -- almost as if the phone were already unlocked. But the phone says No Service instead of T-Mobile and won't operate.

    Yes, the phone will check for updated software and do a number of things when WiFi is on, and I think it is doing these things by communicating with Microsoft (I have an Outlook account set up with WindowsPhone and I have a Nokia account also set up. So the phone almost operates -- it communicates, although I'm not sure with which entity it's communicating to get the updates. But the phone won't ask for the unlock code.

    No, the phone IMEI is not blacklisted -- it's a clean IMEI with both T-Mobile and with AT&T. I called each and had the IMEI checked against their blacklist. That doesn't seem to be the problem here.

    I know I am not the only person to experience this. The only issue is that nobody seems to know the way to force a Nokia Lumia 920 to bring up the unlock screen.

    Is this how a phone would behave if all 10 tries at unlock failed + all 32 tries at PUK SIM unlock failed? Could that have happened before I bought the phone? And if so, would the phone simply never again ask for unlock code?

    The phone is under warranty from Nokia, still, and I can send it in -- I think that they will fix it (maybe just with a swap-out for a reconditioned as so often happens -- they just move over the IMEI to keep it the same).

    There was one time where, briefly, after boot-up with the live T-Mobile SIM: after the Airplane Mode ICON disappeared, I saw T-Mobile appear on the phone tile for a few seconds before the phone went to No Service. So it's almost as if the phone is already unlocked, and checks-in using my T-Mobile active SIM, and then gets an instruction from somewhere to show No Service. Odd. But maybe not helpful to diagnostics

    If you've seen this with a Nokia Lumia 920, where the unlock code request screen simply won't appear, please post so it can be solved. If there is a set of keystrokes specific to Red Nokia Lumia 920 which will bring up the unlock screen, please provide these (for all colors, if you have them). This could help a lot of people solve a problem with no posted solution currently on the net anywhere.

  2. #2  
    Go to phone, dial ##3282#, from the 3 dots below select settings, polling = 3 and network = auto, everything else off, press windows button and come to home. If it still doesn't work then open phone settings, cellular, network selection automatic, if not then try manual and see if it brings up any network at all. Select Tmobile manually.

    Let us know if any of it works.
  3.    #3  
    After sending ##3282# in Phone, the reply is:

    Something Happened and we couldn't complete this action.

    As for setting T-Mobile as carrier under Settings, "Automatic" doesn't work - I've set it manually, and back to "Automatic" without any luck in getting the unlock screen.

    I can set the network there manually, and have done so, trying both of two T-Mobile choices:

    T-Mobile G

    T-Mobile 4G
    (I assume this one is HSPA)

    I've also tried setting to:

    AT&T LTE, 4G, G

    And the most recent time I tried it (just now), I got a 4th network choice which appears as simply a number:

    I'm thinking this one is one of the off-brand GSMs, or maybe even this phone does CDMA frequencies and it's MetroPCS?

    Anyway, none of them make the SIM work, or bring up the Unlock screen, either before or after re-booting. Also, none of them cause ##3282# to work, either before or after rebooting.

    ADDITIONAL INFO: I'm on firmware revision 1314 which I believe is the latest.

    Perhaps the most diagnostically relevant thing is the response to the ##3282# -- it's either an error message, or a message that tips us off that something is still locked. (Now if only we could force up the unlock screen so I could enter my unlock code...

    Still open to any ideas...
  4. #4  
    Can you flash your firmware as a last resort?
  5.    #5  
    I'm thinking that I could flash my firmware, and I considered doing that, but ran into an issue that I'll need to work out. Or maybe somebody knows the issue?

    When I run NaviFirmPlus executable, it can't seem to contact the server (which starts out set to Nokia Care Suite and needs to access it, but can't). I get this message on any server I pick in NaviFirm Plus:

    (Triangle Exclamation Icon) Service specific exception:

    I'm wondering if I need to pop open a port in my firewall, but I haven't researched that yet... it probably doesn't belong in this thread. But once I fix that issue, yes, I can flash it. Then perhaps we'll see if the issue is indeed with the phone.
  6. #6  

    Use this link

    What you are seeing is Nokia has blocked the firmware access. The link above will show you how to download the firmware through Nokia.
    Last edited by pankaj981; 05-27-2013 at 11:01 PM.
  7. Jurgi Taboada's Avatar

    2 Posts
    Do you solve this problem.? I cant go into ##3283 menu i get the same error that you, with Orange in Spain

    Any help will be apreciated
  8. #8  
    It has been disabled in certain firmwares, only option is to flash your phone to a firmware that has the Field Test mode enabled.
  9. Jurgi Taboada's Avatar

    2 Posts
    Many thanks, where can i found how to flash the firmware step by step?

  10. Jeremie 1's Avatar

    4 Posts
    Hey Nelso, I have the exact same problem, but can't seem to solve it, did you?

  11. jkidd01's Avatar

    107 Posts
    Dial ##7820# on your dial screen. An unlock prompt appears. Enter your unlock code. You can do this no matter what SIM is inserted and even if no SIM is inserted.
    Thanked by:
  12. Jeremie 1's Avatar

    4 Posts
    I dial it, the screen goes black and goes back to the dial screen, no unlock screen.

    Do you have any other suggestions?

    Tks man!
  13. yeewiz's Avatar

    287 Posts
    just a thought, but the instructions I got from AT&T yesterday to unlock my Samsung Focus says that if you fail to unlock in 5 attempts, the phone will be permanently locked to the AT&T network. Don't know when they started doing this but seems like that cold be happening here?
  14. jkidd01's Avatar

    107 Posts
    Quote Originally Posted by Jeremie 1 View Post
    I dial it, the screen goes black and goes back to the dial screen, no unlock screen.

    Do you have any other suggestions?

    Tks man!
    Make sure you have Extras and Info installed and updated.
  15. #15  
    Nelson, I've read most of your post and got understood that You've got more than an unlocking code.
    I've got a yellow Nokia Lumia 920, which I bought from eBay.com but unfortunately locked to AT&T. I tried some third parties to unlock it but return in no code. I tried the seller, who said he can not take responsibility to unlock it. Thus I tried At&t myself, but their police states that a user can unlock up to five phones once it has clean IMEI and the user should be active or former At&t customer.
    Therefore and since I am out of the USA and am not their customer, I would like to ask if you could get me a code from the At&t and I would pay what you ask. If yes, by you or a relative of yours, please send me your proposal in a private message. Best regards.
    Note: According to the seller, the phone is more than 12 months old and all the service had been paid.
  16. yeungl's Avatar

    5 Posts
    The key is ##7820#
  17. #17  
    This worked with my nokia lumia 720 to find the unlock screen.Thankyou

Similar Threads

  1. Nokia Lumia 920 won't charge/boot
    By trevormacro in forum Nokia Lumia 920
    Replies: 36
    Last Post: 03-29-2015, 04:44 PM
  2. Help please! Lumia 920 won't power up
    By lottidah in forum Nokia Lumia 920
    Replies: 43
    Last Post: 06-05-2014, 04:39 AM
  3. Replies: 1
    Last Post: 03-23-2013, 01:16 PM
  4. (WTS) AT&T Black Nokia Lumia 920
    By Alex Rodriguez Jr. in forum Marketplace Archive
    Replies: 6
    Last Post: 03-20-2013, 01:52 PM
  5. Nokia Lumia 920 won't lock
    By Krakowiak Tomasz in forum Nokia Lumia 920
    Replies: 6
    Last Post: 03-17-2013, 11:10 AM

Posting Permissions