1. JammyGitz's Avatar
    Hi I just wanted to keep a log in case people wanted to know about other people's repair experiences.

    So I wasn't getting any signal at home and only 2G inside where signal should be H+ or strong 3G. Also, it would get stuck on the gears on every reset.

    I went into the Phones4U store on the 25th June and showed them the phone. They sent it away that evening.

    The repair status changed from 'Awaiting Delivery' to 'Being Assessed' on the 28th June.

    As of 1st July. The status is now 'In Repair Process'.

    UPDATE: I just checked the repair status (http://www.phones4urepairtracking.co.uk) on 2nd July at 11:20am and the phone status shows as 'Repaired'.

    I am of course dubious about it because in certain places I can get a good signal so they may not have actually done anything to it.
    07-02-2013 05:20 AM
  2. Mark Everingham's Avatar
    I am having a similar signal problem with my L920 at my work but it hasn't been from day one of the phone, it is only in the last few weeks.
    I believe that the phone is fine, A friend came in with his S4 on EE and had no signal also, and that it is Orange (EE) changing masts for the roll out of 4G or taking an age to repair a faulty mast that is causing my problems.
    I am trying to get answers and out of my contract because the service is now unusable at a place I spend most of the day.
    07-02-2013 05:37 AM
  3. JammyGitz's Avatar
    For me it's the phone because my SIM works fine in other phones.
    07-02-2013 08:02 AM
  4. JammyGitz's Avatar
    The status of my phone is now showing as "RF Test Pass"
    07-02-2013 08:05 AM
  5. Mark Everingham's Avatar
    May sound like a stupid question but are these other phones you are trying 4G or 3G?
    I think a firmware update which EE have ignored or don't think is needed was supposed to fix signal issues
    Lumia 920

    As you say my issues could be completely different to yours, but I still believe the creation of one EE network is causing my problem, and I wouldn't trust their coverage checker as far as I can throw a car, it also says I should have great signal in my location, even indoors.
    07-02-2013 09:39 AM
  6. JammyGitz's Avatar
    May sound like a stupid question but are these other phones you are trying 4G or 3G?
    I think a firmware update which EE have ignored or don't think is needed was supposed to fix signal issues
    Lumia 920

    As you say my issues could be completely different to yours, but I still believe the creation of one EE network is causing my problem, and I wouldn't trust their coverage checker as far as I can throw a car, it also says I should have great signal in my location, even indoors.

    My GF has the same phone on the same network and my SIM worked perfectly in her phone. She can get about 3 bars of 3G in my house and I got "no service"
    07-03-2013 07:17 AM
  7. JammyGitz's Avatar
    Phone status is now showing as "Collected Awaiting Delivery to Store" so hopefully I can pick it up in the next day or 2
    07-03-2013 07:18 AM
  8. JammyGitz's Avatar
    Well I got my phone back and guess what.... still no signal. They have taken the screen off though and gotten the dust out and also fixed whatever was moving about inside. But I'm sitting here with "No service" on one phone and full signal on another. Dunno what the f*ck to do now, they're a bunch of idiots.
    07-05-2013 12:00 PM
  9. Muessig's Avatar
    Sometimes I can get no signal at all in the same place people on the same network are on. I'm sure you've tried it many times, but whenever I have no signal and it just won't budge turning the phone off and on can get a signal. In my area, the EE signal as a whole has gone downhill (I presume it's because I'm on 3G Orange and they're trying to expand their 4G network.) I even had Orange call me one day out of the blue to ask how my signal was, and they said they're working to try to improve it. Unfortunately none of this helps you.

    Maybe they reflashed your device's radio. Wait a few days and see if your signal has generally improved or if it's just black spots instead of generally having no signal now? If there's literally no change at all I would suggest sending it back and hoping for a replacement device.
    07-06-2013 12:44 AM
  10. JammyGitz's Avatar
    I took it back to the shop and sent it away for repair again. They better fix it this time or else.
    07-09-2013 04:45 AM
  11. VegaNovus's Avatar
    I took it back to the shop and sent it away for repair again. They better fix it this time or else.
    #ragequit

    I had this issue and took it to the shop, I told them I get no signal, they sent it off for repair, got it back, same issue, sent it off for repair again, got it back, same issue. I was then gonna do some serious damage to somebody at EE, then a couple of days later, my 920 got stolen at a gig lol :(

    Luckily my insurance company paid up and got me a new phone that works and is carrier unlocked.

    yey?
    07-09-2013 06:20 AM
  12. JammyGitz's Avatar
    #ragequit

    I had this issue and took it to the shop, I told them I get no signal, they sent it off for repair, got it back, same issue, sent it off for repair again, got it back, same issue. I was then gonna do some serious damage to somebody at EE, then a couple of days later, my 920 got stolen at a gig lol :(

    Luckily my insurance company paid up and got me a new phone that works and is carrier unlocked.

    yey?
    The service is pretty crap. When I had my iphone[s] I just had to take it to the istore and they gave me a new one no questions asked. With Nokia you have to send it off to their silly repair centre and all they do it reflash it. Like I haven't already tried that??
    07-11-2013 03:09 AM
  13. VegaNovus's Avatar
    For me, the problem didn't lie with Nokia, the problem lied with EE.

    No communication skills.
    07-11-2013 07:58 AM
  14. JammyGitz's Avatar
    Finally got my phone back yesterday and they had fixed it. The problem was stated as "mechanical fault". Not only did they fix the aerial, they put a new body on, which was a bonus because I dropped it just after I bought it and it had a dent in the corner.
    Muessig likes this.
    07-19-2013 04:18 AM
  15. rockstarzzz's Avatar
    I have had the same issue for months now. However, for me EE (Orange) has acknowledged that this is due to continued mast shut down and restart process occurring in London. They are upgrading and removing extra masts so that same mast can give 3G and 4G. Apparently this is meant to increase my connectivity and speed by end of July. I have been refunded 75% of my line rental from March-July. They said they've had complaints from not just Nokia users but also iPhone 5 users. I am not sure if swapping or repairing phone may help. Also like someone else mentioned, we NEED that firmware update that EE has blatantly ignored and WPCentral has not covered it on front page inspite of about 3 huge threads here in the forum. That update which rolled out for AT&T to fix their 4G and 3G issue, needs to be rolled out by EE too.
    07-19-2013 06:18 AM

Similar Threads

  1. Build Nokia 920 on TMobile data issues
    By Andy Dunn in forum Nokia Lumia 920
    Replies: 4
    Last Post: 07-03-2013, 12:17 AM
  2. My Lumia 920 malfunction, suspect after install VBA8
    By teho ais in forum Nokia Lumia 920
    Replies: 2
    Last Post: 07-02-2013, 10:52 AM
  3. Nokia Philippines Teasing Lumia Amber Update
    By John Balacano in forum Windows Phone 8
    Replies: 4
    Last Post: 07-02-2013, 08:16 AM
  4. Lumia 920 Product Placement
    By Nogitsune Micah in forum Nokia Lumia 920
    Replies: 3
    Last Post: 07-02-2013, 03:46 AM
  5. FM Radio on Lumia 920? it was there on Lumia 800
    By wayne310 in forum Nokia Lumia 920
    Replies: 1
    Last Post: 07-02-2013, 03:29 AM
LINK TO POST COPIED TO CLIPBOARD