Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. michail71's Avatar
    Member

    Posts
    681 Posts
       #1  
    I know the 920 is well know for slow charging and sudden rapid battery discharge but today it actually died on me while charging.

    With nothing major running in the background that I'm aware of I noticed my phone when into low batter mode. There wasn't a reason think it should happen because it had only been off the charger for 4 hours. I put it on the charge and the charging indicator came on. After 10 minutes it powered down and then went into the "off but charging" mode.
  2. Epic Pie's Avatar
    Member

    Posts
    48 Posts
    #2  
    Make sure that you are using a stable power source, and try performing soft reset (down volume button + power button, hold it until it vibrates)
    Last edited by Epic Pie; 08-14-2013 at 02:16 PM.
  3. KKRLessey's Avatar
    Member

    Posts
    166 Posts
    #3  
    Do a soft reset. My 920 when I restart it while charging, it causes the empty battery indicator to come on after the restart. And the battery is sometimes full. The soft reset fixes it.
  4. Xpider_MX's Avatar
    Member

    Posts
    736 Posts
    #4  
    Mine is not slow for full charging, and battery life s good.
  5. b3rni3703's Avatar
    Member

    Posts
    202 Posts
    #5  
    no issues here.... so far that is... battery life is stable (currently .91 percent/hr) discharge speed.
  6. michail71's Avatar
    Member

    Posts
    681 Posts
       #6  
    Quote Originally Posted by KKRLessey View Post
    Do a soft reset. My 920 when I restart it while charging, it causes the empty battery indicator to come on after the restart. And the battery is sometimes full. The soft reset fixes it.
    A soft reset wasn't really necessary. The battery drained dead while it was charging. Which does a phone reset. It has gone from 0% around 2PM up to 77% at 4PM so I suppose that isn't too slow. It's still plugged in to the same cable it died on.

    I think it was whatever causes the random sudden battery drains some of us get. The phone was draining faster than it could charge. When I had a battery graph running I caught a few of those drains on the graph. It practically makes a vertical dive on the graph instead of a gentle slope. All this while nothing of significance apparently running in the background.

    I've seen the charger sometimes not able to keep up with Here Drive running.

Similar Threads

  1. Replies: 5
    Last Post: 04-26-2014, 12:30 PM
  2. Trident Aegis+Wireless Charging Shell
    By anon5954042 in forum Nokia Lumia 925
    Replies: 6
    Last Post: 02-04-2014, 11:19 PM
  3. Error while manually flashing rom
    By rockinguy in forum Nokia Lumia 620
    Replies: 5
    Last Post: 08-15-2013, 08:51 AM
  4. Replacement battery for Lumia 520
    By nonchy1991 in forum Nokia Lumia 520
    Replies: 3
    Last Post: 08-14-2013, 10:34 PM
  5. Replies: 1
    Last Post: 08-14-2013, 08:18 AM

Posting Permissions