Surface Pwn 5

Surface Pro 5, Project NEON details leaked on LinkedIn?

XP-YESSSSSSS

Dell's already awesome XPS 15 gets even better in 2017

Surface table meets Windows 10

Yes, we did put Windows 10 on the original Surface table ... and it rocks

Cream o' the crop

Before buying a Microsoft laptop, check out our pick for the absolute best

Simple and secure, just the way I like it

We think Windows 10 Cloud is a great idea, here's why

uber micro

Halo Wars 2 has something for everyone. Here's our full review.

Oldie but goldie

We reviewed Microsoft's decade-old Surface table

Creators Update comin' at ya

These are the coolest new features in the next big Xbox One update (video)

Buyer's guide

The Razer Blade 14 is the best laptop Razer has to offer

Windows 10 app gems

10 terrific Windows 10 apps you should be using

Tower of power

Here's what we think of Dell's XPS Tower Special Edition

Quite a deal

Grab the complete C# coding bootcamp for $41!

Your go-to laptop guide

Introducing our ultimate laptop buyer's guide

Listen here

Attn Android and iPhone users: What you need to know about Windows phone

Old is new?

The original Surface Pro still holds its own in the 2-in-1 world

Xbox Greenlight?

No, internet, Microsoft isn't opening Xbox to all UWP games

Falling in love

HP Envy 34 review: An ultrawide curved all-in-one after my heart

2015 machine in 2017?

Surface 3 still holds its own in 2017

Let Kodi cut your cord

You should be using Kodi for Windows 10

Leader of the pack

HP's Spectre x360 15 just might be the best all-around laptop

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 16 of 16
  1. cheesydevil's Avatar
    Member

    Posts
    3 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #1  
    Hi good people of the WPcentral forum

    I have encountered a most severe and annoying problem, My Phone thinks it is charging even when it is not plugged in. somtimes it even alternates like crazy causing the sound fx for charge to reapeat over and over again. this is an issue I can not live with because it causes my phone to go flat very quick as my screen will only stay off on the odd chance the phone remains on the charge icon and whats more I can't turn on battery saver because the phone thinks it's charging.

    I have removed the battery dozens of times and have trawled the internet and the closest thing I find is people having problems with dodgy battery icon behaviour on this handset (omnia 7). I am on mango and my phone has decided it can not charge from the wall plug anymore. sorry for the wordiness I just thought I'd get it all out in one post.
  2. palandri's Avatar
    Retired Moderator

    Posts
    7,589 Posts
    Global Posts
    9,915 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #2  
    I would try a factory reset. If that doesn't work, you need to get your phone replaced.
  3. TheWeeBear's Avatar
    Retired Moderator

    Posts
    5,293 Posts
    Global Posts
    5,295 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #3  

    Yes, that's not good, sound like something's not right with your USB socket cheesydevil. (shorting?)

    As palandri suggested try a reset and if nothing changes get a replacement. :)
  4. cheesydevil's Avatar
    Member

    Posts
    3 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #4  
    I have been dreading that answer, what do you think about the chance the micro usb is screwed? I have no warranty as I bought the phone outright overseas and it does not have international warranty. I had to flash the ROM with an offical optus one when it got here but I doubt thats the problem or everyone in the country would be reporting it.
  5. TheWeeBear's Avatar
    Retired Moderator

    Posts
    5,293 Posts
    Global Posts
    5,295 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #5  
    Oh dear, it does sound as if the USB socket is more likely to be faulty than a software problem. :(

    Other than reseting or flashing not a lot else to suggest. :(
  6. cheesydevil's Avatar
    Member

    Posts
    3 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #6  
    dag nabbit! I want my mummy!
  7. richu75's Avatar
    Member

    Posts
    32 Posts
    Global Posts
    71 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #7  
    I've seen the same behaviour on my Omnia while charging it with an older USB charger.
    I my case it was an older BB charger with a micro-USB cable. Seems the Samsung charger provides more power.

    Do you charge it with an non original adapter?
  8. TheWeeBear's Avatar
    Retired Moderator

    Posts
    5,293 Posts
    Global Posts
    5,295 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #8  
    Quote Originally Posted by richu75 View Post
    I've seen the same behaviour on my Omnia while charging it with an older USB charger.
    I my case it was an older BB charger with a micro-USB cable. Seems the Samsung charger provides more power.

    Do you charge it with an non original adapter?
    That would be good, if that's all it was richu75. :)
  9. richu75's Avatar
    Member

    Posts
    32 Posts
    Global Posts
    71 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #9  
    I've checked the chargers.

    The omnia's original charger delivers 5 volts at 0,7 Amps.
    In my case the old blackberry charger delivered 5 Volts at 0,5 Amps.

    Quite a difference.
    misfituk likes this.
  10. Workshop2's Avatar
    Member

    Posts
    34 Posts
    Global Posts
    35 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #10  
    Hey all, after my sister dropped my phone I am having the same problem with my Omnia. Did you ever figure this out?
  11. PrittStickFace's Avatar
    Member

    Posts
    7 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #11  
    This has started happening to me since last night.

    Since fully charging it overnight and disconnecting it for 1 hour this morning, my battery has already drained to 55%! The screen keeps turning itself on every 5 seconds. I've currently got my phone on vibrate to stop the beeping!

    Did anyone find a fix?
    Last edited by PrittStickFace; 11-06-2012 at 04:22 AM. Reason: spelling
  12. Reflexx's Avatar
    Member

    Posts
    4,483 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #12  
    This is risky, but worked for me.

    If you look in your USB port, you'll notice that the part that's supposed to be in the middle might be making contact with the side wall. I used a very small tool to move that middle island away from the side wall so it would stop touching.

    That was on my Samsung Focus over a year ago. It still works fine now.
    PrittStickFace likes this.
  13. PrittStickFace's Avatar
    Member

    Posts
    7 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #13  
    Quote Originally Posted by Winning Guy View Post
    This is risky, but worked for me.

    If you look in your USB port, you'll notice that the part that's supposed to be in the middle might be making contact with the side wall. I used a very small tool to move that middle island away from the side wall so it would stop touching.

    That was on my Samsung Focus over a year ago. It still works fine now.
    Thanks for the rapid response. :)

    I just tried it with a small jewellers screwdriver. I will see how it goes and report back.

    Battery now at 6% needs another charge!
  14. Reflexx's Avatar
    Member

    Posts
    4,483 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #14  
    Good luck!
  15. PrittStickFace's Avatar
    Member

    Posts
    7 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #15  
    It worked OK for about 2 hours and then the battery completely died. When i fully charged it and disconnected it happened again.

    Tried with the screwdriver again and its been fine for the rest of the day.

    Thanks Winning Guy!
  16. Paul Bamforth's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #16  
    My phone has been going crazy recently with the same fault. I did as suggested regarding moving the central bit inside the USB and it seems to be working fine now.
    xandros9 likes this.

Tags for this Thread

Posting Permissions