Get ready for beta!

Prepare for Halo Wars 2 Blitz Mode beta: Everything you need to know!

One Windows

Microsoft is building a new Windows 10 Shell for PC, Mobile and Xbox

On the Inside

Everything you need to know about the Xbox Insider Program

Beautiful compromises

Surface Studio review: you'll want one, even if you don't need one

3-in-1

Is this the Surface Phone? Microsoft awarded patents for foldable devices

Windows Central Offers

MCSE Certification bundle is just $39

Even more improvements

All the changes found in Windows 10 build 15007!

Games as a Service

What does the cancellation of Scalebound mean for future Xbox exclusives?

Windows Central Offers

Save $90 on these FRESHeBUDS Pro Magnetic Bluetooth Earbuds

Returning for 2017

We're back with an new episode of #AskDanWindows

Lifetime Subscription

VPNSecure is currently 91% off

Our favorite things

The Best of CES 2017 Awards

Infinity Edge in your hand

The XPS 13 2-in-1 is the Dell convertible we've always wanted

Project Valerie

Razer just made a laptop with three — THREE! — 17-inch 4K displays. 😱

Great design from Palo Alto

HP's CES 2017 releases are truly gorgeous PCs

Intel and Google's big day

CES 2017 Day Two: New laptops, new phones, and old ideas made new

Take five is better than ever

The updated Lenovo ThinkPad X1 packs Kaby Lake chips and zero bloatware

Everything we know about the next Xbox: Project Scorpio

UWPowered

'Game Mode' for Windows 10 will power Xbox One and Scorpio games too

Buyer's guide

Best accessories for Microsoft Surface Book

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 26
  1. Stig's Avatar
    Member

    Posts
    103 Posts
    Global Posts
    437 Global Posts
       #1  
    So, I'm hearing that the official 7.8 (7.10.8858.136) update is available for the Omnia 7.

    I can't get the .cab method to work for me. My current OS version is 7.10.8773.98.

    Anyone else had success?
  2. kivancio's Avatar
    Member

    Posts
    91 Posts
    Global Posts
    92 Global Posts
    #2  
    Hey guys, did you hear anything about OMNIA 7 (T-Mobile Deutschland). I mean deutsche telekom. Of course for the 7.8 update ? They never skipped an update. If you hear anything please let me know.
  3. Sotal's Avatar
    Member

    Posts
    11 Posts
    #3  
    I got the update immediately here in the US (Without having to force update). My Omnia 7 is from Europe (as it was never officially sold in the US), unlocked and T-Mobile branded.

    As with others who were lucky enough to update to 7.8; there was a total of 3 updates.

    Edit: Just for background, the only update I had to force was Mango (7720), therefore I don't have the updated Firmware revision, mine is still 2424.11.1.11
    Last edited by Sotal; 01-31-2013 at 05:25 PM.
  4. Coreldan's Avatar
    Member

    Posts
    2,514 Posts
    Global Posts
    2,591 Global Posts
    #4  
    My fiancee has one, but she isnt home so cant confirm if her European unlocked Omnia 7 has it.
  5. monospaced's Avatar
    Member

    Posts
    2 Posts
    #5  
    Got it on my Omnia 7 (European, unlocked, unbranded), by forcing it - and that took a while, since it first gave me the 8779 update, then 8783 and only then 8858 (edit: so you need to force another update, if you get 8779 or 8783 and then again the message "no update available")
  6. Stig's Avatar
    Member

    Posts
    103 Posts
    Global Posts
    437 Global Posts
       #6  
    Quote Originally Posted by monospaced View Post
    Got it on my Omnia 7 (European, unlocked, unbranded), by forcing it - and that took a while, since it first gave me the 8779 update, then 8783 and only then 8858 (edit: so you need to force another update, if you get 8779 or 8783 and then again the message "no update available")
    Can you clarify exactly what you did to 'force' it please?
  7. Stig's Avatar
    Member

    Posts
    103 Posts
    Global Posts
    437 Global Posts
       #7  
    OK, I managed to do a manual update using the files listed here: xda-developers - View Single Post - [CAB] Official WP7 Updates List up to WP 7.8 + ALL LANGUAGES complete + OEM updates

    I needed 5 language files for my German T-Mobile Omnia 7.

    The upgrade path is from 7.10.8773.98
    First 7.10.8779.8
    Then 7.10.8783.12
    Then 7.10.8858.136

    This leaves me on firmware 2424.11.9.4. Did anyone get a more recent firmware update via the 'official' update via Zune?
  8. BadassMads's Avatar
    Member

    Posts
    1 Posts
    #8  
    Anyone else experiensing sluggish responsetimes after update to 7.8?
    My girlfriend and I both have an updated Omnia 7, and App launching now feel horribly slow, especially when opening the People, Markedplace or email tiles.
    Was looking so forward to 7.8, and now it just seems like an annoyance :(
    Web browsing is also not at all as smooth as it was on 7.5.
  9. Stig's Avatar
    Member

    Posts
    103 Posts
    Global Posts
    437 Global Posts
       #9  
    Quote Originally Posted by Stig View Post
    This leaves me on firmware 2424.11.9.4. Did anyone get a more recent firmware update via the 'official' update via Zune?
    Wow, nearly 1000 views of this thread, and nobody can tell me what firmware they're on after the official update?
  10. nicomesh's Avatar
    Member

    Posts
    1 Posts
    #10  
    I have 2424.12.9.1 with a French Omnia 7 after all the official updates. I had to apply 4 or 5 updates before the 7.8 (I hadn't updated since Mango), and I had to force them with the cable pull trick every time.
    Stig likes this.
  11. kivancio's Avatar
    Member

    Posts
    91 Posts
    Global Posts
    92 Global Posts
    #11  
    maybe they haven't got the update yet ?
  12. #12  
    Quote Originally Posted by BadassMads View Post
    Anyone else experiensing sluggish responsetimes after update to 7.8?
    My girlfriend and I both have an updated Omnia 7, and App launching now feel horribly slow, especially when opening the People, Markedplace or email tiles.
    Was looking so forward to 7.8, and now it just seems like an annoyance :(
    Web browsing is also not at all as smooth as it was on 7.5.
    yes!
    i tried the " seven eighter " method and the phone was updated .. but it was very sluggish and slow ..
    i have t-mobile deutche telekom branded phone and i live in egypt .. the update is not available till now through zune and the force update method is not working for me :(
  13. Stig's Avatar
    Member

    Posts
    103 Posts
    Global Posts
    437 Global Posts
       #13  
    Quote Originally Posted by BadassMads View Post
    Anyone else experiensing sluggish responsetimes after update to 7.8?
    My girlfriend and I both have an updated Omnia 7, and App launching now feel horribly slow, especially when opening the People, Markedplace or email tiles.
    Was looking so forward to 7.8, and now it just seems like an annoyance :(
    Web browsing is also not at all as smooth as it was on 7.5.
    It doesn't appear slower to me.
  14. perbear's Avatar
    Member

    Posts
    85 Posts
    #14  
    Still not seen on my Omnia. I am checking at least twice a day.
  15. #15  
    Quote Originally Posted by Stig View Post
    It doesn't appear slower to me.
    what is your firmware, radio, bootloader numbers?
  16. Stig's Avatar
    Member

    Posts
    103 Posts
    Global Posts
    437 Global Posts
       #16  
    Quote Originally Posted by xtremepharmacist View Post
    what is your firmware, radio, bootloader numbers?
    OS 7.10.8858.136
    Firmware: 2424.11.9.4
    Hardware: 3.15.0.4
    Radio s/w: 2424.11.9.1
    Radio h/w: 0.0.0.800
    Bootloader: 5.9.3.0
    Chip SOC: 0.36.2.0
  17. #17  
    Quote Originally Posted by Stig View Post
    OS 7.10.8858.136
    Firmware: 2424.11.9.4
    Hardware: 3.15.0.4
    Radio s/w: 2424.11.9.1
    Radio h/w: 0.0.0.800
    Bootloader: 5.9.3.0
    Chip SOC: 0.36.2.0
    same as mine!
    didn't you notice any slowing when opening some tiles from the start screen? it's just a bit slower but you'll notice it easily?
  18. stewbra's Avatar
    Member

    Posts
    1 Posts
    #18  
    Quote Originally Posted by xtremepharmacist View Post
    same as mine!
    didn't you notice any slowing when opening some tiles from the start screen? it's just a bit slower but you'll notice it easily?
    With mine, after doing forced update using the zune method only, I have:

    OS 7.10.8858.136
    Firmware: 2424.11.11.2
    Hardware: 3.15.0.4
    Radio s/w: 2424.11.9.1
    Radio h/w: 0.0.0.800
    Bootloader: 5.11.1.8
    Chip SOC: 0.36.2.0

    It seems a tad slower, but I didn't actually notice it until you pointed it out :)

    I hope this helps.
    Stig likes this.
  19. #19  
    Quote Originally Posted by stewbra View Post
    With mine, after doing forced update using the zune method only, I have:

    OS 7.10.8858.136
    Firmware: 2424.11.11.2
    Hardware: 3.15.0.4
    Radio s/w: 2424.11.9.1
    Radio h/w: 0.0.0.800
    Bootloader: 5.11.1.8
    Chip SOC: 0.36.2.0

    It seems a tad slower, but I didn't actually notice it until you pointed it out :)

    I hope this helps.
    thanx for the reply :)
    will we be gettin the firmware and bootloader update even we used the cab method?
    Stig likes this.
  20. Jay Patel19's Avatar
    Member

    Posts
    2 Posts
    #20  
    hey friends , i'm using Samsung Omnia W. I'm from Gujarat,india.

    i just update my phone to 7.8 last month manually with the help of "seveneighter" tool, no issue with that just live tile update issue which was by Microsoft side.

    but today i got new update "OS Version :7.10.8860.142" on my phone...

    hope u'll get very soon....
  21. Coreldan's Avatar
    Member

    Posts
    2,514 Posts
    Global Posts
    2,591 Global Posts
    #21  
    My fiancees Omnia 7 just got a crapton of updates, including 7.8

    Through Zune and "normal means", so no cable pulling or anything else.
  22. #22  
    hi guys I can not update my omnia 7 via Zune but seveneighter doesn't work at my computer how i can update my wp?
  23. #23  
    I used Windows Phone Hackers tool to get my update and it work fine :) Not very exciting but atleast it is updated
    Windows Phone 7.8 - YouTube
  24. Stig's Avatar
    Member

    Posts
    103 Posts
    Global Posts
    437 Global Posts
       #24  
    As above, I've managed to get 7.8 on my Omnia 7 using the cab install method.

    however, I'd like to put this ROM on:
    http://forum.xda-developers.com/showthread.php?t=2010962

    I like to think I am pretty good technically, but I can't follow the instructions. When I reboot my phone (which now runs 7.8) I can't get it into the right mode to accept the image.

    Can anyone assist?
  25. forestred's Avatar
    Member

    Posts
    14 Posts
    #25  
    been on 7.8 since the first roms were leaked, kind of like the one i put on as it tricks the phone into thinking its a lumia which obv is good for the nokia apps etc and marketplace
Page 1 of 2 12 LastLast

Similar Threads

  1. Theme Accent Colours are Ugly on Samsung Omnia 7
    By drg in forum Windows Phone 7
    Replies: 3
    Last Post: 10-18-2011, 07:01 AM

Posting Permissions