Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. palandri's Avatar
    Retired Moderator

    Posts
    7,295 Posts
    Global Posts
    9,522 Global Posts
       #1  
    I have a HTC 7 Trophy running 7.8 that I use for work on AT&T pay as you go. My current personal phone is a Nexus 4 which I just switched to T-Mobile a few months ago. I tested the T-Mobile data this morning. Not bad for 3G+

    Test Date: Jul 10, 2013 7:58:17 AM
    Connection Type: Cell
    Server: Chicago, IL
    Download: 11526 kbps
    Upload: 1865 kbps
    Ping: 79 ms


    510451368.png
    Check out the great deals on Windows Phone Accessories: http://store.wpcentral.com
  2. stmav's Avatar
    Retired Moderator

    Posts
    3,685 Posts
    Global Posts
    3,767 Global Posts
    #2  
    Have you compared your speednet tests to the carrier numbers on root metrics? I'd be curious as to how the numbers matched up.
  3. palandri's Avatar
    Retired Moderator

    Posts
    7,295 Posts
    Global Posts
    9,522 Global Posts
       #3  
    Quote Originally Posted by stmav View Post
    Have you compared your speednet tests to the carrier numbers on root metrics? I'd be curious as to how the numbers matched up.
    It's all over the place from what I see listed.
    Check out the great deals on Windows Phone Accessories: http://store.wpcentral.com
  4. tai4de2's Avatar
    Member

    Posts
    157 Posts
    #4  
    I get 30-40mbit on a Lumia 920 on T-Mobile's LTE around Seattle

Similar Threads

  1. Replies: 27
    Last Post: 07-30-2013, 04:04 PM
  2. SD Card Speed Question for my Lumia 822
    By greedo_greedy in forum Nokia Lumia 822
    Replies: 4
    Last Post: 07-15-2013, 04:56 PM
  3. Talk Mobile problems
    By Palm_forlackofchoice in forum WindowsCentral.com - Site News, Feedback, Help
    Replies: 14
    Last Post: 07-15-2013, 09:32 AM
  4. Replies: 2
    Last Post: 07-08-2013, 12:37 PM

Posting Permissions