05-19-2017 12:11 PM
48 12
tools
  1. tdbmoss's Avatar
    Hmm, I haven't had this issue myself - after you do the hard reset it will go back to being normal W10M rather than Enterprise, then for me applying the package again made it go back to Enterprise. Maybe try a hard reset again (use the key combination when switching the phone on to be sure, the one done through Settings gives you the option to keep provisioned content but I would want to completely clear everything and start afresh if resetting), otherwise all I can suggest is ensure you are using the right .ppkg file (you will find the one I used if you Google "windows 10 mobile enterprise.zip"), rebooting after applying it (not normally needed though), etc. To make the Defer Upgrades tickbox appear you sometimes have to press "check for updates" once and then it will be there the next time, but Enterprise needs to be showing in the About screen before moving on to that step as only Enterprise has that option.
    04-03-2017 10:56 AM
  2. aazswapnil's Avatar
    I went ahead and upgraded to Redstone 14393.953 with interop method. After I'm done testing that I'll start over from WP8.1 again, I'll try it then. Thanks for the reply.
    04-03-2017 12:24 PM
  3. Ehsan Ahmed's Avatar
    everything done perfectly. now keyboard is also working after following internal IME settings. Now I am unable to find the XML licence file from google too to convert W10 into enterprise edition. if any one have this, kindly email me @ <redacted>.
    Or Tell me, how to download this.
    Last edited by RumoredNow; 04-06-2017 at 07:24 PM.
    04-03-2017 08:57 PM
  4. aazswapnil's Avatar
    OK, now I'm getting confused. I've gone back to 8.1 with WDRT, updated again to 10586.107 and now the provisioning package does not work on 10586.107 either, even after hard resetting. I got the package from post #25 on the XDA thread that comes up when I google "windows 10 mobile enterprise.zip". And it worked last time, why it isn't working now is a mystery to me.
    04-05-2017 07:38 AM
  5. aazswapnil's Avatar
    Got it now. Have to remove the sim before hard reset. Having the sim card inserted from hard reset to applying the provisioning package prevents the version change to Enterprise edition.
    anthonyng likes this.
    04-05-2017 01:12 PM
  6. tdbmoss's Avatar
    Thanks for the feedback! That is weird though as I have hard reset with the SIM card in and still been able to apply the Enterprise package myself.
    04-05-2017 03:30 PM
  7. Vilius Bajorinas's Avatar
    Hello all ;) just updated my lumia 920 to WP10, and now I want to upadte it to Enterprise version, but I cant becouse I cant find that provisioning package, I was googling for "windows 10 mobile enterprise.zip", but found nothing... :( Please maybe someone can share it with me? <redacted> :)
    Last edited by RumoredNow; 04-06-2017 at 07:24 PM.
    nick popplewell likes this.
    04-06-2017 03:22 PM
  8. RumoredNow's Avatar
    Guys and Gals,

    For your own protection please do not post personal contact info like email addresses on public forums...

    Unless you like tons of SPAM and risking identity theft.
    Guytronic likes this.
    04-06-2017 07:27 PM
  9. tdbmoss's Avatar
    Another Patch Tuesday, another gift from MSFT for us older Lumia lovers

    wp_ss_20170411_0001.png

    10586.873 (April 2017 cumulative update for the Threshold 2 branch) now available!
    04-11-2017 06:10 PM
  10. Siyabonga Bhengu's Avatar
    Thanks for the look up
    04-25-2017 02:51 AM
  11. anthonyng's Avatar
    Is there a way to remove the enterprise provisioning without hard reset? @tdbmoss
    04-28-2017 12:05 AM
  12. tdbmoss's Avatar
    You can remove it through Settings > Accounts > Provisioning, but that doesn't seem to actually revert the OS edition from Enterprise to standard - I'm not aware of any reason to do that though as Enterprise only adds functionality rather than removing anything. To revert to the Current Branch for your updates rather than the Current Branch for Business, just untick the "defer upgrades" box.
    anthonyng likes this.
    04-28-2017 08:34 AM
  13. HerronScott's Avatar
    The instructions on XDA indicate that "the OS version must be at least 8.10.14219.341 or newer. If the version is lower than required, please update it."

    AT&T only took us up to 8.10.12393.890 so how do I get to the minimum required version (if that is indeed really needed?).

    Scott
    04-29-2017 10:32 AM
  14. ErmanGl59's Avatar
    Hi, is it working in Lumia 630 (RM-976)?
    04-30-2017 01:00 PM
  15. DrChucky's Avatar
    Anyone try this on a Lumia 810 yet?
    04-30-2017 09:39 PM
  16. nick popplewell's Avatar
    Will it work on a 920?
    05-02-2017 03:36 AM
  17. HerronScott's Avatar
    The instructions on XDA indicate that "the OS version must be at least 8.10.14219.341 or newer. If the version is lower than required, please update it."
    AT&T only took us up to 8.10.12393.890 so how do I get to the minimum required version (if that is indeed really needed?).
    I should have mentioned that this is for a 920.

    Scott
    05-05-2017 08:01 AM
  18. nick popplewell's Avatar
    Hello,I have a L920,but I don't have a PC or anything else to upgrade my phone to W10,it's currently running OS version 8.10.14219.341,I got it on eBay really cheap and not long after I got it I messed up the sim card reader,so I got another reader but the repair man wants $50+ to put it in for me,is there anyone in the forums that could fix it for me and update it to W10 please? I'm willing to compensate someone for their time,just pm if anyone is interested or can point me in the right direction,thanks in advance.
    05-06-2017 11:38 AM
  19. tdbmoss's Avatar
    Will it work on a 920?
    Hi, is it working in Lumia 630 (RM-976)?
    Anyone try this on a Lumia 810 yet?
    It should work on any Lumia (and some third-party devices) running 8.1 as far as I know, as long as you use the correct set of files for your device from the WIM file that is available on XDA - if they have your device listed in the post that I linked to then you should be good to go.

    The instructions on XDA indicate that "the OS version must be at least 8.10.14219.341 or newer. If the version is lower than required, please update it."
    I'd be inclined to give it a try anyway, I suspect it will work from 8.1, if not then you can always hard reset or re-image with the WDRT to get back to where you were.

    Alternatively download a firmware image from lumiafirmware.com if there is one for a different carrier that is the version that you want - if it is for exactly the same RM-xxx device as yours it *should* work, might be worth sticking to the same region too just in case, no responsibility taken for bricked devices! I did this on a 625 a while back and it removed the carrier boot logos and apps and gave me a completely unbranded image even after upgrading to W10M afterwards.
    05-14-2017 04:36 AM
  20. HerronScott's Avatar
    I'd be inclined to give it a try anyway, I suspect it will work from 8.1, if not then you can always hard reset or re-image with the WDRT to get back to where you were.

    Alternatively download a firmware image from lumiafirmware.com if there is one for a different carrier that is the version that you want - if it is for exactly the same RM-xxx device as yours it *should* work, might be worth sticking to the same region too just in case, no responsibility taken for bricked devices! I did this on a 625 a while back and it removed the carrier boot logos and apps and gave me a completely unbranded image even after upgrading to W10M afterwards.
    Thanks for the reply!

    Scott
    05-14-2017 11:45 AM
  21. tdbmoss's Avatar
    No worries - by the way, to flash an image with the WDRT other than the one that your device's built-in product code tells it to download, the command I used was:

    thor2 -mode uefiflash -ffufile "C:\RM941_3058.50000.1424.0003_RETAIL_eu_euro1_231_03_452380_prd_signed.ffu" -do_full_nvi_update -do_factory_reset -reboot

    Obviously change the .ffu file name to the name of the file that you download from lumiafirmware.com, which must be for the same RM-xxx product as your device.

    It might be worth it if you want to remove any carrier boot logo, etc (doing this persists even after upgrading to W10M and hard resetting - it will only go back to how it was if you reset with the WDRT again and use the branded image that it wants to download). But I think this is a bit riskier than the other things in this how-to and it is at your own risk

    Also another cumulative update for Threshold 2 (10586.916) dropped this month (May 2017) right on schedule for both PC and Mobile users on the Current Branch for Business
    05-14-2017 04:07 PM
  22. Creamy Jamie's Avatar
    My SD card is not functioning properly after I updated my phone to Win 10 mobile build 10586.916. How can fix this?
    05-15-2017 12:15 PM
  23. tdbmoss's Avatar
    I haven't had that issue myself I'm afraid, I don't know of any possible fixes other than a hard reset (and maybe also formatting the memory card) if you haven't already tried that - unless anyone else has had similar issues and knows of a fix?
    05-19-2017 12:11 PM
48 12

Similar Threads

  1. Windows Insider
    By RaRa85 in forum Nokia Lumia 1020
    Replies: 7
    Last Post: 02-16-2017, 08:22 PM
  2. Replies: 2
    Last Post: 02-16-2017, 10:08 AM
  3. Brexit fallout brings UK price bumps to Surface Book and Surface Pro 4
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-15-2017, 10:30 AM
  4. Microsoft announces Windows Insider Program for Business
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-15-2017, 10:00 AM
LINK TO POST COPIED TO CLIPBOARD