1. coolibop's Avatar
    I installed a fresh copy of the creators update last week from USB on my surface pro 3, and I notice that even with all apps toggled 'off' under allowing use of location services, the location services icon is always on unless I turn off the entire service all together.

    Is there a way to see what may be using my location? What could possibly be using my location all the time? What's the point of the taskbar icon if it is always on?
    04-12-2017 06:07 AM
  2. kevin lamarche's Avatar
    Im having the same issue.
    04-12-2017 08:41 PM
  3. Luis Enrique Araque's Avatar
    I installed a fresh copy of the creators update last week from USB on my surface pro 3, and I notice that even with all apps toggled 'off' under allowing use of location services, the location services icon is always on unless I turn off the entire service all together.

    Is there a way to see what may be using my location? What could possibly be using my location all the time? What's the point of the taskbar icon if it is always on?
    Same issue here, I did a clean install today and location service is always active :C (fku nsa xD)
    04-12-2017 11:46 PM
  4. mkzwo's Avatar
    Same here on Surface Pro 4. The problem is caused by the "System Settings Broker" background task. If you end the task the location icon disappears. Unfortunately the tasks starts again automatically after a while and the story starts all over again. Any suggestions what to do?
    04-13-2017 10:34 AM
  5. mkzwo's Avatar
    The location service and system settings broker restarts immediately when you open the info center...
    04-16-2017 11:16 AM
  6. davidhk129's Avatar
    Folks,
    Have you tried this tutorial ?


    https://www.tenforums.com/tutorials/...dows-10-a.html

    Option Four
    To Turn On or Off Location Service for your Account and Apps using a REG file

    Note : I have not tried it myself, but the tutorial is from an extremely reliable source. I never have doubt on its tutorial treasure trove.
    04-16-2017 06:22 PM
  7. wvigotty's Avatar
    I have this same issue. If I shut down and start up (fast startup turned off) or restart my computer, the location service icon functions normally until, as mkzwo described, I click on and open the action center. Then the location service icon appears. Once the icon appears, it's stays stuck until next shut down or restart. As a test I left my computer on all day, 24 hours, without opening the action center and the location service icon functioned normally the whole time.
    04-17-2017 10:34 AM
  8. coolibop's Avatar
    Same here on sp3. Must be a bug.
    04-19-2017 10:18 AM
  9. Roy Khoh's Avatar
    Same behaviour on Surface 3.
    I believe this is the cause of the excessive battery drain I've been experiencing since updating to 15063.xx.
    Even tried a "refreshed installation" only to the experience the same "bug".
    04-25-2017 06:35 AM
  10. Roy Khoh's Avatar
    Thought it would be good if we (who are experiencing this) could all register this with Feedback Hub

    Someone else reported this a week ago.
    https://aka.ms/C9dtrk

    if there are others - post them here, I'll upvote each of them.
    On mobile devices, I think this is a pretty important one, battery time is king in the mobile space.
    04-25-2017 06:54 AM

Similar Threads

  1. Replies: 5
    Last Post: 04-23-2017, 08:06 AM
  2. Surface Book running latest Windows Creators Update 1703 sluggish scrolling
    By Rafael Yousuf in forum Microsoft Surface Book
    Replies: 8
    Last Post: 04-19-2017, 08:13 AM
  3. Windows Central app on start screen
    By DallasXanadu in forum Windows 10 Mobile
    Replies: 8
    Last Post: 04-13-2017, 02:57 PM
  4. Why OneNote on my Windows Phones can't sync anymore?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 04-12-2017, 03:40 AM
  5. Replies: 0
    Last Post: 04-11-2017, 07:04 PM
LINK TO POST COPIED TO CLIPBOARD