The king is back baby!

Resident Evil 7: Biohazard Review — a series risen from the dead

Fitness Apps

Keep your New Year's fitness resolutions with these great Windows 10 apps!

One Windows

Microsoft is building a new Windows 10 Shell for PC, Mobile and Xbox

Get ready for beta!

Halo Wars 2 Blitz: Game modes, beginner's tips, and more

On the Inside

Everything you need to know about the Xbox Insider Program

Beautiful compromises

Surface Studio review: you'll want one, even if you don't need one

3-in-1

Is this the Surface Phone? Microsoft awarded patents for foldable devices

Windows Central Offers

MCSE Certification bundle is just $39

Even more improvements

All the changes found in Windows 10 build 15007!

Games as a Service

What does the cancellation of Scalebound mean for future Xbox exclusives?

Windows Central Offers

Save $90 on these FRESHeBUDS Pro Magnetic Bluetooth Earbuds

Returning for 2017

We're back with an new episode of #AskDanWindows

Lifetime Subscription

VPNSecure is currently 91% off

Our favorite things

The Best of CES 2017 Awards

Infinity Edge in your hand

The XPS 13 2-in-1 is the Dell convertible we've always wanted

Project Valerie

Razer just made a laptop with three — THREE! — 17-inch 4K displays. 😱

Great design from Palo Alto

HP's CES 2017 releases are truly gorgeous PCs

Intel and Google's big day

CES 2017 Day Two: New laptops, new phones, and old ideas made new

Take five is better than ever

The updated Lenovo ThinkPad X1 packs Kaby Lake chips and zero bloatware

Everything we know about the next Xbox: Project Scorpio

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 18 of 18
Like Tree1Likes
  • 1 Post By unstoppablekem
  1.    #1  
    So I have a windows 8 PC. Switched from a Mac. This PC came with nvidia graphics, but it can only read the integrated intel graphics. How do I get it to show the nvidia graphics?
  2. Leonardo Ferrer's Avatar
    Member

    Posts
    12 Posts
    Global Posts
    13 Global Posts
    #2  
    Type dxdiag and run the program to verify your PC having the Nvidia Card.
  3.    #3  
    Quote Originally Posted by Leonardo Ferrer View Post
    Type dxdiag and run the program to verify your PC having the Nvidia Card.
    Nope, doesn't show. Only the intel hd graphics 4000. But I'm positive this PC comes with nvidia GeForce 640.
  4. Paulsalame's Avatar
    Member

    Posts
    25 Posts
    #4  
    click windows then run then msinfo32 and then go to display and see if the nvidia shows up. I have a dell xps that comes with a 420 nvidia
  5.    #5  
    It is there.Click image for larger version. 

Name:	ImageUploadedByWPCentral Fo1360994878.233518.jpg 
Views:	8 
Size:	226.9 KB 
ID:	28807
  6.    #6  
    Lak, we need you.
  7. SvanteH's Avatar
    Developer

    Posts
    36 Posts
    #7  
    Silly question perhaps - have you installed the drivers for it? The driver right now on that screenshot looks awfully "look what Windows found for me".
    This should be the latest if you're using 64-bit Windows 8:
    Drivers | GeForce
  8. martinmc78's Avatar
    Member

    Posts
    2,745 Posts
    Global Posts
    2,777 Global Posts
    #8  
    OP - is that running on a laptop? Am guessing Sony Vaio

    Just wondering because the intel 4000 will use a lot less power and has more dedicated RAM than if you force it to use the nvidia 640M LE on its own.

    The way it should work is the nvidia card will automatically step in to fill the gaps that the intel hd cant handle. The only thing that will happen if you force everything through the nvidia is increased battery drain with no real performance enhancements.
    Last edited by martinmc78; 02-16-2013 at 10:49 AM.
  9.    #9  
    Quote Originally Posted by martinmc78 View Post
    OP - is that running on a laptop? Am guessing Sony Vaio

    Just wondering because the intel 4000 will use a lot less power and has more dedicated RAM than if you force it to use the nvidia 640M LE on its own.

    The way it should work is the nvidia card will automatically step in to fill the gaps that the intel hd cant handle. The only thing that will happen if you force everything through the nvidia is increased battery drain with no real performance enhancements.
    No, a vizio ca27t-a5 all in one.
  10.    #10  
    Quote Originally Posted by SvanteH View Post
    Silly question perhaps - have you installed the drivers for it? The driver right now on that screenshot looks awfully "look what Windows found for me".
    This should be the latest if you're using 64-bit Windows 8:
    Drivers | GeForce
    I did, look what happened. So annoying. Look at "About Your GPU" and "NVIDIA Installer". Click image for larger version. 

Name:	ImageUploadedByWPCentral Fo1361045512.243821.jpg 
Views:	6 
Size:	165.5 KB 
ID:	28837
  11. BIGPADDY's Avatar
    Member

    Posts
    10,282 Posts
    Global Posts
    10,657 Global Posts
    #11  
    Perhaps a call to customer support maybe the best thing to do.
  12. #12  
    Go to Nvidia and see if there are any updated drivers. You might need to uninstall everything Nvidia then proceed.
  13.    #13  
    Fixed this problem.
  14. BIGPADDY's Avatar
    Member

    Posts
    10,282 Posts
    Global Posts
    10,657 Global Posts
    #14  
    Quote Originally Posted by unstoppablekem View Post
    Fixed this problem.
    How did you fix the problem if you don't mind me asking?
    Last edited by BIGPADDY; 02-16-2013 at 09:00 PM.
  15.    #15  
    Quote Originally Posted by BIGPADDY View Post
    How did you think the problem if you don't mind me asking?
    You mean fix? Well I contacted vizio like someone here said and there was a setting to leave nvidia graphics always on, so I enabled that.
    BIGPADDY likes this.
  16. BIGPADDY's Avatar
    Member

    Posts
    10,282 Posts
    Global Posts
    10,657 Global Posts
    #16  
    Quote Originally Posted by unstoppablekem View Post
    You mean fix? Well I contacted vizio like someone here said and there was a setting to leave nvidia graphics always on, so I enabled that.
    Thanks for the correction autocorrect

    It tends to be simple solution which I sometimes overlook however it good to hear that the problem fix
  17. mrpenaflor's Avatar
    Member

    Posts
    1 Posts
    Global Posts
    35 Global Posts
    #17  
    Your laptop got Optimus Technology. Basically its going to use the integrated graphics card to save power then switch to dedicated when you need it e.g. when you open graphic extensive application like games. if you're going to enable it always, that will shorten your battery life.

    Quote Originally Posted by unstoppablekem View Post
    You mean fix? Well I contacted vizio like someone here said and there was a setting to leave nvidia graphics always on, so I enabled that.
  18.    #18  
    Quote Originally Posted by mrpenaflor View Post
    Your laptop got Optimus Technology. Basically its going to use the integrated graphics card to save power then switch to dedicated when you need it e.g. when you open graphic extensive application like games. if you're going to enable it always, that will shorten your battery life.
    I have an all in one, so...

Similar Threads

  1. Tablet hybrid with better graphics card
    By CommonBlob in forum General Tablet & Laptop Discussion
    Replies: 1
    Last Post: 10-25-2012, 03:21 PM
  2. How to change credit card info?
    By dainla in forum Windows Phone 7
    Replies: 2
    Last Post: 11-22-2011, 03:15 PM

Posting Permissions