Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. alexbr91's Avatar
    Member

    Posts
    5 Posts
    Global Posts
    76 Global Posts
       #1  
    Hey guys i got my new hd7 on the 4th and so far im really liking it. However i have a kind of dumb question. So whenever i go to settings->applications->phone, it does not display my correct phone number, is there anyway i can manually change this, i tried putting someones elses sim card in there and it displays the right phone number but not when i put my sim card in there. Any suggestions, again i know it sounds really dumb since its not a major issue, but its just really bugging me lol. thanks!
  2. #2  
    That's weird. You would think its only something your provider can fix.
  3. alexbr91's Avatar
    Member

    Posts
    5 Posts
    Global Posts
    76 Global Posts
       #3  
    so what happened is that the number that is showing was my phone number
    (xxx) xxx-6570 but i tmobile recently ported my number from a different provider which is (xxx) xxxx-9786. so when i activated my new hd7 the phone number was 6570 but now its 9786.
  4. mydefposse's Avatar
    Member

    Posts
    34 Posts
    #4  
    this happened to me, when I got the phone I requested a new number, which took a couple of days to go through, so my phone now displays the old number all the time. not too bothered about this, but I imagine a system reset on the phone would probably fix it, i just can't be bothered to go through all the setup again.
  5. Jay Bennett's Avatar
    Resident Developer

    Posts
    1,066 Posts
    #5  
    Far as I know a hard reset should fix this.

    It won't affect anything apart from that it seems to cause issues using the features at windowsphone.live.com, happened on my father's HD7 as well but not given a try at fixing it just yet

Posting Permissions