1. zhelf's Avatar
    i unlocked achievemts in o.m.g. and de blob and they do not show up on xbox.com or when i click to view achievements in the main xbox live screen on the phone but in both games the show them unlocked and yes they are purchased. I have it set to connect to xbox live havent had any other issues. any idea how to fix or why this is?
    12-16-2010 06:50 PM
  2. electricbopeep's Avatar
    When you got those achievements, did they show up in the style of xbox - green-on-black notification with signature "achievement unlocked' sound?

    The reason I ask is because I was experiencing issues with Monopoly not registering my achievements to my xbl gamertag. I noticed that when the achievements were unlocked, they appeared in the style of Monopoly as opposed to the green-on-black xbl color scheme with the recognizable "achievement unlocked" sound. I *think* I wasn't showing up on the leader boards either. I had recently changed my windows live password and I figured that Monopoly had become unlinked from my xbl account (or wasn't linked in the first place). I un-installed and re-downloaded the game and my achievements are now registering to my xbl account. (I did lose my previous progress and achievements, not sure if this loss would happen with other xbl games).
    12-17-2010 08:09 AM
  3. zhelf's Avatar
    they were xbox style achievements in green and black and in the main xbox live tile hub the score was correct just not on xbox.com or my 360 but the problem has been resolved it took over liek 24 hours but they finally showed up. just seemed weird to me since the 360 achievements unlock instantly on xbox.com
    12-17-2010 04:15 PM
  4. gibbyhome's Avatar
    strange..
    12-17-2010 05:03 PM
  5. action_efn_jackson's Avatar
    I notice a similar incident yesterday. Mine also took @ a day to completely register.
    12-17-2010 08:57 PM
LINK TO POST COPIED TO CLIPBOARD