Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
  1. gideongrimes's Avatar
    Member

    Posts
    3 Posts
    Global Posts
    5 Global Posts
       #1  
    Hi All,

    Sorry if this has been rasied before, but I've searched round and can't find anything.

    I'm trying to pick up my work emails on my HTC 7 Pro via IMAP.

    Work uses Lotus Notes and self signs their certificates, which always creates certificate not valid issues, but on other phones ie iPhone and Android I've just be able to get the OS to accept the certificate and just let my email work.

    On WP7, I get stuck in an endless loop of the error popping up, I click Continue to ignore and carry on and popup reappears, I click, popup reappears.... you get the idea. End result is email doesn't work on IMAP.

    The ports are as standard for SSL IMAP connections, ie outgoing 465 and incoming 993

    Any ideas?
  2. gibbyhome's Avatar
    Member

    Posts
    547 Posts
    #2  
    Have you tried asking your question on answers.microsoft.com
    they might be able to help or use windowsphone support on twitter
    that seems to be the fastest responce time..
  3. gibbyhome's Avatar
    Member

    Posts
    547 Posts
    #3  
    You can try this but I don't know if it will help

    http://answers.microsoft.com/en-us/w...0-9f2b6218d051
  4. josh_johnson11's Avatar
    Member

    Posts
    4 Posts
    Global Posts
    67 Global Posts
    #4  
    Has anyone found a way to fix this? I have e-mailed my IT dept. and received a reply that they are looking into it. I guess my company has a "self-issued" certificate and therefore is not viewed by the phone as "trusted." I am frustrated that I can't simply tell the phone to ignore the certificate issue (as I have to do every time I open my Outlook 2007 at work).

    Please keep in touch if anyone has any additional news. I'll do the same. Thanks!
  5. gideongrimes's Avatar
    Member

    Posts
    3 Posts
    Global Posts
    5 Global Posts
       #5  
    To update this one.

    Have listed issue here, on Microsoft answers website and also contacted Microsoft support via Twitter. I have to highly recommend Twitter support from Microsoft as they get back to me very quickly and seem on top of situation, but unfortunately have yet to resolve.

    I have tried adding account via other account and advanced setup as advised, neither made a difference. I have also contacted my IT department and after asking very nicely got hold of a copy of the root certificate. Despite installing this correctly and also retrying both account creation methods afterwards I have yet to get it working.

    Microsoft support have asked me to try getting a different format certificate, a .cert file rather than a .cer

    I have to admit that the phrase "clutching at straws" springs to mind, but I will try it.

    I do have a temporary, un-elegant work around which involves setting up a new gmail account, setting gmail account to send email via work servers (hence appearing to come from work email address) and setting up a mail rule in Lotus Notes to automatically forward all mail to this new gmail account.

    So until either Microsoft fix this problem or IBM bring out Notes Traveler for WP7 I at least have email access on the go.
  6. gibbyhome's Avatar
    Member

    Posts
    547 Posts
    #6  
    So Microsoft never said its not possable right ? its just a confguration problem .

    Quote Originally Posted by The Net Ranger View Post
    To update this one.

    Have listed issue here, on Microsoft answers website and also contacted Microsoft support via Twitter. I have to highly recommend Twitter support from Microsoft as they get back to me very quickly and seem on top of situation, but unfortunately have yet to resolve.

    I have tried adding account via other account and advanced setup as advised, neither made a difference. I have also contacted my IT department and after asking very nicely got hold of a copy of the root certificate. Despite installing this correctly and also retrying both account creation methods afterwards I have yet to get it working.

    Microsoft support have asked me to try getting a different format certificate, a .cert file rather than a .cer

    I have to admit that the phrase "clutching at straws" springs to mind, but I will try it.

    I do have a temporary, un-elegant work around which involves setting up a new gmail account, setting gmail account to send email via work servers (hence appearing to come from work email address) and setting up a mail rule in Lotus Notes to automatically forward all mail to this new gmail account.

    So until either Microsoft fix this problem or IBM bring out Notes Traveler for WP7 I at least have email access on the go.
  7. commo's Avatar
    Member

    Posts
    27 Posts
    Global Posts
    108 Global Posts
    #7  
    Since you have the root certificate, have you tried to just send it to your phone in an email as an attachment? When your open you mailbox you can click on the certificate attachment and it will ask you if you want to install it. Just say yes and see it that fixes the problem for you.
  8. dkeppler56's Avatar
    Member

    Posts
    1 Posts
    #8  
    Not sure if anyone is still bothered about this but I have found a solution.
    Although the error is given as a certificate error it really has nothing to do with that.
    If you switch on IMAP debug on the Notes Server you can see that it is trying to search for the last seven days of mail and getting an error because the mail file is not indexed!
    So the simple fix is to change the WP7 mail (or WP8 or Windows 8 Mail or Windows Surface, they all have the problem) client to get all mail (the default is 7 days when you set the account up)
    The slightly longer fix is to index your mail file from a Lotus Notes Client so you can keep what you sync to the phone smaller.

    Hope this helps someone.

    David
  9. Phil Krylov's Avatar
    Member

    Posts
    1 Posts
    #9  
    In my case I had an 80048821 error, not the certificate issue.
    Thanks a lot!
    It was not too easy to find this solution :)
    It really works!

Tags for this Thread

Posting Permissions