Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. joseph_707's Avatar
    Member

    Posts
    2 Posts
       #1  
    Hi all, I have got this weird problem with Exchange Server 2007 sync with Windows Phone Mango. I have got the following HTC Model.

    Specifications
    Smartphone : HTC Titan x310e
    Windows : Phone 7.5
    OS Version : 7.10.7720.68
    Firmware : 1600.2200.10902.401
    Bootloader : 1.8.160015.3(132000)
    Chip Soc Ver :1.6.0.0
    Exchange : 2007 Server with the Latest Updates
    Access : OWA Enabled / Active Sync Enabled
    Certificate Auth : Local Certificate Authority. NO third-party

    What I need

    I am not able to send and receive E-mails on my Smartphone. Always require Outlook information pops-up although the information I have entered is correct. In short I need to Sync my Exchange e-mails on my HTC TITAN Windows Phone 7.5

    What I did

    1.Went to HTC TITAN Mobile Settings > Add Email accounts
    2.While adding exchange account, it doesnt find my exchange server settings. Error message We couldnt find your settings
    3.Enter manually all the Details such as
    4.E-mail address
    5.Password
    6.Domain Username
    7.Domain that I logon to at my workplace
    8.And then click Sign-In
    9.Message comes up we couldnt find your settings
    10.I click now advanced tab
    11.Enter my Mail server mail.domain.local (this is the OWA address that I type on the IE bar i.e http://mail.domain.local
    12.Then I click on Sign-in
    13.Error message Not trusted certificate for the domain
    14.I then installed the ROOT CA from my domain that issued to the Exchange Server. (I can confirm this because next to the Certificate it states Root Certificate, DER Coded binary). I created another Hotmail account and e-mailed it to that. From the Hotmail account, I installed the certificates. Dont know where it got installed on my Windows Phone
    15.After which another messages pops-up you would require a private certificate
    16.I enrolled and requested a Private certificate from my CA. I exported all including the Private keys
    17.After which it syncs my e-mails, Temporarily

    What is happening now

    1.But after few minutes of inactivity, I get pop-up message Update your information for mail.domain.local and press save
    2.I look at my Exchange OWA under mobile devices, it says Sync Status is OK
    3.I have entered more times that I can remember and it still asks me
    4.Leaving it alone wont do any good as it wont sync AT ALL
    5.I have Resetted the phone and re-installed the certificates
    6.I have recreated the Outlook account, works for first 10 Minutes ONLY
    7.I have done the setup using Add Email accounts > Advanced Setup > Exchange Active Sync Also
    8.Checked all the system locale i.e it is US English, United States in Regional Language
    9.I checked the dates and time and all are synced
    10.Made sure all the Windows Phone 7.5 updates are in place using Zune
    11.Made sure all the WIFI and Data Connections are available.
    12.Created Hotmail account simultaneously and it SYNCS very well
    13.What am I doing wrong ??? :(

    Thanks for all your help. Funny iPhone and Android Devices dont ask for all this and in one short, everything works perfect.

    Joseph
  2. htc titan's Avatar
    Member

    Posts
    1 Posts
    #2  
    Exactly same problem with my htc titan. Unable to sync with corporate exchnage server. At first it worked - synced fine with exchnage server. I did the exact same thing - e-mailed the cert to gmail account and installed it. Everything went alright first time. then after 2-3 days, all on a sudden that message popped up"...update info and save...". I was 110% sure, i was enetering the correct password but it could save and that annoying msg popeed back. Tried several hours - by reseeting the phone to factory setting and trying again and again but no success. Now returned the phone for iphone.
    I really loved htc titan but this is a deal breaker.
  3. jfa1's Avatar
    Member

    Posts
    2,332 Posts
    Global Posts
    2,411 Global Posts
    #3  
    I think that the hotmail sync is probably like EAS but automatic and perhaps with the Titan buld it is somehow getting conflicted after a brief ime of working. Have you tried talking with Microdoft or HTC about the issue and/or maybe theres a KB article about this with a solution or workaround?
  4. jfa1's Avatar
    Member

    Posts
    2,332 Posts
    Global Posts
    2,411 Global Posts
    #4  
    I have been thinking about using Office 365 and now I am thinking that maybe I should just stick with hotmail calendar and continue to wean myself off of outlook!
  5. joseph_707's Avatar
    Member

    Posts
    2 Posts
       #5  
    Quote Originally Posted by jfa1 View Post
    I have been thinking about using Office 365 and now I am thinking that maybe I should just stick with hotmail calendar and continue to wean myself off of outlook!
    Hi all
    For those of you are having the Exchange Server 2007 sync to HTC titan (any models) please read through. Finally, thank God it is working after spending 5 months to resolve this. By now someone would have figured it out but I want to post it as it might help everyone. These are the different permutations that I have tried, hopefully Microsoft would resolve this in their update patches.

    SCNARIO ONE
    IMPORTANT: Your password for both Hotmail and Exchange Server should be this format . It should contain only wild characters and letters only NO numeric. Example O@%%rdi^ and it should be 8 characters in length. Please do this before proceeding below. This is only applicable if your Exchange Server Admin has enforced this weird policy.

    (dont know how to insert the image in this forum easily)

    a. You should RESET your HTC phone (any model). This is required to have all the old certificates flushed out and new ones to be imported. To do this, go to Settings>About>Reset your Phone (Backup all contacts, picturers etc). All your certificates should have VALID dates and NO EXPIRED certificates, please !
    b. You should have a certificate based on all of the following. This is needed, else it won't work. Usually your Domain Administrator can help on this. See picture below

    Note: Make sure you export all of them one by one. Regarding Personal certificates, you can enrol from your computer to the CA(certificate authority) on your domain controller. I repeat this, make sure you export all certificates path if possible(see picture above). If it is asking to put password also for personal certificates, please make it as '123'. Short and simple
    c. Change your Hotmail Password or Yahoo Password or Gmail Password to the one you are using at your Office Exchange Server. Don't know why, but when I used to sync, I noticed my password length getting changed and the usual pop-up appearing that your settings are incorrect. Do this also, else it won't work.
    d. Now configure your Hotmail, Yahoo or gmail on your HTC any model phone. Once done. E-mail the certificates you had done in the previous steps.
    e. Open the e-mail certificates and it would ask whether you want to install. Install all of the certificates one by one.
    f. Now configure your Exchange e-mail. Please ensure the setting this way.
    E-mail should be full FQDN (fully qualified domain name, in my example joseph@domain.com)
    Password should be the one you logon either to your Outlook Web Access (Exchange Server)
    Domain should be the actual domain you logon on to the workstation. Your Techsupport can let you know this or easy way to find out is joseph@domain.com. The one after '@' is your domain name you logon on to
    Username, should be only the Username without '@' in the option when prompted
    Server, usually the OWA webpage you logon onto. This is usually in this format mail.domain.com. This settings also can be provided by your System Administrator/Techsupport etc.
    All other settings as normal and Press 'Tick' to have the sync begin
    Once you have done this, wait for few minutes and all your e-mails would start to populate. I have tested this after even few hours and all is good.
    SCENARIO B
    Without configuring Hotmail or Gmail or Yahoo account on your HTC model, download the certificates via the Internet explorer browser on HTC phone. Do this because sometimes, accounts gets mixed in their password and password prompts appear. After you have successfully installed all the certificates, and then configure the Exchange account via the Active Sync.
    SCENARIO C
    The account name what you create for your Exchange server should be different. It should read some other name i.e EXCHANGE OFFICE, Domain EXCHANGE, Domain EXG, MY EXG. It shouldnt have the name of your domain as in domain simply.
    SCENARIO D
    Restart your Phone if the password prompts appear again and again. Also, try to sync from your Office Wifi (which is not necessary) but a try.
    To check that it is actually syncing, Open your (OWA)web access e-mail i.e https://mail.domain.com. Once logged in. Go to options on the top right corner > Mobile devices. You would now see your Mobile devices synced and all other relevant details regarding your Phone synced and updated.
    SCENARIO E
    Try to go to https://www.testexchangeconnectivity.com and enter all the necessary details based on your exchange setup. I tried in Exchange ActiveSync and all connectivity tests showed fine.
    Note: Please make sure under your IIS, under Exchange ActiveSync>Right Click Properties and see the main properties as shown below. It has to be Ignore Client Certificates. If it is set to Accept client certificates, then you would have the problem stating that you need to update your passwords every now and then on your Mobile Device.

    (dont know how to insert the image at this forum easily)

    These are the various methods I saw to resolving this.
    Let me know if you or anyone else is having the same problem. Thank GOD for his guidance on this.
    Regards
    Joseph:D

    Psh. If you want to see another place where I posted this steps with images, please click here Exchange Server 2007 Sync Problem with Windows Phone 7.5_

Posting Permissions