Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 7 of 7
  1. tvolpe86's Avatar
    Member

    Posts
    152 Posts
       #1  
    So I send an email from my HTC Trophy with a link in it to my Mom and Dad. Mom checks it from Outlook Express, Dad from Optimum Online's (our cable service) web email client, and I log into my Hotmail on the PC (same account synced with my phone) to view my sent emails, and the link I sent is not clickable on either of these interfaces (hotmail, outlook express, and optimum online's web email client). Just for kicks I forwarded the same email to my personal gmail, and I was able to click the link within the message. Not sure how the WP7.5 email client sends out emails (plain text, rich text, or full html), but I'm not sure why on some email clients/browsers I need to physically highlight, copy and paste the link into the URL field and others (like my gmail) pick up the hyperlink just fine and allow me to click it. Any way I can fix this on the WP7 side so every web browser/client receives a perfectly clickable link? Do other OS's mail clients have this issue when sending to a non mobile email address (on the phone, to test, if i view my sent messages or send the message to myself, the link is clickable). Thanks.

    Phone info - HTC Trophy on Verizon Wireless with Mango



    Tom
  2. enahs555's Avatar
    Member

    Posts
    634 Posts
    #2  
    That is because gmail is automatically detecting URLs and turning them into actual links.

    It would be no different if you copied the URL from the browser bar and pasted it into an email and emailed it off. Those people would get text, unless the email client forced it to a link as well. Not all do that.

    Are you doing "share link" or copying and pasting link?

    FYI, in many browsers, you can just highlight the URL and right click and there will be an option that says browse to this URL, so you at least do not have to copy and paste.
  3. tvolpe86's Avatar
    Member

    Posts
    152 Posts
       #3  
    Quote Originally Posted by enahs555 View Post
    That is because gmail is automatically detecting URLs and turning them into actual links.

    It would be no different if you copied the URL from the browser bar and pasted it into an email and emailed it off. Those people would get text, unless the email client forced it to a link as well. Not all do that.

    Are you doing "share link" or copying and pasting link?

    FYI, in many browsers, you can just highlight the URL and right click and there will be an option that says browse to this URL, so you at least do not have to copy and paste.
    Thanks for the response. I'm long pressing on the link and saying "copy link." I've also tried just highlighting the text in the URL field in mobile IE9 with the handle bars and selecting the little copy icon. Both give the results mentioned above. The way around this would be to go to the linked page in IE9, tap the little dots at the bottom right for page options, and select "Share Page"? Basically, I would just like to know that I'm not sending just a plain text link and am actually sending a hyperlink.

    edit: i tried "share page" and in the various email clients it is still unclickable.

    Tom
    Last edited by tvolpe86; 11-29-2011 at 03:14 PM.
  4. tvolpe86's Avatar
    Member

    Posts
    152 Posts
       #4  
    Quote Originally Posted by tvolpe86 View Post
    Thanks for the response. I'm long pressing on the link and saying "copy link." I've also tried just highlighting the text in the URL field in mobile IE9 with the handle bars and selecting the little copy icon. Both give the results mentioned above. The way around this would be to go to the linked page in IE9, tap the little dots at the bottom right for page options, and select "Share Page"? Basically, I would just like to know that I'm not sending just a plain text link and am actually sending a hyperlink.

    edit: i tried "share page" and in the various email clients it is still unclickable.

    Tom
    in case this helps also. this is my response to someone trying to help me over at answers.microsoft:

    "ok, so i've sent email through my WP7 from both my hotmail and optonline emails, to my gmail, my hotmail, and optimum online. gmail receives it fine, but both hotmail on the pc via the web client and the same for the optimum account receive these messages with a link that is pure text and is unclickable. i have received emails to my hotmail and my optonline account through the web client and outlook express before that have clickable links in them, so I'm not sure why ones received that came from my HTC Trophy aren't clickable but others (not sent from my phone) are."
  5. gerrymad's Avatar
    Member

    Posts
    177 Posts
    #5  
    It is possible that in the cases of the recipients who do not get a clickable link you are not trusted? I sometimes get emails in Outlook on my desktop with links and I need to explicitly allow links from the sender.
  6. tvolpe86's Avatar
    Member

    Posts
    152 Posts
       #6  
    Quote Originally Posted by gerrymad View Post
    It is possible that in the cases of the recipients who do not get a clickable link you are not trusted? I sometimes get emails in Outlook on my desktop with links and I need to explicitly allow links from the sender.
    i've tested this. definitely not the case =\
  7. Italianoleone's Avatar
    Member

    Posts
    12 Posts
    #7  
    This is still a problem in WP 7.8. Any solutions?

Posting Permissions