Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 20 of 20
  1. steve_w_7's Avatar
    Member

    Posts
    210 Posts
       #1  
    I tried to access one of my files via SkyDrive on my phone today and got the following message:

    "Can't download
    You don't have permission to download this file. For help, try contacting the person who manages this site."

    I am signed in with Live.com login.

    Has anyone else gotten this message lately when you try to open a file?
  2. Stunrunner's Avatar
    Member

    Posts
    1 Posts
    #2  
    I've gotten the exact same issue you're describing in the last few hours. Saving (from the app) or opening the file from the SkyDrive location throws the permission error. However, for some reason the file is able to sync if under the SkyDrive location you manually tap-hold and select "upload now" or "download now", but it is a bit of a hassle. Maybe this is a temporary SkyDrive bug.

    Sorry...by "app" I meant saving and accessing from the Office app. I can access the files fine from everywhere else (PC, browser).
    Last edited by Stunrunner; 04-05-2012 at 11:03 AM. Reason: Clarification
  3. Tjarren's Avatar
    Member

    Posts
    216 Posts
    Global Posts
    219 Global Posts
    #3  
    Same here. Out of the clear blue. And it's not the Skydrive app, because I'm having the same problem in the Office app.
  4. woodrow_hills's Avatar
    Member

    Posts
    7 Posts
    Global Posts
    10 Global Posts
    #4  
    I'm having the same problem this morning. Out of the blue, I do not have permission to upload or download my files in SkyDrive.
  5. mikeandlucyg's Avatar
    Member

    Posts
    1 Posts
    #5  
    Exact same issue here.
    I can however with the same live account access it from the live web site.
    Just not from the phone either using the office app or the skydrive app.
  6. jfa1's Avatar
    Member

    Posts
    2,352 Posts
    Global Posts
    2,431 Global Posts
    #6  
    I think they are in the process of upgrading skydrive on the desktop and their servers could be having some glitches or cauing this behavior.
    Your smartphone is only as smart as YOU let it be!
  7. #7  
    Just downloaded some files from office and it worked fine for me.
  8. red grenadine's Avatar
    Member

    Posts
    542 Posts
    Global Posts
    545 Global Posts
    #8  
    Ditto, I'm having onenote issues
  9. steve_w_7's Avatar
    Member

    Posts
    210 Posts
       #9  
    I'm still having issues. I can access them from the desktop, but not from my windows phone.
  10. steve_w_7's Avatar
    Member

    Posts
    210 Posts
       #10  
    Microsoft support says they are aware of the issue. As a workaround, if you long hold on the document you want to open, you can select "download now". After it finishes downloading, tap it again and it will open.
  11. Tjarren's Avatar
    Member

    Posts
    216 Posts
    Global Posts
    219 Global Posts
    #11  
    Quote Originally Posted by steve_w_7 View Post
    Microsoft support says they are aware of the issue. As a workaround, if you long hold on the document you want to open, you can select "download now". After it finishes downloading, tap it again and it will open.
    That doesn't help with my Onenote documents, though. They won't synch since this problem showed up either ...
  12. micronesio's Avatar
    Member

    Posts
    1 Posts
    #12  
    so I had the same issue until I realized that when my phone was new, i created a new live account for the phone, which was different to the account i used with skydrive.

    to solve the problem, i had to reset my phone to factory settings (settings>about>reset) and log onto my phone with the same microsoft account as the one i had on skydrive. it was a pain, but i read on a microsoft official blog that the only way to change the phone's live account was by resetting. i also couldn't just create a new skydrive account because i had already paid for some extra storage linked to that specific account.

    i hope this solves your problem.

    Cheers!
  13. parael's Avatar
    Member

    Posts
    2 Posts
    #13  
    Hi,

    i had the same issue, i did the following

    1. Uninstalled SKYDRIVE from my 920
    2. Reinstalled it
    3. Shut down the device
    4. Power up again and it worked

    Hope this helps
  14. Ng Zachary's Avatar
    Member

    Posts
    1 Posts
    #14  
    Just got hold of the Lumia 920, and since Dropbox doesn't have a native app for Windows Phone 8 (**horrors!!), I had to make the painstaking move to Skydrive. Hit the same problem like what is explained by users above.

    When you create/sign into the "Microsoft" account on your phone, it associates all phone services (ie. Marketplace, XBox Live, etc.) with this account. Somehow or the other, the Skydrive app sees this account (gets confused!) and prompts the error for security reasons. No issues if your Skydrive login is the same as your "Microsoft" account, but due to the proliferation of MS Services along the years, there's bound to be people with a separate Live ID for SkyDrive and another one for Hotmail/LiveMessenger, etc. (me inclusive!).

    To solve this problem, I "shared" access from SkyDrive to my "Microsoft" account, and everything works! Now, this is not an ideal scenario (MS should instead allow merging of accounts), but it solved my problem of needing to access specific files.

    p/s. MS mentions a "factory reset" to get the above working, which is a definite easy way out by them IMHO.
  15. spaulagain's Avatar
    Member

    Posts
    1,206 Posts
    #15  
    ^Just login in to outlook.com and combine/link your MS accounts.
  16. #16  
    It's the same at this end!

    to micronesioJust
    when I realized I made a different account, I shared my SkyDrive with this account instead to reset the WP settings. It works perfectly! Thanks a million!

    to parael
    re-install didn't work with me this time. Cheers!

    Mielna.
  17. #17  
    Share the file (DOCs) or Folder to view and download on WP8..If u r using different live account for skydrive
  18. david a11's Avatar
    Member

    Posts
    1 Posts
    #18  
    The long, full, ANSWER / SOLUTION is, as two people have (sort of) said, that the phone only has access to a file or folder on Skydrive if it is EITHER the same account as the Windows phone was INITIALLY set up with, OR for any other Microsoft account, to allow access on the phone, you first need to have told skydrive to "share" the file / folder. So on the PC (or whatever) you sign in to Skydrive using the account with the files you are unsuccessfully trying to access on the phone, then "share" the file / folder (using the right click option) and specify the Microsoft account that the phone was INITIALLY linked with (because that is the account that the phone uses to supply its credentials to skydrive for permission to access the file / folder). As also mentioned by someone, you CAN NOT change the Microsoft account with which the phone is linked without doing a factory reset, but you don't need to because on the phone you can launch the skydrive app and sign in with a different Microsoft account and access the files / folders, but only those that you chose to SHARE with the phone's Microsoft account.
    Last edited by david a11; 12-20-2013 at 08:42 AM. Reason: clarifying
  19. Ben Sailorboy's Avatar
    Member

    Posts
    1 Posts
    #19  
    same problem here...
    cant open any of document type else than PDF, in WIndows Phone 8 Nokia 1320

    switching back to Google Drive..
  20. tieu vu's Avatar
    Member

    Posts
    1 Posts
    #20  
    I have the same problem as all of you here!
    But i have found a simple solution to this issue! You just set your files public, then you can download your files to your own phone. My documents are not important, so i can set them public. I haven't try with other properties, but you can give it a try!
    Thank you!

Tags for this Thread

Posting Permissions