Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 12 of 12
  1. robshoy's Avatar
    Member

    Posts
    7 Posts
    Global Posts
    8 Global Posts
       #1  
    Hey guys, I just got a Lumia 900 a couple of days ago and I was hoping this problem would fix itself... but it hasn't.

    In my Music & Videos app, the artist images just won't show up. I've made sure that my account is a US account, I've made sure that in the settings I'm letting the app connect to Zune, and none of that has done anything.

    Also, whenever I try to make a Smart DJ playlist it gives me an error saying "We can't make a Smart DJ playlist for this song because we don't recognize this artist". I'm sort of at a loss for what to do.

    Any suggestions?

    (It might be worth noting that I'm using a Lumia 900 on AT&T and syncing all my music to it through the Windows Phone 7 Connector software for the Mac through iTunes)
  2. sinime's Avatar
    Developer

    Posts
    2,917 Posts
    Global Posts
    4,353 Global Posts
    #2  
    Quote Originally Posted by robshoy View Post
    Hey guys, I just got a Lumia 900 a couple of days ago and I was hoping this problem would fix itself... but it hasn't.

    In my Music & Videos app, the artist images just won't show up. I've made sure that my account is a US account, I've made sure that in the settings I'm letting the app connect to Zune, and none of that has done anything.

    Also, whenever I try to make a Smart DJ playlist it gives me an error saying "We can't make a Smart DJ playlist for this song because we don't recognize this artist". I'm sort of at a loss for what to do.

    Any suggestions?

    (It might be worth noting that I'm using a Lumia 900 on AT&T and syncing all my music to it through the Windows Phone 7 Connector software for the Mac through iTunes)
    I'm not familiar with the Mac software and porting to a WP7, however I can say this... iTunes stores album art per song, embedded in the ID3 tag. To save space, Zune (WP7) stores album art per folder with just one JPG in the folder of the CD. This could explain the album art.

    As far as the smart DJ. IDK, but I'd start by checking that the artist info is embedded in the ID3 tags of your music.
  3. robshoy's Avatar
    Member

    Posts
    7 Posts
    Global Posts
    8 Global Posts
       #3  
    Nah, the album art shows up fine. It's the artist images (the ones that Zune floats in the background) that are invisible. My ID3 tags are fine I think...
  4. HeyCori's Avatar
    Mod Emeritus

    Posts
    5,252 Posts
    Global Posts
    5,277 Global Posts
    #4  
    Just to be sure, you've gone too Settings > Applications > music+videos > and turned on "Connect with Zune"
  5. robshoy's Avatar
    Member

    Posts
    7 Posts
    Global Posts
    8 Global Posts
       #5  
    Quote Originally Posted by Figure 8 Dash View Post
    Just to be sure, you've gone too Settings > Applications > music+videos > and turned on "Connect with Zune"
    Yep, I've done that.
  6. HeyCori's Avatar
    Mod Emeritus

    Posts
    5,252 Posts
    Global Posts
    5,277 Global Posts
    #6  
    Have you tried signing into Zune.net and seeing whether your phone shows up as a listed device?

    You might have to go straight to the source for a fix.

    Home - Microsoft Answers
  7. oldgaius's Avatar
    Member

    Posts
    66 Posts
    #7  
    UK, Lumia 800, Mac user... don't have artists displaying on lock screen (just changing colours it seems).
  8. hellomiggy's Avatar
    Member

    Posts
    97 Posts
    Global Posts
    293 Global Posts
    #8  
    I noticed this happened to me, when I had first had gotten my phone. Once I had connected and put music on my windows laptop, with Zune it worked. It never worked with a Mac. I'd say try and get yourself a windows comp and sync through there.
  9. AngryNil's Avatar
    Member

    Posts
    1,383 Posts
    Global Posts
    1,387 Global Posts
    #9  
    Depends on what music you listen to, Zune might not have artist imagery. Get your phone on a strong data connection and open up the artist in the Music+Videos app, and wait a while. It should load if Zune has an image. The imagery loads when you open up the artist or play music from the artist to the best of my knowledge, but I've been applying my own images through homebrew for a while so I can't be sure.

    As for the lock screen, Settings → lock+wallpaper → Show artist when playing music.
  10. massifheed's Avatar
    Member

    Posts
    105 Posts
    Global Posts
    106 Global Posts
    #10  
    I've had this problem both when I had my Omnia 7 and now with my Lumia 900. It seems to be very hit and miss as to whether or not Zune displays artist images. And I've never got Smart DJ to work yet.
  11. ousooner314's Avatar
    Member

    Posts
    155 Posts
    Global Posts
    157 Global Posts
    #11  
    I had this problem as well where my music files had album art on it (whenever I downloaded from Amazon, etc.), but never showed up on the phone. Zune showed the album art, and the phone also showed it on the player, but it never showed up on the lock screen. Here's what worked for me; be aware that this is a manual process and can take a while if you have a lot of songs. It also requires Zune on Windows (sorry!).
    1. In the Zune software (on Windows), go to Settings -> Metadata and Ratings, and select "Automatically retrieve ad update album art and metadata". I also selected "Only add missing information" under this selection.
    2. Now, close out of the Settings and go back to your library
    3. For each ALBUM, right-click and select "Find album info"
    4. Go through the process and select the right album info
    5. Repeat steps 3 and 4 for EVERY album
    6. Re-sync your songs with your phone
    7. On the phone, go to Settings -> Applications -> Music + Videos, and turn ON the "Connect with Zune" option
    8. Your music should now show the album art

    The cool thing about this is when you play your music on the desktop Zune software (in fullscreen mode), it starts displaying album art, artist info, etc. when the songs play.

    Good luck!
  12. #12  
    Hi guys, I know this thread may be a little bit old and I hope most of you see this but I've finally found a solution to what you guys and I have been encountering since we got our windows phone.

    So because microsoft zune isn't apple friendly this only applies to people who have been using the windows phone connecter for mac.

    1. Update windows phone connecter to the most current update.

    2. Uncheck (if you have checked) sync all music.
    *for some reason this makes the connecter overlook all of the metadata that has been downloaded from xbox music. This can be found on the sidebar located in windows phone connecter when your phone is connected.

    3. Manually check all artists, playlists, and genres. (You will find this by looking at the sidebar when your phone is connected and clicking music). same for step 2.

    4. Go to top menu bar and click "windows phone connecter" and under preferences click "sync artist+music information from xbox music". located at the bottom of preferences panel.

    5. Wipe your device otherwise it will sync two versions of every song with the new info and tag information. This doesn't delete contacts, etc. only what you've synced from your itunes/media library.

    6. Sync your phone. (You'll notice it'll take a lot longer because it is actually downloaded the metadata needed to show pictures.)

    7. It should work.

    I hope this works for you guys... I know it's been pretty frustrating but here's a new solution. I made this account just for this. Cheers!

Posting Permissions