1. rashedalam's Avatar
    Hi all,

    I've just bought a Nokia Lumia 800, here in the UK, and would like to sync it with my Macbook.

    The thing is on the Mac App Store its on version 3 which requires Mac OS 10.7. My Macbook is older and running Snow Leopard, which I can't upgrade from, but the laptop itself works perfectly fine for me (maxed RAM and SSD hard drive fitted recently).

    Is there anywhere I can download the most recent version which runs on Snow Leopard? On the Microsoft website it just links to the Mac App Store.

    Many thanks,

    Rashed
    11-05-2012 02:47 PM
LINK TO POST COPIED TO CLIPBOARD