Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 10 of 10
Like Tree2Likes
  • 2 Post By mdameron
  1. razor1973's Avatar
    Member

    Posts
    16 Posts
    Global Posts
    161 Global Posts
       #1  
    I am coming from Android and the Google world and do want to keep my e-mail account and contacts on that world while using a Lumia 710. However, some of my Google contacts don't show on my phone (syncing via my Gmail account which I added) or even Live Contacts when I try to view them on my computer (I have my Live account syncing with Google as well).

    Here's one example: my dad. This is what his contact looks like in Google Contacts and also when I edit his name. Notice how last name is blank, but I don't think this is the problem. Again, I have many others in this same case.

    Luckily, when I'm composing a text or e-mail, I can always search for contacts on the server (gmail.com) and I, ironically, can find them, but this is a hassle.

    Does anyone know why this is happening and how to solve it?

    Thanks in advance!
    Attached Thumbnails Attached Thumbnails dad-contact.jpg   dad-name.jpg  
  2. razor1973's Avatar
    Member

    Posts
    16 Posts
    Global Posts
    161 Global Posts
       #2  
    Nobody? :unsure:
  3. razor1973's Avatar
    Member

    Posts
    16 Posts
    Global Posts
    161 Global Posts
       #3  
    Damn, 88 views and not even one reply, even to say "I have 300+ contacts on Google and that they all get synced"?
  4. mdameron's Avatar
    Member

    Posts
    222 Posts
    Global Posts
    229 Global Posts
    #4  
    You need to add the people to "My Contacts" inside gmail to get your phone to download them. At least, that's the way it works on my phone. Find a contact that's on your phone from gmail, and look to see that he is in "My Contacts". Bet he is. Your dad is not, that I can see.

    Eg, I have several hundred google 'contacts' that I've emailed once. But the only ones downloaded to my phone are in the group "My Contacts". Also, groups created inside gmail (like your Family group) are not synced to your phone. WP7 contact groups must be created within the phone. The good news is that you can select checkboxes in your gmail contact list and say "add to My Contacts". Likewise, any contact group created on your phone will not sync to gmail and be a new group there.
    Thanked by:
    razor1973 and Laura Knotek like this.
  5. razor1973's Avatar
    Member

    Posts
    16 Posts
    Global Posts
    161 Global Posts
       #5  
    You, my friend, are the best! That was it! All my contacts are now synced. Thank you so much for taking the time!
  6. mdameron's Avatar
    Member

    Posts
    222 Posts
    Global Posts
    229 Global Posts
    #6  
    Glad to help!

    If you're wondering how to sync more of your google calendars, read this: https://plus.google.com/+Gmail/posts/HH1vo3Zw9er

    Be sure to select the option to 'delete emails when you hit the trash button' or similar. The default functionality I believe just archives emails, not deletes.
    Thanked by:
  7. razor1973's Avatar
    Member

    Posts
    16 Posts
    Global Posts
    161 Global Posts
       #7  
    I only use 1 calendar, but that's great to know. Thanks again.
  8. Duncan H's Avatar
    Member

    Posts
    1 Posts
    #8  
    Really helpful post re syncing google contacts with phone...

    Previously had lots of contacts on Google (which were created on phone, but which were then automatically being deleted from phone... bizarrely.) Thanks to post now added all to "My Contacts" - and all contacts now synced back with phone...

    However my phone has still retained some old contacts / duplicates. Basically i'd like phone contacts to be exactly as Google contacts. any ideas?
  9. Rushabh Gosar's Avatar
    Member

    Posts
    1 Posts
    #9  
    Here this should help you. It will import all your google contacts to your WP7.8

    Now sync google contacts on Windows Phone 7.8 | Rushabh's blogroll
  10. khalisaplay's Avatar
    Member

    Posts
    1 Posts
    #10  
    This fixed my problem as well. Saved me many hours of typing in contact info manually. Thank you so much!

Tags for this Thread

Posting Permissions