XP-YESSSSSSS

Dell's already awesome XPS 15 gets even better in 2017

Surface table meets Windows 10

Yes, we did put Windows 10 on the original Surface table ... and it rocks

Cream o' the crop

Before buying a Microsoft laptop, check out our pick for the absolute best

Simple and secure, just the way I like it

We think Windows 10 Cloud is a great idea, here's why

uber micro

Halo Wars 2 has something for everyone. Here's our full review.

Oldie but goldie

We reviewed Microsoft's decade-old Surface table

Creators Update comin' at ya

These are the coolest new features in the next big Xbox One update (video)

Buyer's guide

The Razer Blade 14 is the best laptop Razer has to offer

Windows 10 app gems

10 terrific Windows 10 apps you should be using

Tower of power

Here's what we think of Dell's XPS Tower Special Edition

Quite a deal

Grab the complete C# coding bootcamp for $41!

Your go-to laptop guide

Introducing our ultimate laptop buyer's guide

Listen here

Attn Android and iPhone users: What you need to know about Windows phone

Old is new?

The original Surface Pro still holds its own in the 2-in-1 world

Xbox Greenlight?

No, internet, Microsoft isn't opening Xbox to all UWP games

Falling in love

HP Envy 34 review: An ultrawide curved all-in-one after my heart

2015 machine in 2017?

Surface 3 still holds its own in 2017

Let Kodi cut your cord

You should be using Kodi for Windows 10

Leader of the pack

HP's Spectre x360 15 just might be the best all-around laptop

New or refurbed?

Is a refurbed Surface right for you?

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
Like Tree1Likes
  • 1 Post By turbulent
  1. crg28's Avatar
    Member

    Posts
    39 Posts
    Global Posts
    222 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #1  
    I have owned a 900 for a while. In the last 2 weeks I have seen issues with my LTE connection. I works half of the time....I have had to turn it off and on 20 times in the last 10 days. As soon as it is turned back on, it works again.

    I have not downloaded any new app in the last 30 days and the phone was not dropped....what the heck is going on? I love my 900, but this is getting on my nerve....I figure I would ask here before going to my local AT&T store....
  2. Old_Cus's Avatar
    Member

    Posts
    417 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #2  
    That is interesting. Over the past two weeks I have noticed three times that my 900 was picking up 4G instead of LTE. Each time I got LTE back when I turned it off and on.

    Anyone else?
  3. turbulent's Avatar
    Member

    Posts
    52 Posts
    Global Posts
    180 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #3  
    You shold check with you carrier. Could be a case of a bad tower nearby. Have you noticed if you connection is stronger (LTE) in other areas?
    Laura Knotek likes this.

Similar Threads

  1. Replies: 5
    Last Post: 11-27-2012, 09:12 AM
  2. Please help me to solve this annonying call problem.
    By stryik3r in forum Nokia Lumia 800
    Replies: 1
    Last Post: 05-02-2012, 10:36 AM
  3. Facebook Chat not connecting. please help
    By TheRealSel in forum Nokia Lumia 710
    Replies: 3
    Last Post: 03-18-2012, 02:13 PM

Posting Permissions