Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 5 12345 LastLast
Results 1 to 25 of 110
Like Tree34Likes
  1. markfive's Avatar
    Member

    Posts
    377 Posts
       #1  
    Here’s a quick guide on problems you might experience with being notified about app updates.

    If you think you have a problem with app update notifications, there are some steps to go through that hopefully will get your update notifications working again. The key to this is a little patience – don’t try all the fixes in one go, and be prepared to wait a few hours to see if things improve.

    How things should work
    The Store app on your phone has a live tile – if you pin it to your start screen then it is intended that the tile displays the number of app updates available to you. This process works just fine for a lot of people, but some do seem to have problems with the reliability of these updates. Exactly why is a subject clouded in mystery and speculation. There doesn’t seem to be a single magic cure. Fortunately there are some steps you can take to get things up and running again.

    Firstly, a little expectation setting – app update notifications are not immediate. Just because you see an article about your favourite app getting updated, it may take hours before your Store tile shows that an update is available. In my experience, the Store live tile updates about once every 24 hours.

    How do you know you might have a problem?
    So, you've seen a news item on WPCentral that your favourite app got an update this morning. But your Store tile pinned to your start screen doesn't show any app updates pending. If you’ve not had a notification after A Reasonable Time™ (or, like me, you’re just impatient ) then go to the app’s page in the store and see if it shows the “update” button. Just because it does (and it invariably will) it doesn't mean that you have a problem. In truth the only way you will know is if the app was updated more than 24 hours ago (check the date in the store). If the date of last update is not today then you should work through each of the following steps to see which (if any - there are no guarantees that any of these will sort your problem) get your notifications going again.

    Check you have push notifications enabled in Find My Phone
    Go to settings > find my phone and tick “Send apps to my phone using push notifications (not SMS)”. Restart your phone.
    If you already have push notifications switched on, try switching it off (untick the box), restarting your phone and then switching it back on again.

    Re-pin the Store live tile
    Remove the Store live tile from your home screen. Restart your phone and then add the live tile back to your home screen

    Re-pin the Store live tile and clear your IE history

    This is a variation on the previous - as well as removing the Store live tile, clear your IE history by opening IE and selecting settings > delete history. Then soft-restart your phone (power off and then power on whilst holding the volume down key down) and add the live tile back.

    Try using cellular data only
    Some people have reported better reliability of push notifications over cellular data connections. If you spend a lot of time on wifi this can be worth checking out.

    Disable your wifi connection (settings > WiFi > WiFi networking > slide to off) and restart your phone. An extra step that might help this to work is to ensure that you a) have a good cellular signal and b) a working data connection after turning off wifi and before restarting your phone. A quick browse of www.wpcentral.com will do the trick for the latter!

    If this does work for you, it’s possible that something related to the wifi connection is blocking the notification channel – if this is the case then you may find that other notifications become more reliable as well.

    Help us to help you
    Did one of these methods get your notifications going again? Have you managed to sort out this problem using another method? If so, please post here so we can all help each other out!
    Last edited by markfive; 07-16-2013 at 04:24 AM.
    Lumia 930 | Surface Pro 3 |
    Thanked by:
    + Show/Hide list of the thanked
  2. jbjtkbw00#AC's Avatar
    Member

    Posts
    322 Posts
    Global Posts
    639 Global Posts
    #2  
    While I don't have any problems with updates, I am an IT Helpdesk Manager. I can appreciate the step-by-step process in offering up a solution to this problem, and it's very easy to follow. Bravo on your efforts here.
    geekaren likes this.
  3. jojapath's Avatar
    Member

    Posts
    313 Posts
    #3  
    Well for me, the first option worked. The only difference is that when I went into SETTING and checked, it was already ticked so I unticked it, waited a couple of seconds and ticked it again then restarted.

    I've been receiving updates ever since !!!
    Thanked by:
    Haigs 
    Muessig likes this.
  4. Ishan Pandya's Avatar
    Member

    Posts
    10 Posts
    #4  
    Hi. I have a Nokia Lumia 620 and I have the same issue for which you have posted the fix. I tried all the options which you have mentioned in the first post, but have no luck.

    I have made a suggestion in the community for a manual check for update button for the installed apps. Do vote for the same.
    Last edited by Ishan Pandya; 08-09-2013 at 10:21 AM.
    speedtouch and RAUB like this.
  5. njnbat's Avatar
    Member

    Posts
    92 Posts
    #5  
    Hi , first of all i appreciate your efforts in listing down the step by step procedures. I have encountered a similar issue of live tile not getting updated . However when i visit settings->find my phone, i see only one option and that is find my phone . i dont see the below option .
    Go to settings > find my phone and tick “Send apps to my phone using push notifications (not SMS)”. Restart your phone.

    Can u pls help me out . Meanwhile i am trying my luck with the second option of restart.
  6. Sam Wong's Avatar
    Member

    Posts
    29 Posts
    #6  
    There is only one slider in there after GDR1 update (If I remember correctly)
  7. RAUB's Avatar
    Member

    Posts
    9 Posts
    Global Posts
    279 Global Posts
    #7  
    Quote Originally Posted by Ishan Pandya View Post
    Hi. I have a Nokia Lumia 620 and I have the same issue for which you have posted the fix. I tried all the options which you have mentioned in the first post, but have no luck.

    I have made a suggestion in the community for a manual check for update button for the installed apps. Do vote for the same.
    The same here with my Lumia 925... and nothing helps. I've voted.
    Thanked by:
  8. nonsonobiondo's Avatar
    Member

    Posts
    59 Posts
    #8  
    From the Support chat they suggest me to hard-reset my phone and set my date+time to manual and eventually install my keyboard before configuring my Microsoft Account.
    They told me that configuring the Main account is the last thing you shoul do. I let you know if I solve that way.
  9. speedtouch's Avatar
    Member

    Posts
    1,041 Posts
    Global Posts
    2,148 Global Posts
    #9  
    I've had no update notifications for about 3 weeks now. I fixed it today. I followed all the steps in the original post for weeks now, but sadly, they did not work for me. Here's what worked for me.

    Unpin the Store tile
    Go to Settings > Find my phone > Uncheck 'Send apps to my phone...'
    Go to Settings > Phone update > Uncheck 'Tell me when..' and ' Automatically download...'
    Delete history in Internet Explorer
    Shut down phone and remove battery for 2 minutes

    Boot up phone
    Pin the Store tile
    Go to Settings > Find my phone > Add a check mark to 'Send apps to my phone...'
    Go to Settings > Phone update > Add a check mark to 'Tell me when..' and ' Automatically download...'
    Delete history in Internet Explorer
    Shut down phone and remove battery for 2 minutes

    Boot up phone
    Got 8 update notifications about 30 minutes later

    I left WiFi and cellular data enabled during the entire process.
    Lumia 635
    Thanked by:
    RAUB 
  10. RAUB's Avatar
    Member

    Posts
    9 Posts
    Global Posts
    279 Global Posts
    #10  
    Quote Originally Posted by speedtouch View Post
    I've had no update notifications for about 3 weeks now. I fixed it today. I followed all the steps in the original post for weeks now, but sadly, they did not work for me. Here's what worked for me.
    ...
    Thanks for sharing with us your experience. But the problem is some our devices, like my lumia 925 for example, simply have no removable battery...

    I followed your solution (excepting battery removing ofc) but no luck, still no update notifications in Store. Also, instead of phone shutdown with battery removing, I tried to reset my device. Unfortunately with the same result.
  11. speedtouch's Avatar
    Member

    Posts
    1,041 Posts
    Global Posts
    2,148 Global Posts
    #11  
    Quote Originally Posted by RAUB View Post
    Thanks for sharing with us your experience. But the problem is some our devices, like my lumia 925 for example, simply have no removable battery...

    I followed your solution (excepting battery removing ofc) but no luck, still no update notifications in Store. Also, instead of phone shutdown with battery removing, I tried to reset my device. Unfortunately with the same result.
    Well, crap. Sorry it didn't work out for you. I really wish there were no non-removable battery phones out there. It's such a pain when you need to really do some hard troubleshooting and clearing of memory, etc. I'm surprised it didn't work for you even after a soft reset. Supposedly a soft reset is equivalent to a battery pull. I guess not!
    Lumia 635
  12. RAUB's Avatar
    Member

    Posts
    9 Posts
    Global Posts
    279 Global Posts
    #12  
    Quote Originally Posted by speedtouch View Post
    Well, crap. Sorry it didn't work out for you. I really wish there were no non-removable battery phones out there. It's such a pain when you need to really do some hard troubleshooting and clearing of memory, etc. I'm surprised it didn't work for you even after a soft reset. Supposedly a soft reset is equivalent to a battery pull. I guess not!
    To be honest it's already driving me mad... I don't understand why the Store is not checking for update at start. It could be partial, of course, but solution though.

    Related our problem, I specially kept a several (not really important for me) apps outdated and I'm still not notified about new versions. Weird but it is.
  13. Ishan Pandya's Avatar
    Member

    Posts
    10 Posts
    #13  
    Quote Originally Posted by speedtouch View Post
    I've had no update notifications for about 3 weeks now. I fixed it today. I followed all the steps in the original post for weeks now, but sadly, they did not work for me. Here's what worked for me.
    ...
    It doesn't work for devices with removable batteries as well. I tried your solution with lumia 620, waited 3 days and have not found the solution. Also manually checked app for update(found 1), did not update the app and waited for 1 more day, but it doesn't work. Hopefully MS finds a solution for this.
  14. nonsonobiondo's Avatar
    Member

    Posts
    59 Posts
    #14  
    Quote Originally Posted by Ishan Pandya View Post
    It doesn't work for devices with removable batteries as well. I tried your solution with lumia 620, waited 3 days and have not found the solution. Also manually checked app for update(found 1), did not update the app and waited for 1 more day, but it doesn't work. Hopefully MS finds a solution for this.
    Same phone and same problem here. Do you already have installed "Amber"? And how's set your date+time Manual or Automatic? Thanks
  15. RAUB's Avatar
    Member

    Posts
    9 Posts
    Global Posts
    279 Global Posts
    #15  
    Quote Originally Posted by nonsonobiondo View Post
    Same phone and same problem here. Do you already have installed "Amber"? And how's set your date+time Manual or Automatic? Thanks
    As for me, I've tried both options, auto and manual date+time settings. Latest GDR2 ofc.
  16. Ishan Pandya's Avatar
    Member

    Posts
    10 Posts
    #16  
    Quote Originally Posted by nonsonobiondo View Post
    Same phone and same problem here. Do you already have installed "Amber"? And how's set your date+time Manual or Automatic? Thanks
    I have not received "AMBER" yet. Its still in "Coming Soon" status. And my date+time is set to Automatic.
  17. Ishan Pandya's Avatar
    Member

    Posts
    10 Posts
    #17  
    Hi guys.
    I tried a solution shared by a member
    Steps are as below:
    1.Closed all tabs lying in internet explorer.
    2.Clicked on delete history button in settings of internet explorer.
    3.Removed the live tile .
    4.Did a soft reset by pressing volume down and lock button together.
    5.Pinned the live tile back

    I tried it on my Lumia 620, and got 4 updates (I was updating apps by manually checking previously). Also before I started checking for updates I check for one app which had an updated closed the store app (DID NOT Update the app).
    Hope This helps. Good Luck.
  18. Muessig's Avatar


    Posts
    4,155 Posts
    Global Posts
    4,205 Global Posts
    PIN
    Private Message
    #18  
    Quote Originally Posted by Ishan Pandya View Post
    Hi guys.
    I tried a solution shared by a member
    Steps are as below:
    1.Closed all tabs lying in internet explorer.
    2.Clicked on delete history button in settings of internet explorer.
    3.Removed the live tile .
    4.Did a soft reset by pressing volume down and lock button together.
    5.Pinned the live tile back

    I tried it on my Lumia 620, and got 4 updates (I was updating apps by manually checking previously). Also before I started checking for updates I check for one app which had an updated closed the store app (DID NOT Update the app).
    Hope This helps. Good Luck.
    This tip is already listed in the OP. Glad it worked, though!
    Thanked by:
  19. nonsonobiondo's Avatar
    Member

    Posts
    59 Posts
    #19  
    Quote Originally Posted by Ishan Pandya View Post
    Hi guys.
    I tried a solution shared by a member
    Steps are as below:
    1.Closed all tabs lying in internet explorer.
    2.Clicked on delete history button in settings of internet explorer.
    3.Removed the live tile .
    4.Did a soft reset by pressing volume down and lock button together.
    5.Pinned the live tile back

    I tried it on my Lumia 620, and got 4 updates (I was updating apps by manually checking previously). Also before I started checking for updates I check for one app which had an updated closed the store app (DID NOT Update the app).
    Hope This helps. Good Luck.
    How long did you wait?You have Skype? Thank you :)
  20. Ishan Pandya's Avatar
    Member

    Posts
    10 Posts
    #20  
    Quote Originally Posted by nonsonobiondo View Post
    How long did you wait?You have Skype? Thank you :)
    I waited for 10 min, and got the update. Sent you Skpe ID via PM
  21. rcmarvin's Avatar
    Member

    Posts
    18 Posts
    Global Posts
    64 Global Posts
    #21  
    Simply clearing IE history works for Lumia 620 for a number of times, but it didn't work for me now. I've also tried the method mentioned in this thread, also not working. Sad.
  22. Amran Nagal's Avatar
    Member

    Posts
    162 Posts
    #22  
    I tried all the methods here.
    Its not working for me :(
  23. nonsonobiondo's Avatar
    Member

    Posts
    59 Posts
    #23  
    In some other forums they are suggesting that maybe it's some bad-assembled app that cause the problem. Could you list your apps?
    Mine are App di uso quotidiano - App Highlights Social Beta
  24. Amran Nagal's Avatar
    Member

    Posts
    162 Posts
    #24  
    Okay guys Nokia care tweeted me that if you have more than 1 phone linked to the same live id.
    The problem may occur
    So log into windows phone store and delete the extra phone.
    It will take 2-3 days but this thing actually works.
    Worked for me.
    I got 13 app updates today.
    Thanked by:
    Muessig likes this.
  25. Dragunov2's Avatar
    Member

    Posts
    107 Posts
    #25  
    This one was never activated: Send apps to my phone using push notifications (not SMS) and I got always updates by the Store.

    Now I installed the GDR2 update and I didn't receive an update notification for Screen+Touch
Page 1 of 5 12345 LastLast

Similar Threads

  1. Help! "No Service" On Unlocked Rogers Lumia 920
    By BobR1908 in forum Nokia Lumia 920
    Replies: 40
    Last Post: 10-16-2013, 09:26 PM
  2. Tiles aren't auto updating
    By clmbngbkng in forum Windows Phone 8
    Replies: 14
    Last Post: 07-14-2013, 07:43 AM
  3. Not so responsive in multipage thread
    By khunhorm in forum Windows Central for Windows Phone - App Support
    Replies: 4
    Last Post: 07-12-2013, 05:48 AM
  4. Replies: 5
    Last Post: 07-11-2013, 07:29 AM

Posting Permissions