Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 18 of 18
Like Tree3Likes
  • 1 Post By thebordone
  • 2 Post By whitelightning_sam
  1. thebordone's Avatar
    Member

    Posts
    6 Posts
       #1  
    Do people know of WP8 will support this WLAN type?
    Brian Geller likes this.
  2. Goodbyemoff's Avatar
    Member

    Posts
    12 Posts
    #2  
    I would also like to know. Considering all the "enterprise" features WP8 has Id say so, but I would like confirmation. I might finally be able to log onto uni wifi :)
  3. MSIntuser76's Avatar
    Member

    Posts
    1 Posts
    #3  
    WP8 does not have TTLS/PAP support. Only EAP-TLS support
  4. marbla's Avatar
    Member

    Posts
    83 Posts
    Global Posts
    111 Global Posts
    #4  
    Did you try? If it does have EAP-TLS support then TTLS should work. The latter is supported in win8 and I don't know if they allow non global certificates for the former.
    Whatever... I will get my 8x tomorrow or the day after and try out our eduroam and post here. Works with my win8 laptop without supplicant already.

    Sent from my Lumia 800 using Board Express
  5. jjmurphy's Avatar
    Member

    Posts
    258 Posts
    Global Posts
    261 Global Posts
    #5  
    So I tried installing all the certificates that I could find for my University wireless, and it still isn't working. My next step is to contact the network folks and see if they can tell what is happening on their end.
  6. marbla's Avatar
    Member

    Posts
    83 Posts
    Global Posts
    111 Global Posts
    #6  
    Seems strange that they would add a native version in win8 but not wp8. On the other hand it should be a piece of cake to port for ms with the same kernel and all. Hope it's there or coming, no database access sucks.
  7. mrrajesh28's Avatar
    Member

    Posts
    1 Posts
    #7  
    Quote Originally Posted by MSIntuser76 View Post
    WP8 does not have TTLS/PAP support. Only EAP-TLS support
    WP8 doesnt support EAP-TLS. Here is the direct message that I got from Joe Belfiore himself in twitter;

    Twitter / mrrajesh28: Wifi Security EAP-TLS is NOT ...


    "it’s something we are aware of and following up on. not in the very near future, but likely coming at some point."


    Lets vote for this feature again: Add EAP-TLS Authentication support for WiFi
  8. marbla's Avatar
    Member

    Posts
    83 Posts
    Global Posts
    111 Global Posts
    #8  
    Well that's disappointing to state it mildly. I have a workaround for my workplace but our hospital and university depend on that for the eduroam network.

    I love the OS but that kind of makes you wonder what they where thinking when they blurbed about all that business features... effectively noone out of the 15 000 people at our school that want to use the mobile internet at work can use wp... and that's just one of the many universities.

    Oh well. I'm still looking forward to my 8x. For others in the eduroam system I have a workaround that is not very elegant but it works: Look at the network map and see if you have friends who work at a university with a different security protocol e.g. MS-CHAP. If you use their credentials at your home university you can access the eduroam network without EAP-TTLS. As I said: Not very elegant but if you need the network it's a way in.

    P.S. Vote on for the feature! It's high enough in the connectivity bracket that they should have noticed by now.
    Last edited by marbla; 11-14-2012 at 06:08 PM.
  9. philxor's Avatar
    Member

    Posts
    280 Posts
    #9  
    I experienced the same issues trying to get it to connect to my office WiFi which has been working fine with my IPhone for years now.

    It's honestly baffling all of the features which are available on other smartphone OS and even things which were in WP7 which are completely missing from WP8, it really does feel like a beta operating system.
  10. F2a
    F2a is offline
    F2a's Avatar
    Member

    Posts
    33 Posts
    Global Posts
    34 Global Posts
    #10  
    Yep, can't connect to my University's wireless network. Luckily there is a separate one for laptops but I have to log in via the browser to access it. And since the wifi turns off and on all the time... it's FAR from ideal.
  11. marbla's Avatar
    Member

    Posts
    83 Posts
    Global Posts
    111 Global Posts
    #11  
    By the way:
    http://windowsphone.uservoice.com/fo...pport-for-wifi
    Keep voting! That's the best thing we can do to get this moving.
  12. #12  
    I had the same problem too, and was able to solve it. It has to do with the format of the security certificates. Most certificates are .crt files, but WP8 can't use these, and needs a .cer file. Follow these steps to get them.

    1. The phone automatically detects all PEAP and MSCHAP settings.

    2. I had to download a certificate from a website on my computer (in my case it was the UTN-Userfirst-Hardware). Most phones accept certificates in the .crt format, but WP8 accepts only .cer (just like Symbian, but this is widely documented)

    3. On your computer, double click on your downloaded crt file, and hit open.

    4. You should see a new window open with three tabs - General, Details and Certificate Path. Click on the Details tab.

    5. On the lower right, you will find a "Copy to File" button. Hit it and it should open a Certificate Export Wizard.

    6. Hit next, and when select the "Base-64 encoded X.509" format. Hit "Next".

    7. Save the new file. Best to give the same file name as the .cer.

    8. From your computer, email the .cer file as an attachment to yourself.

    9. On your Lumia, open your email and download the attachment. The phone should prompt you to install the certificate.

    10. Now go to settings, find your uni's wireless, put in your username and password, and select the certicate you just installed, and you should be good to go.
    Thanked by:
    R42 and mkayik like this.
  13. R42
    R42 is offline
    R42's Avatar
    Member

    Posts
    29 Posts
    Global Posts
    41 Global Posts
    #13  
    Hope this will work

    Have to bump it up for newer generations to see this

    Tomorow i will go to my uni and see if i can work this out. It was frustrating seeing they had step by step help for mac os, windows, android and ios but none for wp.

    Thanks

    Quote Originally Posted by whitelightning_sam View Post
    I had the same problem too, and was able to solve it. It has to do with the format of the security certificates. Most certificates are .crt files, but WP8 can't use these, and needs a .cer file. Follow these steps to get them.

    1. The phone automatically detects all PEAP and MSCHAP settings.

    2. I had to download a certificate from a website on my computer (in my case it was the UTN-Userfirst-Hardware). Most phones accept certificates in the .crt format, but WP8 accepts only .cer (just like Symbian, but this is widely documented)

    3. On your computer, double click on your downloaded crt file, and hit open.

    4. You should see a new window open with three tabs - General, Details and Certificate Path. Click on the Details tab.

    5. On the lower right, you will find a "Copy to File" button. Hit it and it should open a Certificate Export Wizard.

    6. Hit next, and when select the "Base-64 encoded X.509" format. Hit "Next".

    7. Save the new file. Best to give the same file name as the .cer.

    8. From your computer, email the .cer file as an attachment to yourself.

    9. On your Lumia, open your email and download the attachment. The phone should prompt you to install the certificate.

    10. Now go to settings, find your uni's wireless, put in your username and password, and select the certicate you just installed, and you should be good to go.
  14. e4et's Avatar
    Member

    Posts
    96 Posts
    #14  
    Mailing the certificate and Intalling in the .cer format definately works. I just tested this.
    Will see if i can connect to the corporate wifi when i get to the office tomorrow.
  15. jjmurphy's Avatar
    Member

    Posts
    258 Posts
    Global Posts
    261 Global Posts
    #15  
    I haven't tried this again since Portico, but before I couldn't get it to work on my university wifi.
  16. #16  
    Hi,


    that does not solve the problem stated above. You had a problem connecting to a EAP-TLS / PEAP /MS-CHAPv2 Network. Which is as easy it comes (and the whole certificate foo should not have been nessesary), but hey it definitly works the way you tell.

    As for the Problem above connecting to a EAP-TTLS / PAP Network (i.e. every University with sane network admins :) ) - There is no solution to this problem whatsoever. - But hey it works in Win8 so that I'm guessing Microsoft will figure this out. So keep complaining.

    cuKALLE
  17. mkayik's Avatar
    Member

    Posts
    2 Posts
    #17  
    Quote Originally Posted by whitelightning_sam View Post
    I had the same problem too, and was able to solve it. It has to do with the format of the security certificates. Most certificates are .crt files, but WP8 can't use these, and needs a .cer file. Follow these steps to get them.

    1. The phone automatically detects all PEAP and MSCHAP settings.

    2. I had to download a certificate from a website on my computer (in my case it was the UTN-Userfirst-Hardware). Most phones accept certificates in the .crt format, but WP8 accepts only .cer (just like Symbian, but this is widely documented)

    3. On your computer, double click on your downloaded crt file, and hit open.

    4. You should see a new window open with three tabs - General, Details and Certificate Path. Click on the Details tab.

    5. On the lower right, you will find a "Copy to File" button. Hit it and it should open a Certificate Export Wizard.

    6. Hit next, and when select the "Base-64 encoded X.509" format. Hit "Next".

    7. Save the new file. Best to give the same file name as the .cer.

    8. From your computer, email the .cer file as an attachment to yourself.

    9. On your Lumia, open your email and download the attachment. The phone should prompt you to install the certificate.

    10. Now go to settings, find your uni's wireless, put in your username and password, and select the certicate you just installed, and you should be good to go.
    I can't success too.
    Certificate is not enough for this problem.
    I think we have to wait for ms.
    thanks...
  18. theothercurtis's Avatar
    Member

    Posts
    1 Posts
    #18  
    Seconded. The "solution" is for a different problem.

    This may be helpful (although not hopeful): Extensible Authentication Protocol - Wikipedia, the free encyclopedia

    Microsoft did not incorporate native support for the EAP-TTLS protocol in Windows XP, Vista, or 7. Supporting TTLS on these platforms requires third-party ECP (Encryption Control Protocol) certified software. Microsoft Windows started EAP-TTLS support with Windows 8,[16] however Windows Phone 8 does not support EAP-TTLS.[17]

Posting Permissions