Get ready for beta!

Halo Wars 2 Blitz: Game modes, beginner's tips, and more

One Windows

Microsoft is building a new Windows 10 Shell for PC, Mobile and Xbox

On the Inside

Everything you need to know about the Xbox Insider Program

Beautiful compromises

Surface Studio review: you'll want one, even if you don't need one

3-in-1

Is this the Surface Phone? Microsoft awarded patents for foldable devices

Windows Central Offers

MCSE Certification bundle is just $39

Even more improvements

All the changes found in Windows 10 build 15007!

Games as a Service

What does the cancellation of Scalebound mean for future Xbox exclusives?

Windows Central Offers

Save $90 on these FRESHeBUDS Pro Magnetic Bluetooth Earbuds

Returning for 2017

We're back with an new episode of #AskDanWindows

Lifetime Subscription

VPNSecure is currently 91% off

Our favorite things

The Best of CES 2017 Awards

Infinity Edge in your hand

The XPS 13 2-in-1 is the Dell convertible we've always wanted

Project Valerie

Razer just made a laptop with three — THREE! — 17-inch 4K displays. 😱

Great design from Palo Alto

HP's CES 2017 releases are truly gorgeous PCs

Intel and Google's big day

CES 2017 Day Two: New laptops, new phones, and old ideas made new

Take five is better than ever

The updated Lenovo ThinkPad X1 packs Kaby Lake chips and zero bloatware

Everything we know about the next Xbox: Project Scorpio

UWPowered

'Game Mode' for Windows 10 will power Xbox One and Scorpio games too

Buyer's guide

Best accessories for Microsoft Surface Book

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1.    #1  
    I purchased a Lumia 820 off-contract, popped in my Straight Talk AT&T SIM from my Lumia 900, added the correct APN/MMS settings and started running. Now, I've done 2 hard resets in hopes of figuring out what's wrong, but IE10 is slow as crap. Sites and videos that used to load just fine, in the same areas and places, are moving at a crawl with my Lumia 820. I do not have desktop mode enabled, and left everything default.

    Has anyone else experienced this? Did you have to call Straight Talk perhaps to get something configured before moving to Windows Phone 8? Just trying to figure why everything is so much slower now (along with getting "can't connect" errors at times with full 4G bars).
  2. shinygerbil's Avatar
    Member

    Posts
    208 Posts
    #2  
    That sounds like a connection issue rather than an IE10 issue. Do other apps run fine? Or is IE10 actually sluggish to use?
  3.    #3  
    I'm calling Straight Talk to make sure everything is ok, but this was never an issue with my previous WP 7.5 devices. Usually other apps run fine, although there are time when signing into accounts and using the speech features give me "can't connect errors at time", so it appears to be both. On Wifi, IE 10 seems fine (still a little slower than I'm use to at times), so perhaps it is a network issue.EDIT: Scratch it. After calling Straight Talk and having them do a refresh, my speeds are insanely quick.....like Wifi quick. It's so weird how much faster this is now...like omg fast lol.....
    Last edited by jrdatrackstar1223; 12-11-2012 at 10:57 AM.

Similar Threads

  1. Slow Keyboard?
    By Copiondor in forum Samsung Focus
    Replies: 5
    Last Post: 01-07-2011, 01:23 AM
  2. Scrolling seems a little slow
    By ninjaap in forum HTC Surround
    Replies: 2
    Last Post: 12-17-2010, 03:34 PM
  3. Slow 3G download speeds on AT&T
    By gravage in forum Samsung Focus
    Replies: 0
    Last Post: 12-02-2010, 05:17 PM

Posting Permissions