Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 19 of 19
  1. micTronic's Avatar
    Member

    Posts
    4 Posts
       #1  
    Hi,

    I encountered a problem with my new Lumia 920: For incoming calls (and also in the call history), often only the number is shown, even if I have a contact with that number in my contacts list.
    For some numbers, I could resolve this by saving the contact number again without spaces (which by itself is a joke - is it too hard for WP to see the numbers are the same when they contain spaces?!). For others, this does not work either. I press the number in the call history and "save" it again for the contact (overwriting the identical one), but still the names are not shown.

    Does anyone have the same problem on their phone? Is any fix known?
    This is very annoying since it's such a simple and basic thing. And I'm not really good in remembering numbers...
  2. Ruslan.al's Avatar
    Member

    Posts
    61 Posts
    #2  
    Try to reboot your phone.. I had this issue several times.
  3. micTronic's Avatar
    Member

    Posts
    4 Posts
       #3  
    That actually seems to work... let's see if it stays! Thanks!
  4. John Lockett's Avatar
    Member

    Posts
    1 Posts
    #4  
    I have a Nokia Lumia 822 and just noticed that I no longer get reverse number to contact lookups on inbound calls. I use to see the contact with a picture but now all inbound calls just show a phone number. I tried rebooting but it still has the same behavior.

    Any ideas, is this a new bug or application coexistence issue with Skype or something else?
  5. Guzzler3's Avatar
    Developer

    Posts
    949 Posts
    #5  
    Question: Do you use Outlook with the Hotmail connector on your PC?
    Guz

    iPhone 3G (broken)
    Blackberry 6320 (retired)
    Lumia 810 (current)
  6. #6  
    I have this same issue, to the best of my knowledge I don't use a Hotmail connector with Outlook, not actually sure what that is. A hard reset (Volume Down+Power) does fix it, but only for a brief period. I have the following accounts on my phone:
    Facebook
    Gmail (no contacts, tasks, calendar, Email ONLY)
    Exchange work (everything (contacts, tasks, email, calendar)
    Hotmail/Live/Outlook.com (my "Windows" account)
  7. micTronic's Avatar
    Member

    Posts
    4 Posts
       #7  
    For me rebooting also did not fix it permanently, but it seems to sometimes occur less and sometimes more, very weird.
    I also don't use Outlook, but have Skype installed.
  8. Guzzler3's Avatar
    Developer

    Posts
    949 Posts
    #8  
    Quote Originally Posted by Michael Carpenter View Post
    I have this same issue, to the best of my knowledge I don't use a Hotmail connector with Outlook, not actually sure what that is.
    "Hotmail connector" is a piece of software that allows you to use MS Office Outlook with Hotmail/Live/Outlook.com email accounts.

    I'm still playing around and haven't completely verified it, but my suspicion is there is a file lock issue with the contacts when you use MSO Outlook with your Hotmail/Live/Outlook account. Mainly when you leave MSO Outlook running on your computer, and then your computer goes to sleep or hibernates. Then things get funky.

    (There has to be a better way of differentiating the various "Outlook" names that Microsoft uses now, I think they've gone a bit overboard)
    Guz

    iPhone 3G (broken)
    Blackberry 6320 (retired)
    Lumia 810 (current)
  9. silkyrichness's Avatar
    Member

    Posts
    1 Posts
    #9  
    This is happening to me all the time and the reboot typically works for about 30mins before it seizes up again. I've quite a lot of contacts across a lot of networks and I'm wondering if that is causing it to choke. Its getting to the point I'm having trouble being positive about its other great features when it is failing so badly on the basics.
  10. Coreldan's Avatar
    Member

    Posts
    2,538 Posts
    Global Posts
    2,546 Global Posts
    #10  
    Go to settings, then email and accounts and see if all accounts are syncing properly. I had a similar issuer which was caused by nothing syncing up properly. I had to do a hard reset to fix it.
  11. josipogo's Avatar
    Member

    Posts
    113 Posts
    #11  
    Same problem on my Lumia 920, do not shows names under call history only numbers, weird I did not have this problem before Nokia Amber Update, and it really start to be a issue. By the way, after some period it shows names but not for full call history. Maybe last calls (incoming/outgoing) that they made in last 30 minutes, not shows names, even for same number.
    It must be some bug.
  12. Doohickie's Avatar
    Member

    Posts
    317 Posts
    #12  
    Quote Originally Posted by Coreldan View Post
    Go to settings, then email and accounts and see if all accounts are syncing properly. I had a similar issuer which was caused by nothing syncing up properly. I had to do a hard reset to fix it.
    When you do a hard reset, do you lose contacts resident in your phone? Or are they stored on the Sim Card and come back after the reset?
  13. josipogo's Avatar
    Member

    Posts
    113 Posts
    #13  
    Everything is sync at least not showing: not sync. Right now is updated call history three hour ago.
  14. josipogo's Avatar
    Member

    Posts
    113 Posts
    #14  
    By the way, when I am, just this moment, create the same HOTMAIL account, meaning same user and pass, everything is fine. Still testing.
  15. Veso Mitev's Avatar
    Member

    Posts
    1 Posts
    #15  
    Hello good Sirs,

    I have similar (or perhaps the same) problem. HTC 8S here.

    Tried various noob fixes (resets), but it only fixes the issue for about a week or two. Then it returns.

    Started a similar topic on the official MS community, yet no result. People are having this issue and so far I haven't hound a solution. At first I thought it is power related i.e. the 8s lacking operative memory, but this seems not to be the case, since far more powerful devices have the same problem it seems.

    Have you found any solutions for this?

    It's present, btw, after the last software update.
  16. Ali Assaedi's Avatar
    Member

    Posts
    117 Posts
    #16  
    for me the problem is with country codes
    if i use a + instead of a 00, the name wont show
    or the other way around, cant remember :P
    so, yea, try that if u use country codes :)
  17. josipogo's Avatar
    Member

    Posts
    113 Posts
    #17  
    I am still experiencing problem, if I have huge amount of calls in very short period, history log knows not to show them or simply not show whose call, in other words just show number. Usually, power off/on.
    Maybe GDR3 preview solve this issue.
    Cheers.
  18. Zeeshan125's Avatar
    Member

    Posts
    1 Posts
    #18  
    I am also having the same issue, the problem appeared after the amber update, contacts are there but are not shown while receiving a call :-/
  19. josipogo's Avatar
    Member

    Posts
    113 Posts
    #19  
    Do not know what could be reason but still from time to time it happens, on GDR3 developer edition. Power off/on help but would be nice to be investigated by MS.
    Cheers.

Similar Threads

  1. Replies: 9
    Last Post: 11-11-2012, 06:24 AM
  2. Phone Settings/Incoming Call Speech?
    By Stormjenkins in forum Nokia Lumia 710
    Replies: 4
    Last Post: 04-03-2012, 01:31 PM
  3. Replies: 0
    Last Post: 04-02-2011, 02:01 PM

Posting Permissions