Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 10 of 10
  1. aelesiaa's Avatar
    Member

    Posts
    16 Posts
       #1  
    When I try to access maps.google.com using my Lumia 920, it simply redirects me back to the main Google page again.
  2. manunitedfan5's Avatar
    Member

    Posts
    56 Posts
    #2  
    Same and I can't find google discussions!
  3. TheDvlsAdvc8's Avatar
    Member

    Posts
    104 Posts
    #3  
    Google is playing dirty. Probably because Microsoft went after Android phone makers infringing on Microsoft intellectual property for licensing fees... and now makes money on most Android phones sold.
  4. FredW3's Avatar
    Member

    Posts
    47 Posts
    #4  
    Google is blocking you. Kind of like the corporate equivalent of a spoiled child tantrum.
  5. aelesiaa's Avatar
    Member

    Posts
    16 Posts
       #5  
    Seriously? Is that a fact or is it just an unfounded accusation against Google?
  6. #6  
    It works if you change your settings to desktop. :)
    Thanked by:
  7. stmav's Avatar
    Retired Moderator

    Posts
    3,685 Posts
    Global Posts
    3,767 Global Posts
    #7  
    Nope, mine is always in desktop and it redirects to the main page as well.
  8. aelesiaa's Avatar
    Member

    Posts
    16 Posts
       #8  
    Have you tried it? I tried that but it didn't seem to work either.

    The "desktop" version doesn't seem to work very well btw. I'm still getting mobile sites in Google.com and some other websites.
  9. ExcaliburII's Avatar
    Member

    Posts
    115 Posts
    Global Posts
    122 Global Posts
    #9  
    just gave it a try, and seems to be coming up o.k.

    try to clear your settings. I also have the cookies set to only "block some".
    Thanked by:
  10. manunitedfan5's Avatar
    Member

    Posts
    56 Posts
    #10  
    Quote Originally Posted by ExcaliburII View Post
    just gave it a try, and seems to be coming up o.k.

    try to clear your settings. I also have the cookies set to only "block some".
    I just changed to desktop and selected accept all and now I can use discussions!!! Thank you very much, you don't understand how happy I am now haha

    Thanks

Similar Threads

  1. Replies: 4
    Last Post: 04-06-2013, 03:34 PM
  2. Was anyone else able to place a successful preorder..
    By blackprince in forum General Tablet Discussion
    Replies: 12
    Last Post: 10-17-2012, 11:04 PM
  3. How do I view a google map route?
    By dainouye in forum Windows Phone Apps
    Replies: 1
    Last Post: 10-06-2012, 03:32 AM
  4. My Outlook is not able to reply nor forward emails
    By sinister1 in forum Windows Phone 7
    Replies: 12
    Last Post: 06-26-2012, 05:45 PM
  5. Replies: 0
    Last Post: 06-14-2011, 05:03 PM

Posting Permissions