Get ready for beta!

Halo Wars 2 Blitz: Game modes, beginner's tips, and more

One Windows

Microsoft is building a new Windows 10 Shell for PC, Mobile and Xbox

On the Inside

Everything you need to know about the Xbox Insider Program

Beautiful compromises

Surface Studio review: you'll want one, even if you don't need one

3-in-1

Is this the Surface Phone? Microsoft awarded patents for foldable devices

Windows Central Offers

MCSE Certification bundle is just $39

Even more improvements

All the changes found in Windows 10 build 15007!

Games as a Service

What does the cancellation of Scalebound mean for future Xbox exclusives?

Windows Central Offers

Save $90 on these FRESHeBUDS Pro Magnetic Bluetooth Earbuds

Returning for 2017

We're back with an new episode of #AskDanWindows

Lifetime Subscription

VPNSecure is currently 91% off

Our favorite things

The Best of CES 2017 Awards

Infinity Edge in your hand

The XPS 13 2-in-1 is the Dell convertible we've always wanted

Project Valerie

Razer just made a laptop with three — THREE! — 17-inch 4K displays. 😱

Great design from Palo Alto

HP's CES 2017 releases are truly gorgeous PCs

Intel and Google's big day

CES 2017 Day Two: New laptops, new phones, and old ideas made new

Take five is better than ever

The updated Lenovo ThinkPad X1 packs Kaby Lake chips and zero bloatware

Everything we know about the next Xbox: Project Scorpio

UWPowered

'Game Mode' for Windows 10 will power Xbox One and Scorpio games too

Buyer's guide

Best accessories for Microsoft Surface Book

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 11 of 11
  1. lasm2000's Avatar
    Member

    Posts
    30 Posts
    Global Posts
    37 Global Posts
       #1  
    Hi, I just got a Lumia 620 but I have quite a bunch of issues which might or might not be related. Just to be sure I am posting them together in case it pinpoints to a culprit.

    - The most annoying one is that the integrated chat (the one for messenger/facebook) is not working. It just says "unable to connect to chat" and I have tried to change password on outlook.com and restarting the device for a gazillion of times.

    - Notifications are very random. It is not infrequent that I open whatsapp and receive a bunch of unread messages. Yet there was no notification in the live tile nor the small push notifications that appear on the top of the screen. As mentioned before, this is quite random, sometimes I do get my notifications in timely form and in others I just see the messages hours later when I explicitly open whatsapp (or viber). By the way, shouldn't those notifications also appear in the block screen?

    - A small issue, but probably related is that the bing image for the block screen never changes. It is supposed to change everyday but in fact only changes if I go to the configuration screen and change to another background image and then select again bing (so then it just loades the image of the day).

    I am not sure where to pinpoint these issues, some look like failures in the data connection, but then, this happens all the time in my home's wifi connection, which while not great should be more than enough to get a damn whatsapp message :| Any ideas would be appreciated. :)
  2. ttsoldier's Avatar
    Retired Ambassador

    Posts
    4,160 Posts
    Global Posts
    4,833 Global Posts
    #2  
    Quote Originally Posted by lasm2000 View Post
    Hi, I just got a Lumia 620 but I have quite a bunch of issues which might or might not be related. Just to be sure I am posting them together in case it pinpoints to a culprit.

    - The most annoying one is that the integrated chat (the one for messenger/facebook) is not working. It just says "unable to connect to chat" and I have tried to change password on outlook.com and restarting the device for a gazillion of times.

    - Notifications are very random. It is not infrequent that I open whatsapp and receive a bunch of unread messages. Yet there was no notification in the live tile nor the small push notifications that appear on the top of the screen. As mentioned before, this is quite random, sometimes I do get my notifications in timely form and in others I just see the messages hours later when I explicitly open whatsapp (or viber). By the way, shouldn't those notifications also appear in the block screen?

    - A small issue, but probably related is that the bing image for the block screen never changes. It is supposed to change everyday but in fact only changes if I go to the configuration screen and change to another background image and then select again bing (so then it just loades the image of the day).

    I am not sure where to pinpoint these issues, some look like failures in the data connection, but then, this happens all the time in my home's wifi connection, which while not great should be more than enough to get a damn whatsapp message :| Any ideas would be appreciated. :)
    Your first and third point sound seriously like a data connection issue. Is there a better WiFi connection you can connect to? Also, please ensure that battery saver is off.

    Whatsapp is generally buggy and is no fault of yours. There is currently a version in beta that wil be released very shortly. This should fix your whatsapp problems
  3. dkp23's Avatar
    Member

    Posts
    1,494 Posts
    Global Posts
    1,529 Global Posts
    #3  
    Im guessing in general, this is a data connection issue. I have a 620 i am using in the U.S and it seems to be ok for now.

    I just checked the bing image and it changed this morning so not sure what the issue is for you, again, perhaps data.

    Whatsapp, the problems you have date all the way back at launch of wp8, same issues i had with my lumia 920 which i eventually uninstalled, it wasn't reliable. So this is a wp8 wide issue for the msot part, maybe data issue again.

    I dont use the integrated chat much, but the little i did use, worked fine, again, i dont use it much so dont have extensive experience.

    I'd check your data connection, stay off wifi for now and see how your phoen does with just data. You probably dont wan to go on wifi right now because it would just mask any problems you may have with reception which may be caused by a hardware issue.
  4. #4  
    Agree with ttsoldier.
  5. lasm2000's Avatar
    Member

    Posts
    30 Posts
    Global Posts
    37 Global Posts
       #5  
    Thanks for your replies. I tried by turning off battery saver and then rebooting the phone, perhaps a bit excessive but it did the trick... for a while. It managed to connect and all fine but now is again failing. Looks weird to me that it just worked for a few hours. In the interim I was out of home, so maybe at sometime the 3g network snapped, but then why it just refuses to connect again if I explicitly put myself offline and then as "available"?

    On an unrelated issue, how much life out of the battery are you getting from a 620? Mine gets around 3 hours of browsing, at most. Seems way to little to me. It comes with a 1300 mAH battery. Is that what everyone else is getting? I see some online reviews reporting a 1430 mAH batteries and way better lifetimes.
  6. dkp23's Avatar
    Member

    Posts
    1,494 Posts
    Global Posts
    1,529 Global Posts
    #6  
    Im on ATT in the U.S. I have 3 emails 2 receiving as they come and one pushing every 30 minutes. I have 3 apps running in the background, bluetooth and nfc off most of the day, but will use bluetooth when i drive to work and drive home which is about 1.5 hours each day combined. I probably surf almost an hour for lunch in my car and check peoplehub from time to time during the day. Perhaps about 20-25 texts max and a couple minutes of calls a day.

    Taking off my phone at 730am and by 5 pm when i go home from work, my % is probably going to be 30%-40%. I can probably manage to get to bed time at 11pm or 12 am with maybe 10% or less left, but that is if i baby the phone.

    With the same usage on my 920, i'd probably be at 50-60% when i go home from work and easily have 20-30% by the time i go to bed at 11pm or 12am.

    The battery wasn't great the first couple days, first couple days i had to recharge by 7 or 8pm. Now, i probably get it to 11pm or 12am for bedtime.

    Not the greatest battery life, but if it gets me through the day without charging, thats all i ask for. I am investing in a backup battery as well.
  7. #7  
    Quote Originally Posted by lasm2000 View Post
    Thanks for your replies. I tried by turning off battery saver and then rebooting the phone, perhaps a bit excessive but it did the trick... for a while. It managed to connect and all fine but now is again failing. Looks weird to me that it just worked for a few hours. In the interim I was out of home, so maybe at sometime the 3g network snapped, but then why it just refuses to connect again if I explicitly put myself offline and then as "available"?

    On an unrelated issue, how much life out of the battery are you getting from a 620? Mine gets around 3 hours of browsing, at most. Seems way to little to me. It comes with a 1300 mAH battery. Is that what everyone else is getting? I see some online reviews reporting a 1430 mAH batteries and way better lifetimes.
    I use mine for video watching online for 1 hour and internet for normal browsing for 1 hour on wifi, gaming for 2 hours, music for 2 hours. Battery goes from 100% to roughly 50% . I don't use 3G. Standby time is usually 1 day 18 hours from 100% to 0%.
  8. OzRob's Avatar
    Member

    Posts
    604 Posts
    Global Posts
    636 Global Posts
    #8  
    Quote Originally Posted by lasm2000 View Post
    On an unrelated issue, how much life out of the battery are you getting from a 620? Mine gets around 3 hours of browsing, at most. Seems way to little to me. It comes with a 1300 mAH battery. Is that what everyone else is getting? I see some online reviews reporting a 1430 mAH batteries and way better lifetimes.
    My 620 makes it through a full day of light to moderate use. If you're browsing via 3G, keep in mind that signal strength has a huge impact an the power consumed. If you're in a marginal signal area the 3G radio will ramp up the transmission power to maintain a connection. This can really chew through battery charge.
  9. lasm2000's Avatar
    Member

    Posts
    30 Posts
    Global Posts
    37 Global Posts
       #9  
    Turned out that 3G was indeed the culprit. As soon as I turned it off the messages application managed to go online (so apparently it connects by default on the data network and only goes to wifi if that is unavailable) and battery time was also greatly improved. Now it can survive the day. Thanks for your replies.
  10. OzRob's Avatar
    Member

    Posts
    604 Posts
    Global Posts
    636 Global Posts
    #10  
    Quote Originally Posted by lasm2000 View Post
    Turned out that 3G was indeed the culprit. As soon as I turned it off the messages application managed to go online (so apparently it connects by default on the data network and only goes to wifi if that is unavailable) and battery time was also greatly improved. Now it can survive the day. Thanks for your replies.
    If you're talking about SMS text messaging, it only transmits via the cellular data network - SMS is a cellular protocol and never uses the WiFi connection.
  11. #11  
    hey guys i have a problem..

    i own a L720 and for me, whatsapp is a pain in the *** on data connection.not only whatsapp but almost all messaging app that uses data. it works fine with the wifi...with data connection, my messages are arrives late, and the just shows the small clock icon below the messages. i really dont know whats wrong with it because i already soft and hard reset it , but didnt help...i think microsoft gotta fix this. i tried two different networks and its still the same...
    i also own a c7 nokia and the whatsapp is flawless... :(

Similar Threads

  1. Is there variable speed playback of mp3s in WP8?
    By bradleyj in forum Windows Phone 8
    Replies: 4
    Last Post: 02-20-2014, 10:12 AM
  2. Pinch to zoom in IE is jittery on Lumia 620
    By ListenUpGuys in forum Nokia Lumia 620
    Replies: 2
    Last Post: 02-27-2013, 01:41 AM
  3. Does Skype for WP8 run in the background?
    By TechAbstract in forum Windows Phone Apps
    Replies: 7
    Last Post: 01-16-2013, 05:51 AM
  4. List of Apps / Games Missing in WP8
    By jhoff80 in forum Windows Phone 8
    Replies: 1
    Last Post: 11-09-2012, 09:08 PM
  5. GIF of start menu animation in WP8
    By VagrantWade in forum Windows Phone 8
    Replies: 12
    Last Post: 09-27-2012, 07:26 PM

Posting Permissions