Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 15 of 15
Like Tree1Likes
  • 1 Post By OzRob
  1. Quitch's Avatar
    Member

    Posts
    8 Posts
       #1  
    So I've run into a problem I can't solve.

    I'd connected my Microsoft account to LinkedIn, but since enabling two-factor authentication it wants me to do it again. Problem is part of this process involves inputting a code received via SMS, but if I switch to the Messaging page to get the code I am booted back to the accounts list rather than the "enter the code" page, and when I go back through the connection process to use the code I am sent... a new code.

    I cannot find a way (which doesn't involve a second phone) of collecting and entering this code, and therefore am unable to link to my Linkedin account.

    Is there any way to make this work?
  2. Need4Geek's Avatar
    Member

    Posts
    66 Posts
    Global Posts
    72 Global Posts
    #2  
    This happened to me when I was setting up SkyDrive. Try to put your Windows Phone in landscape mode so you can read the verification code when the toast notification pops up.
  3. Quitch's Avatar
    Member

    Posts
    8 Posts
       #3  
    Unfortunately it doesn't support landscape mode so the toast still appears at the "top" of the screen.
  4. Fred P's Avatar
    Member

    Posts
    100 Posts
    Global Posts
    103 Global Posts
    #4  
    1) install the authenticator app (from MS) on your phone.
    2) go to live.com and link the authenticator app to your ms account
    3) run the app on your phone and take note of the number
    4) go to the 3rd party app (in this case linkedin) on your phone and login

    hope this helps
    F
  5. Quitch's Avatar
    Member

    Posts
    8 Posts
       #5  
    How will that help? The authenticator is linked to my Microsoft account, but it's LinkedIn asking for the code, and LinkedIn use SMS codes for authentication not the authenticator I have linked to my Microsoft account.
  6. Fred P's Avatar
    Member

    Posts
    100 Posts
    Global Posts
    103 Global Posts
    #6  
    i thought the sms codes were coming from microsoft. that the two factor authentication was for the microsoft login on these lines:

    Set up a Twitter or LinkedIn account | Windows Phone How-to (United States)
  7. Quitch's Avatar
    Member

    Posts
    8 Posts
       #7  
    No, the code is from LinkedIn as you are logging into your account from an unknown device. This is verified by the e-mail which also comes from LinkedIn telling you this. The SMS also identifies itself as a LinkedIn code. The reason I have to relink my account is because I enabled two-factor authentication on my LinkedIn account.
  8. Fred P's Avatar
    Member

    Posts
    100 Posts
    Global Posts
    103 Global Posts
    #8  
    sorry, then
    the only thing i can think of is to add the linkedin sms number to your contacts and give it a very short name like A

    hopefully that will save enough characters that the toast will be able to show the code, without needing to resort to landscape

    hope this is more useful

    f
  9. OzRob's Avatar
    Member

    Posts
    604 Posts
    Global Posts
    634 Global Posts
    #9  
    Quote Originally Posted by Quitch View Post
    No, the code is from LinkedIn as you are logging into your account from an unknown device. This is verified by the e-mail which also comes from LinkedIn telling you this. The SMS also identifies itself as a LinkedIn code. The reason I have to relink my account is because I enabled two-factor authentication on my LinkedIn account.
    I recently did this on my 720. I don't recall having a problem. From what I remember I opened the messaging app first, then went to the account settings to do the linking. When the message came I long-pressed on the back button and selected the messaging app, got the code then long-pressed back again and selected the window to enter the code.
  10. Quitch's Avatar
    Member

    Posts
    8 Posts
       #10  
    When I do that it leaves the linking screen and sends me back to the accounts list.
  11. MazoMark's Avatar
    Member

    Posts
    71 Posts
    Global Posts
    189 Global Posts
    #11  
    Quote Originally Posted by OzRob View Post
    I recently did this on my 720. I don't recall having a problem. From what I remember I opened the messaging app first, then went to the account settings to do the linking. When the message came I long-pressed on the back button and selected the messaging app, got the code then long-pressed back again and selected the window to enter the code.
    I've got same problem on my 920. Tried this approach, but when I when I long press to return to account settings to enter the validation code, it flips me to the account list. Really frustrating, because screen shows the account setup page requesting validation code entry - as soon as I select it to open - bam I'm back to start of accounts list.

    Seems like the only way to connect LinkedIn to Microsoft account is to have 2 factor authentication turned off in LinkedIn. Really don't want to do that if I can avoid it. I'm just coming over from Android, and this is first bug I've seen where WP is definitely lacking.
  12. Quitch's Avatar
    Member

    Posts
    8 Posts
       #12  
    I resolved this by logging into my Microsoft account on my computer and fixing the connection there. This then appears to propagate to my phone.
    Thanked by:
  13. MazoMark's Avatar
    Member

    Posts
    71 Posts
    Global Posts
    189 Global Posts
    #13  
    Quote Originally Posted by Quitch View Post
    I resolved this by logging into my Microsoft account on my computer and fixing the connection there. This then appears to propagate to my phone.
    Thanks! I did same and it worked for me too. One thing that surprised me - using this approach, I never got asked for validation code for LinkedIn, even though I have 2 factor authentication turned on!
  14. OzRob's Avatar
    Member

    Posts
    604 Posts
    Global Posts
    634 Global Posts
    #14  
    Quote Originally Posted by MazoMark View Post
    One thing that surprised me - using this approach, I never got asked for validation code for LinkedIn, even though I have 2 factor authentication turned on!
    You wouldn't if the computer you were using was a 'trusted' device for you LinkedIn account.
    Arie Vianza likes this.
  15. MazoMark's Avatar
    Member

    Posts
    71 Posts
    Global Posts
    189 Global Posts
    #15  
    Quote Originally Posted by OzRob View Post
    You wouldn't if the computer you were using was a 'trusted' device for you LinkedIn account.
    Duh😊 Of course!

Similar Threads

  1. Lumia 720 unable to connect to wifi
    By muhammed yazeen in forum Nokia Lumia 720
    Replies: 12
    Last Post: 10-25-2014, 01:20 AM
  2. How to upgrade Samsung SGH-i917 to Windows Phone 7.8
    By Alek Davis in forum Windows Phone 7
    Replies: 14
    Last Post: 01-23-2014, 02:47 AM
  3. New to the forums
    By Colby Lee in forum Introductions
    Replies: 6
    Last Post: 07-22-2013, 10:22 PM
  4. Why Windows Phone 8?? My Switch Pitch to a friend.
    By dalydose in forum Windows Phone 8
    Replies: 39
    Last Post: 07-06-2013, 01:42 PM
  5. Replies: 1
    Last Post: 06-27-2013, 08:02 AM

Posting Permissions