Get ready for beta!

Prepare for Halo Wars 2 Blitz Mode beta: Everything you need to know!

One Windows

Microsoft is building a new Windows 10 Shell for PC, Mobile and Xbox

On the Inside

Everything you need to know about the Xbox Insider Program

Beautiful compromises

Surface Studio review: you'll want one, even if you don't need one

3-in-1

Is this the Surface Phone? Microsoft awarded patents for foldable devices

Windows Central Offers

MCSE Certification bundle is just $39

Even more improvements

All the changes found in Windows 10 build 15007!

Games as a Service

What does the cancellation of Scalebound mean for future Xbox exclusives?

Windows Central Offers

Save $90 on these FRESHeBUDS Pro Magnetic Bluetooth Earbuds

Returning for 2017

We're back with an new episode of #AskDanWindows

Lifetime Subscription

VPNSecure is currently 91% off

Our favorite things

The Best of CES 2017 Awards

Infinity Edge in your hand

The XPS 13 2-in-1 is the Dell convertible we've always wanted

Project Valerie

Razer just made a laptop with three — THREE! — 17-inch 4K displays. 😱

Great design from Palo Alto

HP's CES 2017 releases are truly gorgeous PCs

Intel and Google's big day

CES 2017 Day Two: New laptops, new phones, and old ideas made new

Take five is better than ever

The updated Lenovo ThinkPad X1 packs Kaby Lake chips and zero bloatware

Everything we know about the next Xbox: Project Scorpio

UWPowered

'Game Mode' for Windows 10 will power Xbox One and Scorpio games too

Buyer's guide

Best accessories for Microsoft Surface Book

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Newfangled's Avatar
    Member

    Posts
    285 Posts
    Global Posts
    2,858 Global Posts
       #1  
    I've had my Lumia 521 for a few weeks, and over that time I've had 3 instances when I'm in an app, hit the power button to put the phone in sleep mode, and then the phone will not wake from sleep.

    2 instances were when I was using Nokia Here, and 1 was when I was using the camera.

    Do any other WP users experience this problem? Will a hard reset resolve it if you don't have a removable battery like the 521?
  2. stmav's Avatar
    Retired Moderator

    Posts
    3,685 Posts
    Global Posts
    3,767 Global Posts
    #2  
    I've only had it happen once after installing an app. A soft reset did the trick for me.

Similar Threads

  1. Ativ using loads of data
    By bristolbluebear in forum Samsung ATIV S
    Replies: 5
    Last Post: 07-17-2013, 09:54 AM
  2. Missing mesh on top of Lumia 920 after digitizer replacement
    By Cornelius in forum Nokia Lumia 920
    Replies: 2
    Last Post: 07-06-2013, 08:17 AM
  3. 8.1 Preview - Tegra 3 battery saver core enabled?
    By mrpuny in forum Microsoft Surface for Windows RT
    Replies: 4
    Last Post: 07-05-2013, 08:42 PM
  4. Happy 4th of July!
    By mase123987 in forum The "Off Topic" Lounge
    Replies: 2
    Last Post: 07-05-2013, 01:10 AM
  5. Replies: 1
    Last Post: 07-04-2013, 06:29 PM

Posting Permissions