01-01-2017 03:13 AM
60 123
tools
  1. Kimi Alin's Avatar
    Hey there! I was wondering if it's possible to force my Lumia 920 to use 3G only if it's available. My problem concerns situations when there are both 2G and 3G connections available and 3G signal is not so strong while 2G is much stronger, so phone prefers taking 2G signal, which means not been able to use internet at all. It also takes battery life when the phone is constantly switcing between 2G and 3G. I experience this issue a lot on some areas I visit a lot. For instance there are several places where there are these 2G amplifier towers nearby, which leads to no 3G-connection. This is annoying problem and I would like to solve it.
    08-25-2013 06:57 AM
  2. rockstarzzz's Avatar
    There is no field test menu accessibility any more after the recent update so you will be able to select highest connection speed but not the lowest. If you get an option (depends on your network provider) in settings -> cellular/mobile network -> highest connection speed to 2G or 3G - you can set that. But you can't set lowest connection speed or single G.
    08-25-2013 07:02 AM
  3. pankaj981's Avatar
    Well field test is still enabled on some Lumia models.

    OP: Dial ##3282# and see if you get something. If yes then please post back, if not then you're out of luck!
    08-25-2013 07:20 AM
  4. Kimi Alin's Avatar
    Well there is Field test on my phone but I don't understand anything about it What use it would it be for me?
    08-25-2013 08:10 AM
  5. pankaj981's Avatar
    Well there is Field test on my phone but I don't understand anything about it What use it would it be for me?
    ok then you can force 3g always on. Goto field test, click on three dots in the bottom and click settings, network type set to 3g only and click windows key and that's about it, now your phone is locked to 3g only. But you will lose signal when there is no 3g signal and then you will have to go back and set the network type to automatic. I hope this makes sense.

    Do post your results.
    08-25-2013 08:38 AM
  6. Kimi Alin's Avatar
    I found it and changed it to 3G but how do I confirm it? I mean after I did that and went back to metro and back to field test I saw it was on automatic again? Odd.
    08-25-2013 09:16 AM
  7. pankaj981's Avatar
    It does seem to stick but resets when you open the app again, check the network when you select 2G, the n/w resets and you see phone connected to E
    08-25-2013 09:47 AM
  8. Kimi Alin's Avatar
    Okay, it seems to be working but I can't really tell if it actually works since I have to test my mobile connection in common places I spend time and which have that problem but it looks like its forcing 3G at all times. So now if there is no 3G connection now, phone will not have any connection? Does it also mean I cannot call calls either? Well I will see that eventually. Thanks for your help!
    08-25-2013 11:26 AM
  9. pankaj981's Avatar
    Yes if you don't have 3g network then your phone wont connect to the network.
    08-25-2013 05:57 PM
  10. samzephyr's Avatar
    Hey there. Any luck with the field test mode access after the amber update. ##3282 or ##3282# does not seem to be working here either.
    08-28-2013 08:58 AM
  11. samzephyr's Avatar
    Any luck with ##3282 or whatever the new access code for field test? Any help is appreciated!
    08-28-2013 09:01 AM
  12. Corepc's Avatar
    Any luck with ##3282 or whatever the new access code for field test? Any help is appreciated!
    What phone do you have and what carrier ? some carrier may be blocking the feature. I can still access the field test mode on 521 (gdr2/amber).
    08-28-2013 09:41 AM
  13. waqqas31's Avatar
    Well field test is still enabled on some Lumia models.

    OP: Dial ##3282# and see if you get something. If yes then please post back, if not then you're out of luck!
    Field test is accessible on my Rogers Lumia 920 running OTA Amber.
    08-28-2013 09:43 AM
  14. Kimi Alin's Avatar
    I solved this problem with Field test which worked on my lumia 920 post-amber
    08-28-2013 09:45 AM
  15. samzephyr's Avatar
    What phone do you have and what carrier ? some carrier may be blocking the feature. I can still access the field test mode on 521 (gdr2/amber).
    Its an unlocked 820. Bought in india. Using airtel sim.
    08-29-2013 12:58 AM
  16. samzephyr's Avatar
    I solved this problem with Field test which worked on my lumia 920 post-amber
    Thats fantastic! What code did you use?
    08-29-2013 01:00 AM
  17. Kimi Alin's Avatar
    Thats fantastic! What code did you use?
    ##3282# as suggested by pankaj981 on the third post. After some use I have decided to change it back to automatic because my battery has started to drain faster. I don't know if that's the case but I will test if my battery lasts longer now.
    08-29-2013 07:27 AM
  18. samzephyr's Avatar
    Hey guys! Any luck with field test on lumia 820 GDR2. ##3282 not working after amber update. Kindly help.
    09-06-2013 09:44 AM
  19. samzephyr's Avatar
    Hi Pankaj. Any idea about the new code for the field test in lumia 820 after the amber update. ##3282 doesn't work out! Kindly reply.
    09-06-2013 11:55 AM
  20. thariqanwar's Avatar
    any code for amber updated phones, to 3g only
    09-28-2013 04:04 AM
  21. simran543's Avatar
    I solved this problem with Field test which worked on my lumia 920 post-amber
    Pls tell us the code .... Congrats
    09-30-2013 04:43 AM
  22. Kimi Alin's Avatar
    ##3282# as suggested by pankaj981 on the third post. After some use I have decided to change it back to automatic because my battery has started to drain faster. I don't know if that's the case but I will test if my battery lasts longer now.
    I said it a long time ago. ##3282 is the code I used. It worked for me.
    10-04-2013 05:08 AM
  23. FayadNazim's Avatar
    I have this exact problem of switching between 3g and 2g in my lumia720 amber.

    The problem has become severe after the gdr2+amber update. Even a slight variation in 3g signal will make the phone switch to 2g. Now I cannot use 3G because of this issue.

    This field test code isn't working either. Any other solutions?

    Sent from my Lumia 720 using Tapatalk
    10-04-2013 05:23 AM
  24. dennis5pia's Avatar
    Field test work on my Lumia 822. But 3G only setting doesn't work, I set up 3G only, hit the windows key and it stay on EDGE.
    10-11-2013 09:43 AM
  25. octa4ocha's Avatar
    Please help me to force only on 3g network my lumia 620
    10-13-2013 09:13 AM
60 123

Similar Threads

  1. Transfering Playlists from Windows 8 Music App to Windows Phone
    By Erik Walther in forum Windows Phone 8
    Replies: 15
    Last Post: 03-31-2014, 05:58 AM
  2. Replies: 13
    Last Post: 09-14-2013, 11:01 AM
  3. Replies: 3
    Last Post: 08-25-2013, 02:36 PM
  4. WiFi channel checker for WP
    By pr0phecy in forum Windows Phone 8
    Replies: 2
    Last Post: 08-25-2013, 09:57 AM
  5. Save numbers to Exchange instead of Hotmail
    By Kimboo in forum Windows Phone 8
    Replies: 2
    Last Post: 08-25-2013, 06:05 AM
LINK TO POST COPIED TO CLIPBOARD