Windows goes galactic

Revealed: Samsung's Surface Pro-like Galaxy Book, running Windows 10

Saving money on data

Mint SIM is the perfect way to get cheap data in the U.S.

We made some changes

Our new forums are here!

Don't count Windows Phone out just yet

Dead? Psh. Here are 5 reasons to stick with Windows 10 Mobile

VPN vs. Proxy

The difference between a proxy and a VPN

Latitude attitude

Dell Latitude 7280 is a business laptop with tons of consumer attitude

4K all the way

You probably don't NEED a 4K webcam, but we love Logitech's BRIO 4K anyway

Long live Windows phone

Contrary to popular belief, Windows phone won't die anytime soon

XP-YESSSSSSS

Dell's already awesome XPS 15 gets even better in 2017

Surface Pwn 5

Surface Pro 5, Project NEON details leaked on LinkedIn?

Redefining the PC

Why Microsoft's Surface phone could be MUCH more than a mere 'phone'

Surface table meets Windows 10

Yes, we did put Windows 10 on the original Surface table ... and it rocks

Cream o' the crop

Before buying a Microsoft laptop, check out our pick for the absolute best

Simple and secure, just the way I like it

We think Windows 10 Cloud is a great idea, here's why

uber micro

Halo Wars 2 has something for everyone. Here's our full review.

Oldie but goldie

We reviewed Microsoft's decade-old Surface table

Creators Update comin' at ya

These are the coolest new features in the next big Xbox One update (video)

Buyer's guide

The Razer Blade 14 is the best laptop Razer has to offer

Windows 10 app gems

10 terrific Windows 10 apps you should be using

Tower of power

Here's what we think of Dell's XPS Tower Special Edition

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. vanstatten's Avatar
    Member

    Posts
    3 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #1  
    Im trying to register to echoecho app,
    somehow after i send sms message, back in app stucks on completing registration screen and says cant register at all

    it seems its an issue with wp8 or 920 itself because i can register with lumia 900 without any problems

    anyone else experiencing this weird problem?
  2. Eric Hon's Avatar
    Member

    Posts
    30 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #2  
    hmm, I get new phone on Monday and heavily use echoecho. I will check it out and report back. I wish this app could be updated to be on par with Android's.
  3. vanstatten's Avatar
    Member

    Posts
    3 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #3  
    well i tried to register with 2 different lumia 920's on 2 different operators,
    i did get in touch with the app developers,
    they couldn't figure it out..,
    so i believe its either wp8 handles push notifications differently or lumia 920 have some kind of settings for push notifications..
    if someone can try to register echoecho on lumia 920 on wp8 and can register successfully and able to use app pls let me know...
    im trying to pinpoint this problem since last week.. and it pretty drives me crazy..
  4. Spdracer's Avatar
    Member

    Posts
    32 Posts
    Global Posts
    136 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #4  
    I have echoecho on my Lumia 920. I use it but it doesn't seem to be very accurate. I've registered multiple times on both the 920 and 820
  5. vanstatten's Avatar
    Member

    Posts
    3 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #5  
    hmm thanks,
    that makes everything more weird...

Similar Threads

  1. Replies: 18
    Last Post: 06-30-2012, 02:54 AM
  2. Anyone having problems with the auto brightness?
    By btbam91 in forum Samsung Focus S 4G
    Replies: 13
    Last Post: 11-08-2011, 06:44 PM
  3. Anyone else having problems with groups?
    By GekkoAce in forum Windows Phone 7
    Replies: 1
    Last Post: 10-12-2011, 09:36 PM
  4. Anyone have the same problem with pictures?
    By Trader05 in forum HTC Arrive / 7 Pro
    Replies: 4
    Last Post: 04-15-2011, 09:55 PM
  5. Anyone having problems with playing YouTube videos?
    By netkodrugi in forum Windows Phone 7
    Replies: 2
    Last Post: 03-15-2011, 02:38 AM

Posting Permissions

";