Cut the jargon

What exactly is monitor refresh rate? And what rate is ideal?

Cube stylin'

Lenovo's IdeaCentre Y710 Cube PC is equally stylish and BADASS

Biometrics FTW

These are all the laptops that support Windows Hello

Can you handle the truth?

What Apple's latest iPad ads say about Microsoft and Windows

Drop it like it's hot

Panasonic's Toughbook CF-33 is a ridiculously rugged 2-in-1

Saving money on data

Mint SIM is the perfect way to get cheap data in the U.S.

Forecast is cloudy

Windows 10 Cloud will run Win32 apps, but only from the Windows Store

Excessive in a good way

GTX 1050 in a 15-inch convertible? Lenovo went there

Windows goes galactic

Revealed: Samsung's Surface Pro-like Galaxy Book, running Windows 10

We made some changes

Our new forums are here!

Don't count Windows Phone out just yet

Dead? Psh. Here are 5 reasons to stick with Windows 10 Mobile

VPN vs. Proxy

The difference between a proxy and a VPN

Latitude attitude

Dell Latitude 7280 is a business laptop with tons of consumer attitude

4K all the way

You probably don't NEED a 4K webcam, but we love Logitech's BRIO 4K anyway

Long live Windows phone

Contrary to popular belief, Windows phone won't die anytime soon

XP-YESSSSSSS

Dell's already awesome XPS 15 gets even better in 2017

Surface Pwn 5

Surface Pro 5, Project NEON details leaked on LinkedIn?

Redefining the PC

Why Microsoft's Surface phone could be MUCH more than a mere 'phone'

Surface table meets Windows 10

Yes, we did put Windows 10 on the original Surface table ... and it rocks

Cream o' the crop

Before buying a Microsoft laptop, check out our pick for the absolute best

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 13 of 13
  1. afgzee's Avatar
    Member

    Posts
    609 Posts
    Global Posts
    686 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #1  
    Does this app crash for anyone? Its been crashing since yesterday for me... Tried reinstalling which didn't fix the issue.
  2. CopaCC's Avatar
    Member

    Posts
    86 Posts
    Global Posts
    88 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #2  
    I was about to start a thread for the same thing. I've had my 521 for two weeks now and Speedtest has worked great until this morning. It loads, says it looking for the server for a few seconds, then goes back to the Start screen. Glad to hear it's not just me!
  3. Corepc's Avatar
    Member

    Posts
    1,333 Posts
    Global Posts
    1,335 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #3  
    Same here has well, speedtest crashes on startup, was working fine yesterday, lumia 521.
  4. cybodroid's Avatar
    Member

    Posts
    105 Posts
    Global Posts
    106 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #4  
    Same
  5. joshredraider's Avatar
    Member

    Posts
    27 Posts
    Global Posts
    31 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #5  
    Same here. Lumia 920. Tried re-installing twice, still no go.
  6. CopaCC's Avatar
    Member

    Posts
    86 Posts
    Global Posts
    88 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #6  
    Working again. :)
  7. mslek's Avatar
    Member

    Posts
    6 Posts
    Global Posts
    7 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #7  
    Mine still crushes. Did you do anything, or did it start working by it self?
  8. ravi72munde's Avatar
    Member

    Posts
    11 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #8  
    I had the same issue with my lumia 620, worked like a charm for a month and suddenly started crashing. Re-installing didnt work for me either. So I tried something different. I uninstalled few more apps(just 2 honestly) and then installed speedtest.net. To my surprise it started working. I had same issue with wpcentral app did the same there. It seems to work. Maybe some memory problem. Hope this helps you.
    mslek likes this.
  9. mslek's Avatar
    Member

    Posts
    6 Posts
    Global Posts
    7 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #9  
    Tried uninstalling couple of apps and speedtest is working again. Doesn't make any sense, but like you said, it's maybe a memory problem.
  10. CopaCC's Avatar
    Member

    Posts
    86 Posts
    Global Posts
    88 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #10  
    I didn't install or uninstall anything. Just waited a few hours and tried again.
  11. Kevin Harvell's Avatar
    Member

    Posts
    92 Posts
    Global Posts
    412 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #11  
    Have not noticed any issues with it running on the Lumia 928 I'm testing. Just ran a few tests to confirm.

    Anyone else still having issues?
  12. Corepc's Avatar
    Member

    Posts
    1,333 Posts
    Global Posts
    1,335 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #12  
    Working now here has well
  13. afgzee's Avatar
    Member

    Posts
    609 Posts
    Global Posts
    686 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #13  
    Still not working here for me. Tried reinstalling.

Similar Threads

  1. Speedtest.net
    By Cartman in forum Nokia Lumia 900
    Replies: 8
    Last Post: 01-29-2013, 12:15 PM
  2. "phone" app crashing / won't open
    By Mr_pither in forum Samsung Focus S 4G
    Replies: 5
    Last Post: 02-22-2012, 12:20 AM
  3. Camera App Crashing
    By stoogefandave in forum HTC TITAN
    Replies: 5
    Last Post: 12-09-2011, 11:05 PM
  4. Replies: 3
    Last Post: 11-27-2011, 07:38 AM

Posting Permissions

";