The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
05-01-2018 09:18 PM
207 123 ...
tools
  1. nate0's Avatar
    Can you provide your experience or feedback while using it with the AT&T carrier?

    I expect no HD voice/VoWiFi or Enhanced LTE services as this goes for all unlocked windows phones on AT&T. AT&T only last week announced interoperability with LTE band 12 was a go so I'm curious now how that will play out with this device. LTE band 12 as far I remember is limited in my area, but it won't be that way forever. I would like to acquire and use the Idol 4s soon.

    Any difference besides carrier software between a sim unlocked version or the factory unlocked?

    Thank you!
    Last edited by Nate W; 01-20-2018 at 11:58 PM.
    01-21-2017 11:02 PM
  2. editguy's Avatar
    I'm not on AT&T so I can't answer your first questions. But as to the differences between the Tmo version and the unlocked, I'm fairly confident that the only difference*between the two is the Tmo software and that it says T-Mobile on the splash screen while booting up. There is no T-Mobile branding on the exterior of the phone. But none of that answers your major questions
    libra89 and RumoredNow like this.
    01-21-2017 11:42 PM
  3. nate0's Avatar
    For those interested in purchasing the unlocked model from Microsoft I wanted to share this info. I'm not certain about the bands supported on the T-Mobile Variant but the unlocked model shows some additional bands listed.
    02-13-2017 11:15 AM
  4. nate0's Avatar
    Here is some updated information.

    Been using this on AT&T since Monday. I am still in support with AT&T at the moment on this, but so far so good. Here is what I mean by this. I will start by adding first that AT&T does not have this device type registered on their network yet. The IMEI shows up as unknown make and model. I spent several days trying to get this taken care of and today I had a break through, which is good. So, if you already using an AT&T Android or Windows 10 phone, meaning it is certified for AT&T, and then you pop that sim out and into your new IDOL 4s it work right out of the box with no issues...same for if you are using an AT&T iphone...however this minus the Enhanced 4g LTE services. That is because the IMEIs for the idol 4s atleast the unlocked ones are not in their "database". It could maybe even be my IMEI subset, but I asked the support admin if I could be the guinea pig here, and he pretty much nodded. Stated once he gets the request in for my imei/make/model and it is active then all subset imei numbers matching that device will provision as well. Technically Enhanced 4G LTE services are not suppose to provision for Unlocked AT&T phones, but I guess I will see later.

    Everything was so far so good until they tried to update my IMEI on my account today and now I have no LTE data and no Voicemail. Not so bad for now as he said it should be in the next 24hrs that this is fixed.
    02-15-2017 06:42 PM
  5. nate0's Avatar
    I will add that I have had full LTE bars almost every where. Which is odd considering my iphone 6s plus, s7 Edge, and others always had less (1-2 bars) at my job place. Which is near the South Mountain area in Phoenix. I am really impressed so far on the LTE reception while on AT&T with this phone!
    02-15-2017 06:47 PM
  6. editguy's Avatar
    I will add that I have had full LTE bars almost every where. Which is odd considering my iphone 6s plus, s7 Edge, and others always had less (1-2 bars) at my job place. Which is near the South Mountain area in Phoenix. I am really impressed so far on the LTE reception while on AT&T with this phone!
    I'm in East Mesa on T-Mobile and I'm getting much better reception than I did on any phone before this. It is encouraging to see that you are too and on a different carrier.
    02-15-2017 07:54 PM
  7. nate0's Avatar
    I'm in East Mesa on T-Mobile and I'm getting much better reception than I did on any phone before this. It is encouraging to see that you are too and on a different carrier.
    Yes. At first I thought it had to do with AT&T's recent update to band 12 interoperability. Which could be your coverage boost too, unless the T-Mobile model does not include band 17.
    02-15-2017 07:57 PM
  8. editguy's Avatar
    Yes. At first I thought it had to do with AT&T's recent update to band 12 interoperability. Which could be your coverage boost too, unless the T-Mobile model does not include band 17.
    Tmo model does have band 12.
    02-15-2017 08:08 PM
  9. nate0's Avatar
    Tmo model does have band 12.
    Yes. Which the model I have does too. The model also shows band 17 which is good. Meaning since AT&T can inter-operate using their Band 17 and band 12, could then explain the better coverage I have. I was not certain though if I had to leave roaming enabled to help the phone do better or not. But at the current time am just trying to fix the imei/model mismatch mishap.
    02-15-2017 08:15 PM
  10. HoosierDaddy's Avatar
    I will add that I have had full LTE bars almost every where. Which is odd considering my iphone 6s plus, s7 Edge, and others always had less (1-2 bars) at my job place. Which is near the South Mountain area in Phoenix. I am really impressed so far on the LTE reception while on AT&T with this phone!
    I haven't got a SIM in mine yet (getting it all set up first) so don't know about LTE strength yet but the WiFi strength indicators on mine fluctuate between 1 and 2 bars LESS than my 950XL sitting beside it. The 950XL has all bars (arcs?) where the phones are (not near the router).
    02-15-2017 09:20 PM
  11. nate0's Avatar
    I haven't got a SIM in mine yet (getting it all set up first) so don't know about LTE strength yet but the WiFi strength indicators on mine fluctuate between 1 and 2 bars LESS than my 950XL sitting beside it. The 950XL has all bars (arcs?) where the phones are (not near the router).
    Yep same here. I get less on the 5ghz (bars) then I did on the 950. Might be the metal or antenna setup? I only notice it when I am on the opposite end of the house from the wifi router.
    02-15-2017 09:21 PM
  12. jes1888's Avatar
    I have an Elite 3 with att and my history is like yours, my account shows unrecognized phone,I do have visual voicemail and lte on my phone, with the average speed are around 18mb download and 3mb upload. Disappointing if you ask me since I have seen phones reach the 50mb down mark. Att store rep put apn settings of an IPhone 7 and galaxy s7 with still same speeds as the default apn, so that's not it. A thing I've noticed is that in my phone sometimes the LTE icon switches between LTE and LTE+ very quickly sometimes, like 12-15 times in a space of 8 seconds while other moments like now that the phone has been all the time on regular LTE. Curious if that phone model does the same. Added picture of Speed test history.


    Sent from mTalk
    RumoredNow likes this.
    02-15-2017 10:03 PM
  13. nate0's Avatar
    I have an Elite 3 with att and my history is like yours, my account shows unrecognized phone,I do have visual voicemail and lte on my phone, with the average speed are around 18mb download and 3mb upload. Disappointing if you ask me since I have seen phones reach the 50mb down mark. Att store rep put apn settings of an IPhone 7 and galaxy s7 with still same speeds as the default apn, so that's not it. A thing I've noticed is that in my phone sometimes the LTE icon switches between LTE and LTE+ very quickly sometimes, like 12-15 times in a space of 8 seconds while other moments like now that the phone has been all the time on regular LTE. Curious if that phone model does the same. Added picture of Speed test history.
    http://i.imgur.com/Q7JacKr.jpg

    Sent from mTalk
    The X3 has Cat 4 LTE just like the IDOL 4s. Except it is LTE-A capable (LTE+/LTE Advanced) unlike the IDOL. Yet my X3 registered just fine. He even saw the history of my last like 5 devices on my account which included the X3. The difference here for my IDOL 4s was that they have nothing on it. Which means either Alcatel has not submitted the IMEI subset to AT&T yet or in this case I need to be one to tell them and then they can build it manually.
    Last edited by Nate W; 02-16-2017 at 05:46 PM.
    02-15-2017 10:08 PM
  14. editguy's Avatar
    Yep same here. I get less on the 5ghz (bars) then I did on the 950. Might be the metal or antenna setup? I only notice it when I am on the opposite end of the house from the wifi router.
    That's interesting, because I'm getting better Wi-Fi reception then I did with my other phones. It's strange how with all cell phones we have somewhat different experiences.
    libra89 and RumoredNow like this.
    02-15-2017 11:30 PM
  15. jes1888's Avatar
    The X3 has Cat 6 LTE just like the IDOL 4s. Except it is LTE-A capable (LTE+/LTE Advanced) unlike the IDOL. Yet my X3 registered just fine. He even saw the history of my last like 5 devices on my account which included the X3. The difference here for my IDOL 4s was that they have nothing on it. Which means either Alcatel has not submitted the IMEI subset to AT&T yet or in this case I need to be one to tell them and then they can build it manually.
    So on your elite, can your see the lte+ sign all the time or does it switch back and forth between lte+ and LTE like mine does? Also, how do you register your device correctly on their system? (at&t) My device appears as unknown and a family member 950 dual sim unlocked also appears as unknown and would like to correct that. Previously i had a 950xl and also appeared as unknown.


    Sent from mTalk
    02-16-2017 05:49 AM
  16. nate0's Avatar
    So on your elite, can your see the lte+ sign all the time or does it switch back and forth between lte+ and LTE like mine does? Also, how do you register your device correctly on their system? (at&t) My device appears as unknown and a family member 950 dual sim unlocked also appears as unknown and would like to correct that. Previously i had a 950xl and also appeared as unknown.


    Sent from mTalk
    Unlocked phones on AT&T will show that way. But anytime you set your sim card in a phone that you were not using before, they suggest you call support and update your IMEI of that phone you are using on their end. If you are not having any issues I would not mess with it. However if you want to check or just update that info with them anyway, you have to call in and give that information to AT&T to update.
    libra89 likes this.
    02-16-2017 08:18 AM
  17. jes1888's Avatar
    Unlocked phones on AT&T will show that way. But anytime you set your sim card in a phone that you were not using before, they suggest you call support and update your IMEI of that phone you are using on their end. If you are not having any issues I would not mess with it. However if you want to check or just update that info with them anyway, you have to call in and give that information to AT&T to update.
    I don't really care how the phone appears on the system, unless I get better LTE speeds or whatever, I just wanna know how to allow the phone to get LTE+ all the time, and if anyone else with a elite x3 on at&t have had the same issue about LTE (+) plus sign switching back and forth quickly

    Sent from mTalk
    02-17-2017 08:11 AM
  18. nate0's Avatar
    Good news. They (AT&T) should have the imei set updated in their master table for the Idol 4s LTE device by some time Friday. It took much longer than usual since this was not a type of device they already carried that was unlocked (S7/LG etc.).
    RumoredNow, fpetro22 and libra89 like this.
    02-23-2017 12:53 PM
  19. nate0's Avatar
    Anyone else ever experience a high pitched screetch when answering a call or if your call is answered? For me, its not new...I've had this issue only on unlocked phones (non-AT&T) with W10M while using them on AT&T. Wondering if there's a way around that. Or if anyone knows what causes it. At one point I thought it was still related to the bug seen over year ago, which I thought was related to Cortana...

    When using a AT&T Lumia 950 or 830, it never occurs. I could only relate it back to the Modem and enhanced LTE services enabled on those and not the unlocked models.

    It does not happen that often but when it does it catches me off guard. I know it's not this device, because it's happened on my unlocked 950 and 950xl when I had them. The Elite X3 did it too.
    03-10-2017 01:15 AM
  20. HoosierDaddy's Avatar
    Anyone else ever experience a high pitched screetch when answering a call
    I used to, until I got a restraining order against her.

    I would ask AT&T about that if it just happens with unbranded W10 phones.
    TgeekB, nate0, editguy and 1 others like this.
    03-10-2017 05:37 AM
  21. fpetro22's Avatar
    Yep. Using unlocked Idol 4S. Seems to only happen to me when i call an iPhone.
    03-10-2017 08:26 AM
  22. fpetro22's Avatar
    Anyone else ever experience a high pitched screetch when answering a call or if your call is answered? For me, its not new...I've had this issue only on unlocked phones (non-AT&T) with W10M while using them on AT&T. Wondering if there's a way around that. Or if anyone knows what causes it. At one point I thought it was still related to the bug seen over year ago, which I thought was related to Cortana...


    When using a AT&T Lumia 950 or 830, it never occurs. I could only relate it back to the Modem and enhanced LTE services enabled on those and not the unlocked models.

    It does not happen that often but when it does it catches me off guard. I know it's not this device, because it's happened on my unlocked 950 and 950xl when I had them. The Elite X3 did it too.


    Yep. Using unlocked Idol 4S. Seems to only happen to me when i call an iPhone.
    03-10-2017 08:27 AM
  23. nate0's Avatar
    Ya I notice it when calling my wife who too has had an iPhone the past couple years.
    RumoredNow likes this.
    03-10-2017 08:33 AM
  24. RumoredNow's Avatar
    ...my wife who too has had an iPhone the past couple years.
    Mine has a Samsung. The things we put up with, huh?

    editguy and nate0 like this.
    03-11-2017 12:22 PM
  25. jes1888's Avatar
    Lol! ^ Mine also has an IPhone 6+ in the last year and at the same time I've had the 950xl ( my 1st unlocked and now the X3) and haven't noticed any of this, will verify and I'll let you know, we both are on AT&T also by the way. What do you meant by adding the phone to the master tables ?
    Last edited by jes1888; 03-13-2017 at 03:28 PM.
    03-13-2017 03:05 PM
207 123 ...

Similar Threads

  1. Does your Facebook app autoplay video in the news feed?
    By Chubbynaga in forum Microsoft Lumia 950
    Replies: 6
    Last Post: 02-16-2017, 10:10 AM
  2. Works with T-Mobile Digits Beta!
    By Chubbynaga in forum Microsoft Lumia 950
    Replies: 3
    Last Post: 01-26-2017, 06:44 PM
  3. Will there be any new phones that come with a PureView camera?
    By TechJunkie81 in forum Windows 10 Mobile
    Replies: 5
    Last Post: 01-26-2017, 04:18 PM
  4. Viber for Windows 10 scores a*huge update with design improvements in tow
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-21-2017, 03:20 PM
  5. my nokia phone turns of and on by itself
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-21-2017, 02:02 PM
LINK TO POST COPIED TO CLIPBOARD