1. Aden Rossinni's Avatar
    Hi All, having problems with my Idol 4s with the IMS: not registered. I purchased it at Amazon and it's not getting data. Tried setting APN etc, called my provider, sit's not the sim, called Microsoft, no help at all, no help from Alcatel. WTF!!
    Does anyone know what I can do? As I purchased in the US and had it sent to Australia.
    04-30-2017 10:05 PM
  2. ttsoldier's Avatar
    Does the phone support the bands used by your carrier?
    RumoredNow likes this.
    05-01-2017 05:05 AM
  3. jay_max's Avatar
    We purchase three of these from T-Mobile (TMO-branded, not unlocked) to use on T-Mobile's network and ALL of them have been having frequent IMS registration issues which results, in part, in not being able to connect voice calls over LTE.
    ttsoldier likes this.
    05-01-2017 11:44 AM
  4. nate0's Avatar
    The T-Mobile model has specific FW baked into the OS to make it work and be optimized for T-Mobile in the States. The Amazon model (NA unlocked) is specific to N. America (Canada and US) it has LTE bands 2,4,5,7,12,17. IMS is the IP multimedia subsystem for carrier VoLTE, data, media, etc. services. You could get Data without IMS registration. In fact it is strictly up to the carrier on which IMEI/Devices they allow to be provisioned for IMS on their networks.
    libra89 likes this.
    05-01-2017 11:13 PM
  5. nate0's Avatar
    We purchase three of these from T-Mobile (TMO-branded, not unlocked) to use on T-Mobile's network and ALL of them have been having frequent IMS registration issues which results, in part, in not being able to connect voice calls over LTE.
    Wonder if your issue is a result of something on T-mobiles end?
    05-01-2017 11:22 PM
  6. nate0's Avatar
    Hi All, having problems with my Idol 4s with the IMS: not registered. I purchased it at Amazon and it's not getting data. Tried setting APN etc, called my provider, sit's not the sim, called Microsoft, no help at all, no help from Alcatel. WTF!!
    Does anyone know what I can do? As I purchased in the US and had it sent to Australia.
    What carrier sim card is in it that you are having no data connection with?
    05-01-2017 11:23 PM
  7. jay_max's Avatar
    Wonder if your issue is a result of something on T-mobiles end?
    Yeah, I figure its is either something on TMO's end or some type of bug in W10 Mobile. Not sure, but it is annoying as hell. The device itself seems really solid.
    05-02-2017 12:47 PM
  8. Iain_S's Avatar
    Yeah, I figure its is either something on TMO's end or some type of bug in W10 Mobile. Not sure, but it is annoying as hell. The device itself seems really solid.
    everything is annoying about the 4s, they cant even put a recovery image on wdrt that ******* works. NO SUPPORT whatsoever from anyone involved with this phone.
    05-08-2017 05:46 PM
  9. nate0's Avatar
    Yeah, I figure its is either something on TMO's end or some type of bug in W10 Mobile. Not sure, but it is annoying as hell. The device itself seems really solid.
    It is a platform ID mismatch between what the FFU file expects compared to what is on your Open Market phone.
    05-08-2017 08:59 PM
  10. jay_max's Avatar
    It is a platform ID mismatch between what the FFU file expects compared to what is on your Open Market phone.
    Mine is T-Mobile branded.
    05-09-2017 02:12 PM
  11. nate0's Avatar
    That is the messed up part. Even the T-Mobiles fail to flash, but is expected if you think about it. They are meant for the carrier based ROM.

    The FFU itself is the problem from what I know...so far all the IDOL 4s phones have the same PLAT ID, it is just the Open Market FFU that needs the NA trailed on the Open market devices. Both the T-Mo and Open Market phone PLAT IDs are the same. ALCATEL.8996.IDOL4S. The FFU is expecting ALCATEL.8996.IDOL4S.NA
    RumoredNow likes this.
    05-09-2017 08:14 PM
  12. lachutm's Avatar
    I just purchase Unlocked Idol 4 S from Microsoft (99$) and IMS services are enabled with T-Mobile. HD Voice is working. I can't find how to enabled WiFi calling.
    01-10-2018 09:26 PM
  13. martzelx's Avatar
    Hello,
    I have also bought it on Microsoft US store for 99$, and it is a good phone (for remplacing my older Lumia 950) but I have problems with MMS.
    I live in France and my carrier is Bouygues Telecom. I have called them but no help because the phone is coming from US.
    I have tried many APN settings and the best I can do is sending MMS but not receiving them. Is there a solution ?
    Thanks for advance.
    02-17-2018 03:49 AM
  14. Palm_forlackofchoice's Avatar
    This is not a fix, just work around. Have you tried using Skype? Due to phone being North America model you may not get native mms to receive.
    02-17-2018 04:39 PM
  15. midnightfrolic's Avatar
    you can try the XDA website and try installing the other firmware, Open FFU. I had 4s for about a week and did that. works fine in TMobile.
    02-17-2018 10:10 PM
  16. Aden Rossinni's Avatar
    In the end, I loved the phone but couldn't get it to work and had to send it back. Felt very disappointed as he hardware was very nice.
    02-17-2018 10:57 PM
  17. martzelx's Avatar
    Hi,
    Thanks for your help, but Skype is just another Messsaging app but use the same settings.
    I've tried and I had the same errors.
    02-18-2018 12:24 PM
  18. martzelx's Avatar
    My phone is already a OpenMarket version, but this ROM does not contains original settings of my carrier.
    I have compare the FFU of the OpenMarket version and the FFU of the Idol 4 Pro (the Europe version of 4S) and this last one contains all european carriers settings, but it seems that it is not possible to push it on our US phones because 4G bands are not the same.

    You have reset your phone with XDA Tools or WDRT?
    02-18-2018 12:31 PM
  19. Palm_forlackofchoice's Avatar
    You are correct about Skype except it can work over cellular or wifi. Meaning you would have functionality when connected to wifi as a temporary work around until you find a solution for the cellular data.
    02-18-2018 02:27 PM

Similar Threads

  1. Replies: 22
    Last Post: 01-14-2018, 11:45 AM
  2. Replies: 6
    Last Post: 05-03-2017, 12:44 AM
  3. Windows 10 Mobile creators update not received
    By Muhammad Tarique1 in forum Windows 10 Mobile
    Replies: 5
    Last Post: 05-02-2017, 01:38 PM
  4. Why my WhatsApp images are not getting saved in photos
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-01-2017, 07:58 AM
  5. Why is my Alcatel One Touch Spazing?
    By mstalter36 in forum Alcatel OneTouch Fierce XL
    Replies: 1
    Last Post: 04-30-2017, 06:42 PM
LINK TO POST COPIED TO CLIPBOARD