The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. SharpFranz's Avatar
    Hi all, I connected my new Idol 4S to HD500 display dock (which was working fine for last 2 years with my Lumia 950XL) and unfortunately after many beeps and sounds I cannot get it to work. It seems like it is detecting something but without success. Even more, few days ago after connecting it to HD500 phone was freezing/stuttering. Today I tried one more time and that issue is gone (for now) but the phone still doesn't cooperate with my display dock. Anybody knows what is the problem?
    BTW: I have driver 4.0.0 for HD500 and latest build for the phone (with patch from January'18).
    I live in Europe and it will take me some time to get back to USA to "solve" the problem using Microsoft store...
    01-14-2018 01:01 PM
  2. kaktus1389's Avatar
    Are you using any adapters for the display or is it just a usual HDMI cable? I sometimes have difficulties with 950 and I am using DVI to HDMI cable (not an adapter) and it works fine most of the time. When it doesn't work I try reconnecting the phone or the display to the display dock and it solves the issue. I would start with doing that if you haven't yet, other than that I don't know if there's much that you can do, maybe try tweaking around with the dock in the gadgets app.
    If the above doesn't help, try using it with a different monitor - I used a monitor that's probably like 10 years old and is capable of 1024*1280 resolution but I got like 480p Continuum running on it and it didn't support Netflix.
    SharpFranz likes this.
    01-14-2018 03:03 PM
  3. SharpFranz's Avatar
    Thank you very much - that was the case! I was connecting to old Samsung via HDMI but I forgot monitor had only DVI input and that is not gonna work.
    Now interesting thing is that after connecting to the second monitor (DELL with 4 inputs) via HDMI I was receiving windows/system errors saying there is NO audio device. I then changed cable to the one I received with Xbox One S and now all is fine. I mean I have sound on my phone at least... Yes, would be good to have it on my DELL but maybe that is another few minutes of testing with different cables.
    Unless this is not possible?
    So next question would be: is there any cable/standard that would give sound on external monitor - do you guys have it configured like that?

    Thanks again kaktus1389!
    Last edited by SharpFranz; 01-14-2018 at 03:46 PM. Reason: misspell
    kaktus1389 likes this.
    01-14-2018 03:45 PM
  4. kaktus1389's Avatar
    Thank you very much - that was the case! I was connecting to old Samsung via HDMI but I forgot monitor had only DVI input and that is not gonna work.
    Now interesting thing is that after connecting to the second monitor (DELL with 4 inputs) via HDMI I was receiving windows/system errors saying there is NO audio device. I then changed cable to the one I received with Xbox One S and now all is fine. I mean I have sound on my phone at least... Yes, would be good to have it on my DELL but maybe that is another few minutes of testing with different cables.
    Unless this is not possible?
    So next question would be: is there any cable/standard that would give sound on external monitor - do you guys have it configured like that?

    Thanks again kaktus1389!
    No problem mate, glad you solved your issue :)

    Now I have no experience with Continuum with monitors that also support sound, but I was able to get the sound working on a Panasonic TV just fine with an HDMI cable. I am not 100% sure but once you get Continuum up and working, try to launch Continuum app on your phone and check settings there - I am not 100% sure about that but it could be there. Other than that I would try to tweak settings on the monitor itself. Perhaps you should try another HDMI cable if none of the above helps, maybe there's an issue with the one you have.
    SharpFranz likes this.
    01-14-2018 04:17 PM
  5. SharpFranz's Avatar
    So as I suspected it is a matter of invalid/missing drivers in Idols 4S. I cannot confirm 100% percent but after testing with lots of cables here is what I found: Idols 4S is very sensitive when it comes to plugs. WIth the "best" cable I have I was only able to get it to work. With any HDMI my old Lumia 950 XL gives sound on external device. With HDMI->Analog DVI I can get image.
    Idols 4S on the other hand with my "best" cable/combination gives me only image and I was unable to get sound no matter what... Maybe interop unlocking with new 2.3 tool solves the problem but I am really far from it at least for now.
    If someone gets voice on external device with Idol 4S please let me know.
    Thanks!
    kaktus1389 likes this.
    01-15-2018 02:31 PM
  6. Dono Newcomb's Avatar
    I think someone else was having an issue with this problem. Not sure if anything ever came of it, or how accurate the info is.

    https://forums.windowscentral.com/wi...l-idol-4s.html

    Sounds to me that maybe he was thinking there was a firmware update for the dock itself, but that he needed the "Microsoft Gadgets App" which I am guessing is only available to install on Microsoft devices. But if it is a fix, maybe you can find a friend with a Microsoft phone and use that to update the firmware.
    I heard of altering the registry to install certain apps and updates but not sure how safe that would be.
    01-16-2018 10:12 AM

Similar Threads

  1. Little help please?
    By joshbtnik in forum Microsoft Surface Pro 3
    Replies: 4
    Last Post: 01-14-2018, 04:38 AM
  2. Little help please?
    By joshbtnik in forum Microsoft Surface Pro (2017)
    Replies: 2
    Last Post: 01-13-2018, 04:09 AM
  3. IseeVM no longer working on my 950XL?
    By mtf1380 in forum Microsoft Lumia 950 XL
    Replies: 6
    Last Post: 01-11-2018, 10:01 AM
  4. Surface dock stopped working after update ( 9th JAN 18)
    By David Gohar in forum Microsoft Surface Book
    Replies: 0
    Last Post: 01-10-2018, 10:37 AM
  5. continuum and transfering files
    By ochhanz in forum Ask a Question
    Replies: 0
    Last Post: 01-10-2018, 10:21 AM
LINK TO POST COPIED TO CLIPBOARD